diff mbox series

[1/1] package/tzdata: install leap-seconds.list into results

Message ID 20221027203039.1004439-1-dave-git@centerclick.org
State Accepted
Headers show
Series [1/1] package/tzdata: install leap-seconds.list into results | expand

Commit Message

David Johnson Oct. 27, 2022, 8:30 p.m. UTC
add leap-seconds.list to installed files so it can be used by other packages

specifically, ntpd's ntp.conf can now include:
leapfile /usr/share/zoneinfo/leap-seconds.list

Signed-off-by: David Johnson <dave-git@centerclick.org>
---
 package/tzdata/tzdata.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 28, 2022, 6:45 a.m. UTC | #1
On Thu, 27 Oct 2022 16:30:39 -0400
David Johnson via buildroot <buildroot@buildroot.org> wrote:

> add leap-seconds.list to installed files so it can be used by other packages
> 
> specifically, ntpd's ntp.conf can now include:
> leapfile /usr/share/zoneinfo/leap-seconds.list
> 
> Signed-off-by: David Johnson <dave-git@centerclick.org>
> ---
>  package/tzdata/tzdata.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/tzdata/tzdata.mk b/package/tzdata/tzdata.mk
index 21ea94ecad..7a1a77fcd9 100644
--- a/package/tzdata/tzdata.mk
+++ b/package/tzdata/tzdata.mk
@@ -59,7 +59,7 @@  endef
 
 define HOST_TZDATA_INSTALL_CMDS
 	$(INSTALL) -d -m 0755 $(HOST_DIR)/share/zoneinfo
-	cp -a $(@D)/_output/* $(@D)/*.tab $(HOST_DIR)/share/zoneinfo
+	cp -a $(@D)/_output/* $(@D)/*.tab $(@D)/leap-seconds.list $(HOST_DIR)/share/zoneinfo
 endef
 
 $(eval $(generic-package))