diff mbox series

[1/1] package/python-cchardet: fix python 3.11 compatibility

Message ID 20221025192219.1296974-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-cchardet: fix python 3.11 compatibility | expand

Commit Message

James Hilliard Oct. 25, 2022, 7:22 p.m. UTC
Add host-python-cython so that cython will generate python 3.11
compatible sources instead of using the python 3.11 incompatible
pre-built sources.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-cchardet/python-cchardet.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Oct. 25, 2022, 8:57 p.m. UTC | #1
On Tue, 25 Oct 2022 13:22:19 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> Add host-python-cython so that cython will generate python 3.11
> compatible sources instead of using the python 3.11 incompatible
> pre-built sources.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/python-cchardet/python-cchardet.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-cchardet/python-cchardet.mk b/package/python-cchardet/python-cchardet.mk
index 396e9d6c53..53a17f6732 100644
--- a/package/python-cchardet/python-cchardet.mk
+++ b/package/python-cchardet/python-cchardet.mk
@@ -10,5 +10,6 @@  PYTHON_CCHARDET_SITE = https://files.pythonhosted.org/packages/a8/5d/090c9f0312b
 PYTHON_CCHARDET_SETUP_TYPE = setuptools
 PYTHON_CCHARDET_LICENSE = MPL-1.1
 PYTHON_CCHARDET_LICENSE_FILES = COPYING
+PYTHON_CCHARDET_DEPENDENCIES = host-python-cython
 
 $(eval $(python-package))