diff mbox series

[1/1] package/nodejs: bypass configure shell wrapper

Message ID 20221025190236.1190494-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/nodejs: bypass configure shell wrapper | expand

Commit Message

James Hilliard Oct. 25, 2022, 7:02 p.m. UTC
The configure file is a shell script which searches for a predefined
python binary and then calls configure.py with that.

As we already call configure with the desired python binary we should
call configure.py directly so that the expected python binary is used
and so that the shell wrapper doesn't throw spurious interpreter
validation errors.

This also avoid spurious errors due to the configure shell wrapper
missing supported python versions, for example this fixes:
Node.js configure: Found Python 3.11.0...
Please use python3.10 or python3.9 or python3.8 or python3.7 or python3.6.
	/usr/bin/python3.10 ./configure

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/nodejs/nodejs.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Oct. 25, 2022, 8:57 p.m. UTC | #1
On Tue, 25 Oct 2022 13:02:36 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> The configure file is a shell script which searches for a predefined
> python binary and then calls configure.py with that.
> 
> As we already call configure with the desired python binary we should
> call configure.py directly so that the expected python binary is used
> and so that the shell wrapper doesn't throw spurious interpreter
> validation errors.
> 
> This also avoid spurious errors due to the configure shell wrapper
> missing supported python versions, for example this fixes:
> Node.js configure: Found Python 3.11.0...
> Please use python3.10 or python3.9 or python3.8 or python3.7 or python3.6.
> 	/usr/bin/python3.10 ./configure
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/nodejs/nodejs.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 5, 2022, 10:02 a.m. UTC | #2
>>>>> "James" == James Hilliard <james.hilliard1@gmail.com> writes:

 > The configure file is a shell script which searches for a predefined
 > python binary and then calls configure.py with that.

 > As we already call configure with the desired python binary we should
 > call configure.py directly so that the expected python binary is used
 > and so that the shell wrapper doesn't throw spurious interpreter
 > validation errors.

 > This also avoid spurious errors due to the configure shell wrapper
 > missing supported python versions, for example this fixes:
 > Node.js configure: Found Python 3.11.0...
 > Please use python3.10 or python3.9 or python3.8 or python3.7 or python3.6.
 > 	/usr/bin/python3.10 ./configure

 > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Committed to 2022.08.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index 05456e3443..29a10b900f 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -88,7 +88,7 @@  define HOST_NODEJS_CONFIGURE_CMDS
 		$(HOST_CONFIGURE_OPTS) \
 		PATH=$(@D)/bin:$(BR_PATH) \
 		PYTHON=$(HOST_DIR)/bin/python3 \
-		$(HOST_DIR)/bin/python3 ./configure \
+		$(HOST_DIR)/bin/python3 configure.py \
 		--prefix=$(HOST_DIR) \
 		--without-dtrace \
 		--without-etw \
@@ -200,7 +200,7 @@  define NODEJS_CONFIGURE_CMDS
 		LDFLAGS="$(NODEJS_LDFLAGS)" \
 		LD="$(TARGET_CXX)" \
 		PYTHON=$(HOST_DIR)/bin/python3 \
-		$(HOST_DIR)/bin/python3 ./configure \
+		$(HOST_DIR)/bin/python3 configure.py \
 		--prefix=/usr \
 		--dest-cpu=$(NODEJS_CPU) \
 		$(if $(NODEJS_ARM_FP),--with-arm-float-abi=$(NODEJS_ARM_FP)) \