diff mbox series

[v2,1/1] package/python-flask-jsonrpc: bump to version 2.2.2

Message ID 20221025071634.8563-1-sebastien.szymanski@armadeus.com
State Accepted
Headers show
Series [v2,1/1] package/python-flask-jsonrpc: bump to version 2.2.2 | expand

Commit Message

Sébastien Szymanski Oct. 25, 2022, 7:16 a.m. UTC
Drop patch 0001 as it is not needed anymore:
https://github.com/cenobites/flask-jsonrpc/commit/2426b7f6fabeef9eb3a8dc6570e2fce33a30f98e

Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
---
 ...-Move-pytest-runner-to-tests_require.patch | 32 -------------------
 .../python-flask-jsonrpc.hash                 |  4 +--
 .../python-flask-jsonrpc.mk                   |  4 +--
 3 files changed, 4 insertions(+), 36 deletions(-)
 delete mode 100644 package/python-flask-jsonrpc/0001-Move-pytest-runner-to-tests_require.patch
diff mbox series

Patch

diff --git a/package/python-flask-jsonrpc/0001-Move-pytest-runner-to-tests_require.patch b/package/python-flask-jsonrpc/0001-Move-pytest-runner-to-tests_require.patch
deleted file mode 100644
index 8b6712e601..0000000000
--- a/package/python-flask-jsonrpc/0001-Move-pytest-runner-to-tests_require.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 8f07768085fa4c8d21dbe27805b7238e67d3aea5 Mon Sep 17 00:00:00 2001
-From: James Hilliard <james.hilliard1@gmail.com>
-Date: Tue, 17 May 2022 15:52:58 -0600
-Subject: [PATCH] Move pytest-runner to tests_require
-
-This isn't a build requirement so it shouldn't be under
-setup_requires.
-
-Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
-[Upstream status:
-https://github.com/cenobites/flask-jsonrpc/pull/227]
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 197d6c9..f23c472 100755
---- a/setup.py
-+++ b/setup.py
-@@ -42,8 +42,8 @@ setuptools.setup(
-         'async': ['Flask[async]>=1.0.0,<3.0'],
-         'dotenv': ['Flask[dotenv]>=1.0.0,<3.0'],
-     },
--    setup_requires=['pytest-runner'],
-     tests_require=[
-+        'pytest-runner',
-         'mock==4.0.3',
-         'coverage==6.3.2;python_version>"3.6"',
-         'coverage<6.2;python_version<="3.6"',
--- 
-2.36.0
-
diff --git a/package/python-flask-jsonrpc/python-flask-jsonrpc.hash b/package/python-flask-jsonrpc/python-flask-jsonrpc.hash
index ee407dbd7a..d5c0e46595 100644
--- a/package/python-flask-jsonrpc/python-flask-jsonrpc.hash
+++ b/package/python-flask-jsonrpc/python-flask-jsonrpc.hash
@@ -1,6 +1,6 @@ 
 # md5, sha256 from https://pypi.org/pypi/flask-jsonrpc/json
-md5  f2b7bf5222f3aaf050f396522d7f692d  Flask-JSONRPC-2.2.1.tar.gz
-sha256  f994f8dd80bf31cf7272eb1a3030c6caf30fef3ced5866e66b56871d4047be68  Flask-JSONRPC-2.2.1.tar.gz
+md5  fb6205e6e776802c6000ea7119229066  Flask-JSONRPC-2.2.2.tar.gz
+sha256  0cb6ac2804980dc8ac7cbbc3149025f4ec9323227978a4a7ce7b55a9f8263a11  Flask-JSONRPC-2.2.2.tar.gz
 # Locally computed sha256 checksums
 sha256  5e6175926ba7dde28c7d292a8b0350aa82c40a8c5691a878fe02b0c9c6b43b39  LICENSE
 sha256  5e6175926ba7dde28c7d292a8b0350aa82c40a8c5691a878fe02b0c9c6b43b39  COPYING
diff --git a/package/python-flask-jsonrpc/python-flask-jsonrpc.mk b/package/python-flask-jsonrpc/python-flask-jsonrpc.mk
index 542b9e73f5..c816749085 100644
--- a/package/python-flask-jsonrpc/python-flask-jsonrpc.mk
+++ b/package/python-flask-jsonrpc/python-flask-jsonrpc.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_FLASK_JSONRPC_VERSION = 2.2.1
+PYTHON_FLASK_JSONRPC_VERSION = 2.2.2
 PYTHON_FLASK_JSONRPC_SOURCE = Flask-JSONRPC-$(PYTHON_FLASK_JSONRPC_VERSION).tar.gz
-PYTHON_FLASK_JSONRPC_SITE = https://files.pythonhosted.org/packages/ca/2a/3f2bd79840d9643fc909cf27f730b2c5006351746ba09c4dab1b898ddee9
+PYTHON_FLASK_JSONRPC_SITE = https://files.pythonhosted.org/packages/a5/7b/8cbd53084a1efb58a1105905a38b0cbefcd3ae13ef2c90c07eedf0fdb6dc
 PYTHON_FLASK_JSONRPC_LICENSE = BSD-3-Clause
 PYTHON_FLASK_JSONRPC_LICENSE_FILES = LICENSE COPYING
 PYTHON_FLASK_JSONRPC_SETUP_TYPE = setuptools