diff mbox series

[1/1] package/python-distro: bump to version 1.8.0

Message ID 20221024195436.409490-1-ju.o@free.fr
State Accepted
Headers show
Series [1/1] package/python-distro: bump to version 1.8.0 | expand

Commit Message

Julien Olivain Oct. 24, 2022, 7:54 p.m. UTC
Also adds md5 file hash published on:
https://pypi.org/pypi/distro/json

For change log since 1.7.0, see:
https://github.com/python-distro/distro/releases/tag/v1.8.0

Most notable change is the upstream support for Buildroot
(included in python module docs and tests).

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
Tested on commit bd6e792 with commands:

    make check-package
    ...
    0 warnings generated

    support/testing/run-tests \
       -d dl \
       -o output_folder \
       tests.package.test_python_distro.TestPythonPy3Distro
    ...
    OK
---
 package/python-distro/python-distro.hash | 4 +++-
 package/python-distro/python-distro.mk   | 4 ++--
 2 files changed, 5 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Oct. 24, 2022, 9:01 p.m. UTC | #1
On Mon, 24 Oct 2022 21:54:36 +0200
Julien Olivain <ju.o@free.fr> wrote:

> Also adds md5 file hash published on:
> https://pypi.org/pypi/distro/json
> 
> For change log since 1.7.0, see:
> https://github.com/python-distro/distro/releases/tag/v1.8.0
> 
> Most notable change is the upstream support for Buildroot
> (included in python module docs and tests).
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
> Tested on commit bd6e792 with commands:

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-distro/python-distro.hash b/package/python-distro/python-distro.hash
index 8f09197156..3d3e4258de 100644
--- a/package/python-distro/python-distro.hash
+++ b/package/python-distro/python-distro.hash
@@ -1,3 +1,5 @@ 
+# From https://pypi.org/pypi/distro/json
+md5  a1e81972bbcfc0dc77dd0cde590c22a6  distro-1.8.0.tar.gz
+sha256  02e111d1dc6a50abb8eed6bf31c3e48ed8b0830d1ea2a1b78c61765c2513fdd8  distro-1.8.0.tar.gz
 # Locally computed
-sha256  151aeccf60c216402932b52e40ee477a939f8d58898927378a02abbe852c1c39  distro-1.7.0.tar.gz
 sha256  cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14  LICENSE
diff --git a/package/python-distro/python-distro.mk b/package/python-distro/python-distro.mk
index c69849b7ac..e079d8e265 100644
--- a/package/python-distro/python-distro.mk
+++ b/package/python-distro/python-distro.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-PYTHON_DISTRO_VERSION = 1.7.0
-PYTHON_DISTRO_SITE = https://files.pythonhosted.org/packages/b5/7e/ddfbd640ac9a82e60718558a3de7d5988a7d4648385cf00318f60a8b073a
+PYTHON_DISTRO_VERSION = 1.8.0
+PYTHON_DISTRO_SITE = https://files.pythonhosted.org/packages/4b/89/eaa3a3587ebf8bed93e45aa79be8c2af77d50790d15b53f6dfc85b57f398
 PYTHON_DISTRO_SOURCE = distro-$(PYTHON_DISTRO_VERSION).tar.gz
 PYTHON_DISTRO_LICENSE = Apache-2.0
 PYTHON_DISTRO_LICENSE_FILES = LICENSE