diff mbox series

[1/1] package/iperf: bump to version 2.1.8

Message ID 20221023212956.60845-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/iperf: bump to version 2.1.8 | expand

Commit Message

Fabrice Fontaine Oct. 23, 2022, 9:29 p.m. UTC
2.1.8 (as of August 5th, 2022)
------------------------------
- Add support for --bounceback to perform a repsonsiveness test (see man
  page for other options)
- add support for working loads with --bounceback
- Fix to wait_tick with Mac OS X
- Various python pyflows commits
- add support for client side tcp-write-time histograms and mean/min/max
- add support for human readable dscp or -T values (see man page)
- udp_accept no longer accepts packets from a previous run as a new
  connection, this can occur with long network delays
- multiple isoch bug fixes for both UDP and TCP
- isoch server provides mean/min/max/stdev for both frames and packets
- UDP max MTU discovery, requires configure.ac will support
  --enable-discover-defaultlen prior to compile

- Drop first patch (already in version)
- Drop second patch (not needed since
  https://sourceforge.net/p/iperf2/code/ci/de5cb9954617309eecb8ae7d24b14e6b1e0c11eb)

https://sourceforge.net/projects/iperf2/files/

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .../iperf/0001-Fix-build-with-musl-libc.patch | 67 -------------------
 .../0002-compat-gettcpinfo.c-fix-build.patch  | 34 ----------
 package/iperf/iperf.hash                      |  4 +-
 package/iperf/iperf.mk                        |  2 +-
 4 files changed, 3 insertions(+), 104 deletions(-)
 delete mode 100644 package/iperf/0001-Fix-build-with-musl-libc.patch
 delete mode 100644 package/iperf/0002-compat-gettcpinfo.c-fix-build.patch

Comments

Thomas Petazzoni Oct. 25, 2022, 6:23 p.m. UTC | #1
On Sun, 23 Oct 2022 23:29:56 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> 2.1.8 (as of August 5th, 2022)
> ------------------------------
> - Add support for --bounceback to perform a repsonsiveness test (see man
>   page for other options)
> - add support for working loads with --bounceback
> - Fix to wait_tick with Mac OS X
> - Various python pyflows commits
> - add support for client side tcp-write-time histograms and mean/min/max
> - add support for human readable dscp or -T values (see man page)
> - udp_accept no longer accepts packets from a previous run as a new
>   connection, this can occur with long network delays
> - multiple isoch bug fixes for both UDP and TCP
> - isoch server provides mean/min/max/stdev for both frames and packets
> - UDP max MTU discovery, requires configure.ac will support
>   --enable-discover-defaultlen prior to compile

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/iperf/0001-Fix-build-with-musl-libc.patch b/package/iperf/0001-Fix-build-with-musl-libc.patch
deleted file mode 100644
index 269079ee1e..0000000000
--- a/package/iperf/0001-Fix-build-with-musl-libc.patch
+++ /dev/null
@@ -1,67 +0,0 @@ 
-From 6766ab322a9eb8c73f8276be9cdea356eb124de0 Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Thu, 11 Nov 2021 07:58:10 +0200
-Subject: [PATCH] Fix build with musl libc
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-musl libc defines its own struct ethhdr that conflicts with the kernel
-define one. The kernel headers provide a way to suppress its struct
-ethhdr. For that to work the libc headers must precede the kernel. Move
-the kernel linux/if_tun.h include below libc net/ethernet.h. That fixes
-the following build failure:
-
-In file included from .../arm-buildroot-linux-musleabihf/sysroot/usr/include/net/ethernet.h:10,
-                 from ../include/headers.h:117,
-                 from Thread.c:72:
-.../arm-buildroot-linux-musleabihf/sysroot/usr/include/netinet/if_ether.h:116:8: error: redefinition of ‘struct ethhdr’
-  116 | struct ethhdr {
-      |        ^~~~~~
-In file included from .../arm-buildroot-linux-musleabihf/sysroot/usr/include/linux/if_tun.h:20,
-                 from ../include/headers.h:110,
-                 from Thread.c:72:
-.../arm-buildroot-linux-musleabihf/sysroot/usr/include/linux/if_ether.h:148:8: note: originally defined here
-  148 | struct ethhdr {
-      |        ^~~~~~
-
-Fixes bug #157.
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-Upstream status: sent to Robert McMahon <rjmcmahon@rjmcmahon.com>
-
- include/headers.h | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/include/headers.h b/include/headers.h
-index 00e0ea0dba42..887490475381 100644
---- a/include/headers.h
-+++ b/include/headers.h
-@@ -106,11 +106,6 @@ typedef bool _Bool;
- #include <net/if.h>
- #endif
- 
--#if ((HAVE_TUNTAP_TAP) || (HAVE_TUNTAP_TUN))
--#include <linux/if_tun.h>
--#include <sys/ioctl.h>
--#endif
--
- 
- // AF_PACKET HEADERS
- #if defined(HAVE_LINUX_FILTER_H) && defined(HAVE_AF_PACKET)
-@@ -146,6 +141,11 @@ typedef bool _Bool;
- #define  IPV6HDRLEN 40
- #endif // HAVE_AF_PACKET
- 
-+#if ((HAVE_TUNTAP_TAP) || (HAVE_TUNTAP_TUN))
-+#include <linux/if_tun.h>
-+#include <sys/ioctl.h>
-+#endif
-+
- #ifdef WIN32
- 
- /* Windows config file */
--- 
-2.33.0
-
diff --git a/package/iperf/0002-compat-gettcpinfo.c-fix-build.patch b/package/iperf/0002-compat-gettcpinfo.c-fix-build.patch
deleted file mode 100644
index 786c7d1873..0000000000
--- a/package/iperf/0002-compat-gettcpinfo.c-fix-build.patch
+++ /dev/null
@@ -1,34 +0,0 @@ 
-From a3339604bafa99f66e12687efc2c50d2e2df1276 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 12 Dec 2021 20:03:04 +0100
-Subject: [PATCH] compat/gettcpinfo.c: fix build
-
-Fix the following build failure raised since commit
-c8f861a0a07b0606a581f2658c71959ad9417923:
-
-gettcpinfo.c: In function 'gettcpinfo':
-gettcpinfo.c:101:42: error: expected declaration or statement at end of input
-  101 | inline void gettcpinfo (int sock, struct ReportStruct *sample) {
-      |                                          ^~~~~~~~~~~~
-
-Fixes:
- - http://autobuild.buildroot.org/results/073e070478f0cda34784af96bb3a802c3aac8f72
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- compat/gettcpinfo.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/compat/gettcpinfo.c b/compat/gettcpinfo.c
-index 4e11e2a..1d3791a 100644
---- a/compat/gettcpinfo.c
-+++ b/compat/gettcpinfo.c
-@@ -99,4 +99,5 @@ inline void gettcpinfo (SOCKET sock, struct ReportStruct *sample) {
- };
- #else
- inline void gettcpinfo (int sock, struct ReportStruct *sample) {
-+};
- #endif
--- 
-2.33.0
-
diff --git a/package/iperf/iperf.hash b/package/iperf/iperf.hash
index 2e1f433dc7..34218bcf3b 100644
--- a/package/iperf/iperf.hash
+++ b/package/iperf/iperf.hash
@@ -1,6 +1,6 @@ 
 # From https://sourceforge.net/projects/iperf2/files/
-sha1  41bd049625cbecda2bf5b6a6cc12a6c5baec549b  iperf-2.1.6.tar.gz
+sha1  7725efffc6ef46fe5247ee326c39e5fa2eadf1eb  iperf-2.1.8.tar.gz
 
 # Locally computed:
-sha256  4a43e44439b95622aebeee55754a17d1c94076032e90620dfc1ab9908cb9e080  iperf-2.1.6.tar.gz
+sha256  8e2cf2fbc9d0d4d1cf9d109b1e328459f9622993dc9a4c5a7dc8a2088fb7beaf  iperf-2.1.8.tar.gz
 sha256  5f9f5c4feca3347c3b3c0ada8b16b4e6b698aac4e6f016a24adf61a5915336d1  COPYING
diff --git a/package/iperf/iperf.mk b/package/iperf/iperf.mk
index f999ff4ac2..47944880a3 100644
--- a/package/iperf/iperf.mk
+++ b/package/iperf/iperf.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-IPERF_VERSION = 2.1.6
+IPERF_VERSION = 2.1.8
 IPERF_SITE = http://downloads.sourceforge.net/project/iperf2
 IPERF_LICENSE = MIT-like
 IPERF_LICENSE_FILES = COPYING