diff mbox series

[v3,1/1] package/usbredir: bump to version 0.13.0

Message ID 20221023085251.8723-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v3,1/1] package/usbredir: bump to version 0.13.0 | expand

Commit Message

Fabrice Fontaine Oct. 23, 2022, 8:52 a.m. UTC
usbredirserver was dropped by
https://gitlab.freedesktop.org/spice/usbredir/-/commit/f4ffdce329305da2803684776f7659083a530819

Add an option to enable tools (and usbredirect binary) as a replacement
to usbredirserver

https://gitlab.freedesktop.org/spice/usbredir/-/blob/usbredir-0.13.0/ChangeLog.md

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v2 -> v3 (after review of Peter Seiderer):
 - Add libglib2 dependency
Changes v1 -> v2 (after review of Peter Seiderer):
 - Add an option to enable tools

 Config.in.legacy               |  8 ++++++++
 package/usbredir/Config.in     | 18 +++++++++++++-----
 package/usbredir/usbredir.hash |  4 ++--
 package/usbredir/usbredir.mk   | 22 ++++++++--------------
 4 files changed, 31 insertions(+), 21 deletions(-)

Comments

Thomas Petazzoni Nov. 14, 2022, 9:35 p.m. UTC | #1
On Sun, 23 Oct 2022 10:52:51 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> usbredirserver was dropped by
> https://gitlab.freedesktop.org/spice/usbredir/-/commit/f4ffdce329305da2803684776f7659083a530819
> 
> Add an option to enable tools (and usbredirect binary) as a replacement
> to usbredirserver
> 
> https://gitlab.freedesktop.org/spice/usbredir/-/blob/usbredir-0.13.0/ChangeLog.md
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v2 -> v3 (after review of Peter Seiderer):
>  - Add libglib2 dependency
> Changes v1 -> v2 (after review of Peter Seiderer):
>  - Add an option to enable tools

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 0e63d59a98..17f0858e70 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,14 @@  endif
 
 comment "Legacy options removed in 2022.11"
 
+config BR2_PACKAGE_USBREDIR_SERVER
+	bool "usbredirserver removed"
+	select BR2_LEGACY
+	help
+	  usbredirserver has been dropped by upstream since version
+	  0.13.0. usbredir tools (which include usbredirect binary) can
+	  be used as a replacement.
+
 config BR2_KERNEL_HEADERS_5_17
 	bool "kernel headers version 5.17.x are no longer supported"
 	select BR2_LEGACY
diff --git a/package/usbredir/Config.in b/package/usbredir/Config.in
index 8ce180a884..3e2e32568d 100644
--- a/package/usbredir/Config.in
+++ b/package/usbredir/Config.in
@@ -15,18 +15,26 @@  config BR2_PACKAGE_USBREDIR
 	  protocol.
 
 	  Note: only the library is installed, not the utilities. Say
-	  'y' below if you want the server too.
+	  'y' below if you want the tools too.
 
 	  http://www.spice-space.org/page/UsbRedir
 
 if BR2_PACKAGE_USBREDIR
 
-config BR2_PACKAGE_USBREDIR_SERVER
-	bool "usbredirserver on target"
+config BR2_PACKAGE_USBREDIR_TOOLS
+	bool "Enable tools"
+	depends on BR2_USE_MMU # libglib2
+	depends on BR2_USE_WCHAR # libglib2
+	select BR2_PACKAGE_LIBGLIB2
 	help
 	  If you want to serve usbredir requests on your target, say
-	  'y' here to have the usbredir server on the target.
+	  'y' here to have the tools built and installed on the target
+	  (including usbredirect binary).
 
-	  Note: the server is not required to use the library.
+	  Note: the tools are not required to use the library.
+
+comment "tools needs a toolchain w/ wchar"
+	depends on BR2_USE_MMU
+	depends on !BR2_USE_WCHAR
 
 endif
diff --git a/package/usbredir/usbredir.hash b/package/usbredir/usbredir.hash
index f738c36690..577e08efba 100644
--- a/package/usbredir/usbredir.hash
+++ b/package/usbredir/usbredir.hash
@@ -1,5 +1,5 @@ 
-# https://spice-space.org/download/usbredir/usbredir-0.12.0.tar.xz.sha256sum
-sha256  fbb44025bf55e1ce8d84afc7596bfa47c8a36cd603c6fa440f9102c1c9761e6d  usbredir-0.12.0.tar.xz
+# https://spice-space.org/download/usbredir/usbredir-0.13.0.tar.xz.sha256sum
+sha256  4ba6faa02c0ae6deeb4c53883d66ab54b3a5899bead42ce4ded9568b9a7dc46e  usbredir-0.13.0.tar.xz
 
 # Hash for license files
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/usbredir/usbredir.mk b/package/usbredir/usbredir.mk
index 6792a3e758..325e7313aa 100644
--- a/package/usbredir/usbredir.mk
+++ b/package/usbredir/usbredir.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-USBREDIR_VERSION = 0.12.0
+USBREDIR_VERSION = 0.13.0
 USBREDIR_SOURCE = usbredir-$(USBREDIR_VERSION).tar.xz
 USBREDIR_SITE = http://spice-space.org/download/usbredir
 USBREDIR_LICENSE = LGPL-2.1+ (libraries)
@@ -14,21 +14,15 @@  USBREDIR_DEPENDENCIES = host-pkgconf libusb
 USBREDIR_CONF_OPTS = \
 	-Dgit_werror=disabled \
 	-Dstack_protector=disabled \
-	-Dtests=disabled \
-	-Dtools=disabled
-
-ifeq ($(BR2_PACKAGE_USBREDIR_SERVER),y)
+	-Dtests=disabled
 
+ifeq ($(BR2_PACKAGE_USBREDIR_TOOLS),y)
 USBREDIR_LICENSE += , GPL-2.0+ (program)
 USBREDIR_LICENSE_FILES += COPYING
-
-else # BR2_PACKAGE_USBREDIR_SERVER != y
-
-define USBREDIR_POST_INSTALL_TARGET_RM_SERVER
-	rm -f $(TARGET_DIR)/usr/sbin/usbredirserver
-endef
-USBREDIR_POST_INSTALL_TARGET_HOOKS += USBREDIR_POST_INSTALL_TARGET_RM_SERVER
-
-endif # BR2_PACKAGE_USBREDIR_SERVER
+USBREDIR_DEPENDENCIES += libglib2
+USBREDIR_CONF_OPTS += -Dtools=enabled
+else
+USBREDIR_CONF_OPTS += -Dtools=disabled
+endif
 
 $(eval $(meson-package))