diff mbox series

package/rsync: force HAVE_C99_VSNPRINTF to "yes"

Message ID 20221019233414.868133-1-mmayer@broadcom.com
State Accepted
Headers show
Series package/rsync: force HAVE_C99_VSNPRINTF to "yes" | expand

Commit Message

Markus Mayer Oct. 19, 2022, 11:34 p.m. UTC
We know the system will have a modern-enough C library that implements
the required snprintf() functionality. Since the configure stage can't
detect the system's capabilities (because it is cross-compiling), let's
hard-code the decision.

As a result, rsync won't be linking in its own copy of snprintf().

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
---
 package/rsync/rsync.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni Nov. 3, 2022, 10:12 p.m. UTC | #1
On Wed, 19 Oct 2022 16:34:14 -0700
Markus Mayer via buildroot <buildroot@buildroot.org> wrote:

> We know the system will have a modern-enough C library that implements
> the required snprintf() functionality. Since the configure stage can't
> detect the system's capabilities (because it is cross-compiling), let's
> hard-code the decision.
> 
> As a result, rsync won't be linking in its own copy of snprintf().
> 
> Signed-off-by: Markus Mayer <mmayer@broadcom.com>
> ---
>  package/rsync/rsync.mk | 3 +++
>  1 file changed, 3 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 14, 2022, 10:25 a.m. UTC | #2
>>>>> "Markus" == Markus Mayer via buildroot <buildroot@buildroot.org> writes:

 > We know the system will have a modern-enough C library that implements
 > the required snprintf() functionality. Since the configure stage can't
 > detect the system's capabilities (because it is cross-compiling), let's
 > hard-code the decision.

 > As a result, rsync won't be linking in its own copy of snprintf().

 > Signed-off-by: Markus Mayer <mmayer@broadcom.com>

Committed to 2022.08.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/rsync/rsync.mk b/package/rsync/rsync.mk
index e288033b9819..0d311aa1673c 100644
--- a/package/rsync/rsync.mk
+++ b/package/rsync/rsync.mk
@@ -11,6 +11,9 @@  RSYNC_LICENSE_FILES = COPYING
 RSYNC_CPE_ID_VENDOR = samba
 RSYNC_SELINUX_MODULES = rsync
 RSYNC_DEPENDENCIES = zlib popt
+# We know that our C library is modern enough for C99 vsnprintf(). Since
+# configure can't detect this, we tell configure that vsnprintf() is safe.
+RSYNC_CONF_ENV = rsync_cv_HAVE_C99_VSNPRINTF=yes
 RSYNC_CONF_OPTS = \
 	--with-included-zlib=no \
 	--with-included-popt=no \