diff mbox series

package/libnss: disable parallel build with Make 4.4

Message ID 20221019195519.28536-1-giulio.benetti@benettiengineering.com
State Rejected
Headers show
Series package/libnss: disable parallel build with Make 4.4 | expand

Commit Message

Giulio Benetti Oct. 19, 2022, 7:55 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/libnss/libnss.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

James Hilliard Oct. 19, 2022, 11:36 p.m. UTC | #1
On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
<giulio.benetti@benettiengineering.com> wrote:
>
> Fixes:
> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/

Hmm, this looks like a bug in the libnss makefile, what was the failure
seen with make 4.3 here:
https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/

>
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>  package/libnss/libnss.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
> index 041b2cfc56..a613006f70 100644
> --- a/package/libnss/libnss.mk
> +++ b/package/libnss/libnss.mk
> @@ -15,8 +15,8 @@ LIBNSS_LICENSE_FILES = nss/COPYING
>  LIBNSS_CPE_ID_VENDOR = mozilla
>  LIBNSS_CPE_ID_PRODUCT = nss
>
> -# Don't parallel build if make version = 4.3
> -ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3),)
> +# Don't parallel build if make version = 4.3 or 4.4
> +ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3 4.4),)
>  LIBNSS_MAKE = $(MAKE1)
>  else
>  LIBNSS_MAKE = $(MAKE)
> --
> 2.34.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
James Hilliard Oct. 20, 2022, 12:23 a.m. UTC | #2
On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
<james.hilliard1@gmail.com> wrote:
>
> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
> <giulio.benetti@benettiengineering.com> wrote:
> >
> > Fixes:
> > http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
>
> Hmm, this looks like a bug in the libnss makefile, what was the failure
> seen with make 4.3 here:
> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/

This patch also does not fix the build with make 4.4(make from master branch)
from my testing.

Even without shuffle mode enabled the build appears to always fail.

>
> >
> > Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> > ---
> >  package/libnss/libnss.mk | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
> > index 041b2cfc56..a613006f70 100644
> > --- a/package/libnss/libnss.mk
> > +++ b/package/libnss/libnss.mk
> > @@ -15,8 +15,8 @@ LIBNSS_LICENSE_FILES = nss/COPYING
> >  LIBNSS_CPE_ID_VENDOR = mozilla
> >  LIBNSS_CPE_ID_PRODUCT = nss
> >
> > -# Don't parallel build if make version = 4.3
> > -ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3),)
> > +# Don't parallel build if make version = 4.3 or 4.4
> > +ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3 4.4),)
> >  LIBNSS_MAKE = $(MAKE1)
> >  else
> >  LIBNSS_MAKE = $(MAKE)
> > --
> > 2.34.1
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
Giulio Benetti Oct. 20, 2022, 6:53 a.m. UTC | #3
Hi James,

> Il giorno 20 ott 2022, alle ore 02:23, James Hilliard <james.hilliard1@gmail.com> ha scritto:
> 
> On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
> <james.hilliard1@gmail.com> wrote:
>> 
>>> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
>>> <giulio.benetti@benettiengineering.com> wrote:
>>> 
>>> Fixes:
>>> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
>> 
>> Hmm, this looks like a bug in the libnss makefile, what was the failure
>> seen with make 4.3 here:
>> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/
> 
> This patch also does not fix the build with make 4.4(make from master branch)
> from my testing.
> 
> Even without shuffle mode enabled the build appears to always fail.

Thank you for testing, I have forgotten exactly to ask you to do it :-) since almost all the failures comes from your asahi-mini that I remember to have Make 4.4.

So I try to reproduce the bug here at me and find out a fix.

Thanks again

Best regards
Giulio

> 
>> 
>>> 
>>> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
>>> ---
>>> package/libnss/libnss.mk | 4 ++--
>>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>> 
>>> diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
>>> index 041b2cfc56..a613006f70 100644
>>> --- a/package/libnss/libnss.mk
>>> +++ b/package/libnss/libnss.mk
>>> @@ -15,8 +15,8 @@ LIBNSS_LICENSE_FILES = nss/COPYING
>>> LIBNSS_CPE_ID_VENDOR = mozilla
>>> LIBNSS_CPE_ID_PRODUCT = nss
>>> 
>>> -# Don't parallel build if make version = 4.3
>>> -ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3),)
>>> +# Don't parallel build if make version = 4.3 or 4.4
>>> +ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3 4.4),)
>>> LIBNSS_MAKE = $(MAKE1)
>>> else
>>> LIBNSS_MAKE = $(MAKE)
>>> --
>>> 2.34.1
>>> 
>>> _______________________________________________
>>> buildroot mailing list
>>> buildroot@buildroot.org
>>> https://lists.buildroot.org/mailman/listinfo/buildroot
James Hilliard Oct. 20, 2022, 1:29 p.m. UTC | #4
On Thu, Oct 20, 2022 at 2:53 AM Giulio Benetti
<giulio.benetti@benettiengineering.com> wrote:
>
> Hi James,
>
> > Il giorno 20 ott 2022, alle ore 02:23, James Hilliard <james.hilliard1@gmail.com> ha scritto:
> >
> > On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
> > <james.hilliard1@gmail.com> wrote:
> >>
> >>> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
> >>> <giulio.benetti@benettiengineering.com> wrote:
> >>>
> >>> Fixes:
> >>> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
> >>
> >> Hmm, this looks like a bug in the libnss makefile, what was the failure
> >> seen with make 4.3 here:
> >> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/
> >
> > This patch also does not fix the build with make 4.4(make from master branch)
> > from my testing.
> >
> > Even without shuffle mode enabled the build appears to always fail.
>
> Thank you for testing, I have forgotten exactly to ask you to do it :-) since almost all the failures comes from your asahi-mini that I remember to have Make 4.4.

I'm running make master branch on all my autobuilders at the moment,
the failures aren't limited to asahi-mini:
http://autobuild.buildroot.net/?reason=libnss-3.84

>
> So I try to reproduce the bug here at me and find out a fix.

Use make master branch from here for testing:
git clone https://git.savannah.gnu.org/git/make.git

>
> Thanks again
>
> Best regards
> Giulio
>
> >
> >>
> >>>
> >>> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> >>> ---
> >>> package/libnss/libnss.mk | 4 ++--
> >>> 1 file changed, 2 insertions(+), 2 deletions(-)
> >>>
> >>> diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
> >>> index 041b2cfc56..a613006f70 100644
> >>> --- a/package/libnss/libnss.mk
> >>> +++ b/package/libnss/libnss.mk
> >>> @@ -15,8 +15,8 @@ LIBNSS_LICENSE_FILES = nss/COPYING
> >>> LIBNSS_CPE_ID_VENDOR = mozilla
> >>> LIBNSS_CPE_ID_PRODUCT = nss
> >>>
> >>> -# Don't parallel build if make version = 4.3
> >>> -ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3),)
> >>> +# Don't parallel build if make version = 4.3 or 4.4
> >>> +ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3 4.4),)
> >>> LIBNSS_MAKE = $(MAKE1)
> >>> else
> >>> LIBNSS_MAKE = $(MAKE)
> >>> --
> >>> 2.34.1
> >>>
> >>> _______________________________________________
> >>> buildroot mailing list
> >>> buildroot@buildroot.org
> >>> https://lists.buildroot.org/mailman/listinfo/buildroot
>
Giulio Benetti Nov. 17, 2022, 7:48 p.m. UTC | #5
Hi James,

On 20/10/22 15:29, James Hilliard wrote:
> On Thu, Oct 20, 2022 at 2:53 AM Giulio Benetti
> <giulio.benetti@benettiengineering.com> wrote:
>>
>> Hi James,
>>
>>> Il giorno 20 ott 2022, alle ore 02:23, James Hilliard <james.hilliard1@gmail.com> ha scritto:
>>>
>>> On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
>>> <james.hilliard1@gmail.com> wrote:
>>>>
>>>>> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
>>>>> <giulio.benetti@benettiengineering.com> wrote:
>>>>>
>>>>> Fixes:
>>>>> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
>>>>
>>>> Hmm, this looks like a bug in the libnss makefile, what was the failure
>>>> seen with make 4.3 here:
>>>> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/
>>>
>>> This patch also does not fix the build with make 4.4(make from master branch)
>>> from my testing.
>>>
>>> Even without shuffle mode enabled the build appears to always fail.
>>
>> Thank you for testing, I have forgotten exactly to ask you to do it :-) since almost all the failures comes from your asahi-mini that I remember to have Make 4.4.
> 
> I'm running make master branch on all my autobuilders at the moment,
> the failures aren't limited to asahi-mini:
> http://autobuild.buildroot.net/?reason=libnss-3.84
> 
>>
>> So I try to reproduce the bug here at me and find out a fix.
> 
> Use make master branch from here for testing:
> git clone https://git.savannah.gnu.org/git/make.git
> 

After lot of time I've found a way to fix this bug with this patch:
https://patchwork.ozlabs.org/project/buildroot/patch/20221117194505.949846-1-giulio.benetti@benettiengineering.com/

Can you please give a try at you too and give a Tested-by tag?

Thank you
Best regards
James Hilliard Nov. 20, 2022, 6:39 p.m. UTC | #6
On Thu, Nov 17, 2022 at 3:48 PM Giulio Benetti
<giulio.benetti@benettiengineering.com> wrote:
>
> Hi James,
>
> On 20/10/22 15:29, James Hilliard wrote:
> > On Thu, Oct 20, 2022 at 2:53 AM Giulio Benetti
> > <giulio.benetti@benettiengineering.com> wrote:
> >>
> >> Hi James,
> >>
> >>> Il giorno 20 ott 2022, alle ore 02:23, James Hilliard <james.hilliard1@gmail.com> ha scritto:
> >>>
> >>> On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
> >>> <james.hilliard1@gmail.com> wrote:
> >>>>
> >>>>> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
> >>>>> <giulio.benetti@benettiengineering.com> wrote:
> >>>>>
> >>>>> Fixes:
> >>>>> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
> >>>>
> >>>> Hmm, this looks like a bug in the libnss makefile, what was the failure
> >>>> seen with make 4.3 here:
> >>>> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/
> >>>
> >>> This patch also does not fix the build with make 4.4(make from master branch)
> >>> from my testing.
> >>>
> >>> Even without shuffle mode enabled the build appears to always fail.
> >>
> >> Thank you for testing, I have forgotten exactly to ask you to do it :-) since almost all the failures comes from your asahi-mini that I remember to have Make 4.4.
> >
> > I'm running make master branch on all my autobuilders at the moment,
> > the failures aren't limited to asahi-mini:
> > http://autobuild.buildroot.net/?reason=libnss-3.84
> >
> >>
> >> So I try to reproduce the bug here at me and find out a fix.
> >
> > Use make master branch from here for testing:
> > git clone https://git.savannah.gnu.org/git/make.git
> >
>
> After lot of time I've found a way to fix this bug with this patch:
> https://patchwork.ozlabs.org/project/buildroot/patch/20221117194505.949846-1-giulio.benetti@benettiengineering.com/
>
> Can you please give a try at you too and give a Tested-by tag?

Yeah, I verified it works on the recently released make 4.4 final.

>
> Thank you
> Best regards
> --
> Giulio Benetti
> CEO/CTO@Benetti Engineering sas
Giulio Benetti Nov. 20, 2022, 7:18 p.m. UTC | #7
Hi James,

> Il giorno 20 nov 2022, alle ore 19:41, James Hilliard <james.hilliard1@gmail.com> ha scritto:
> 
> On Thu, Nov 17, 2022 at 3:48 PM Giulio Benetti
> <giulio.benetti@benettiengineering.com> wrote:
>> 
>> Hi James,
>> 
>>> On 20/10/22 15:29, James Hilliard wrote:
>>> On Thu, Oct 20, 2022 at 2:53 AM Giulio Benetti
>>> <giulio.benetti@benettiengineering.com> wrote:
>>>> 
>>>> Hi James,
>>>> 
>>>>> Il giorno 20 ott 2022, alle ore 02:23, James Hilliard <james.hilliard1@gmail.com> ha scritto:
>>>>> 
>>>>> On Wed, Oct 19, 2022 at 7:36 PM James Hilliard
>>>>> <james.hilliard1@gmail.com> wrote:
>>>>>> 
>>>>>>> On Wed, Oct 19, 2022 at 3:55 PM Giulio Benetti
>>>>>>> <giulio.benetti@benettiengineering.com> wrote:
>>>>>>> 
>>>>>>> Fixes:
>>>>>>> http://autobuild.buildroot.net/results/433/4335d0d8454035a8f74645ba8d6c2329ab2e5480/
>>>>>> 
>>>>>> Hmm, this looks like a bug in the libnss makefile, what was the failure
>>>>>> seen with make 4.3 here:
>>>>>> https://lore.kernel.org/buildroot/20220101210952.2148256-1-giulio.benetti@benettiengineering.com/
>>>>> 
>>>>> This patch also does not fix the build with make 4.4(make from master branch)
>>>>> from my testing.
>>>>> 
>>>>> Even without shuffle mode enabled the build appears to always fail.
>>>> 
>>>> Thank you for testing, I have forgotten exactly to ask you to do it :-) since almost all the failures comes from your asahi-mini that I remember to have Make 4.4.
>>> 
>>> I'm running make master branch on all my autobuilders at the moment,
>>> the failures aren't limited to asahi-mini:
>>> http://autobuild.buildroot.net/?reason=libnss-3.84
>>> 
>>>> 
>>>> So I try to reproduce the bug here at me and find out a fix.
>>> 
>>> Use make master branch from here for testing:
>>> git clone https://git.savannah.gnu.org/git/make.git
>>> 
>> 
>> After lot of time I've found a way to fix this bug with this patch:
>> https://patchwork.ozlabs.org/project/buildroot/patch/20221117194505.949846-1-giulio.benetti@benettiengineering.com/
>> 
>> Can you please give a try at you too and give a Tested-by tag?
> 
> Yeah, I verified it works on the recently released make 4.4 final.

Thanks a lot!

Giulio

> 
>> 
>> Thank you
>> Best regards
>> --
>> Giulio Benetti
>> CEO/CTO@Benetti Engineering sas
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
index 041b2cfc56..a613006f70 100644
--- a/package/libnss/libnss.mk
+++ b/package/libnss/libnss.mk
@@ -15,8 +15,8 @@  LIBNSS_LICENSE_FILES = nss/COPYING
 LIBNSS_CPE_ID_VENDOR = mozilla
 LIBNSS_CPE_ID_PRODUCT = nss
 
-# Don't parallel build if make version = 4.3
-ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3),)
+# Don't parallel build if make version = 4.3 or 4.4
+ifneq ($(filter $(RUNNING_MAKE_VERSION),4.3 4.4),)
 LIBNSS_MAKE = $(MAKE1)
 else
 LIBNSS_MAKE = $(MAKE)