diff mbox series

[1/3] package/linux: don't leak host timezone into linux version string

Message ID 20221004111528.384625-1-nunog@fr24.com
State Accepted
Headers show
Series [1/3] package/linux: don't leak host timezone into linux version string | expand

Commit Message

Nuno Gonçalves Oct. 4, 2022, 11:15 a.m. UTC
Signed-off-by: Nuno Gonçalves <nunog@fr24.com>
---
 linux/linux.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Nov. 5, 2022, 2:10 p.m. UTC | #1
Nuno, All,

On 2022-10-04 12:15 +0100, Nuno Gonçalves via buildroot spake thusly:
> Signed-off-by: Nuno Gonçalves <nunog@fr24.com>

Applied to master, thanks.
Regards,
Yann E. MORIN.

> ---
>  linux/linux.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index efdc21eff2..6b547a68ed 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -162,7 +162,7 @@ LINUX_MAKE_ENV += \
>  	KBUILD_BUILD_VERSION=1 \
>  	KBUILD_BUILD_USER=buildroot \
>  	KBUILD_BUILD_HOST=buildroot \
> -	KBUILD_BUILD_TIMESTAMP="$(shell LC_ALL=C date -d @$(SOURCE_DATE_EPOCH))"
> +	KBUILD_BUILD_TIMESTAMP="$(shell LC_ALL=C TZ='UTC' date -d @$(SOURCE_DATE_EPOCH))"
>  endif
>  
>  # gcc-8 started warning about function aliases that have a
> -- 
> 2.37.3
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Nov. 14, 2022, 10:40 a.m. UTC | #2
>>>>> "Nuno" == Nuno Gonçalves via buildroot <buildroot@buildroot.org> writes:

 > Signed-off-by: Nuno Gonçalves <nunog@fr24.com>

Committed to 2022.08.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index efdc21eff2..6b547a68ed 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -162,7 +162,7 @@  LINUX_MAKE_ENV += \
 	KBUILD_BUILD_VERSION=1 \
 	KBUILD_BUILD_USER=buildroot \
 	KBUILD_BUILD_HOST=buildroot \
-	KBUILD_BUILD_TIMESTAMP="$(shell LC_ALL=C date -d @$(SOURCE_DATE_EPOCH))"
+	KBUILD_BUILD_TIMESTAMP="$(shell LC_ALL=C TZ='UTC' date -d @$(SOURCE_DATE_EPOCH))"
 endif
 
 # gcc-8 started warning about function aliases that have a