diff mbox series

package/gdk-pixbuf: fix test compilation (don't build the test suite)

Message ID 20220914063108.3686785-1-thomas.devoogdt@barco.com
State Accepted
Headers show
Series package/gdk-pixbuf: fix test compilation (don't build the test suite) | expand

Commit Message

Thomas Devoogdt Sept. 14, 2022, 6:31 a.m. UTC
Not needed + breaks compilation on some platforms.
The compilation error was seen on 2.42.8, but also relevant
for 2.42.9 to not compile the test suite.

The option was added in 2.42.9:
https://github.com/GNOME/gdk-pixbuf/commit/801eef111df624f4377baed9a90c94b6a2d4340c

```
[179/246] Generating tests/resources.c with a custom command
FAILED: tests/resources.c
/buildroot/output/host/bin/python3 /buildroot/output/build/host-gdk-pixbuf-2.42.8/build-aux/gen-resources.py --glib-compile-resources=/buildroot/output/host/bin/glib-compile-resources --pixdata=/buildroot/output/build/host-gdk-pixbuf-2.42.8/build/gdk-pixbuf/gdk-pixbuf-pixdata --loaders=/buildroot/output/build/host-gdk-pixbuf-2.42.8/build/gdk-pixbuf/loaders.cache --sourcedir=/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests --source ../tests/resources.gresource.xml tests/resources.c
failed to load "/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests/icc-profile.png": Couldn?t recognize the image file format for file ?/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests/icc-profile.png?
../tests/resources.gresource.xml: Child process exited with code 1.
```

Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
 package/gdk-pixbuf/gdk-pixbuf.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Korsgaard Sept. 18, 2022, 11:29 a.m. UTC | #1
>>>>> "Thomas" == Thomas Devoogdt <thomas@devoogdt.com> writes:

 > Not needed + breaks compilation on some platforms.
 > The compilation error was seen on 2.42.8, but also relevant
 > for 2.42.9 to not compile the test suite.

 > The option was added in 2.42.9:
 > https://github.com/GNOME/gdk-pixbuf/commit/801eef111df624f4377baed9a90c94b6a2d4340c

 > ```
 > [179/246] Generating tests/resources.c with a custom command
 > FAILED: tests/resources.c
 > /buildroot/output/host/bin/python3
 > /buildroot/output/build/host-gdk-pixbuf-2.42.8/build-aux/gen-resources.py
 > --glib-compile-resources=/buildroot/output/host/bin/glib-compile-resources
 > --pixdata=/buildroot/output/build/host-gdk-pixbuf-2.42.8/build/gdk-pixbuf/gdk-pixbuf-pixdata
 > --loaders=/buildroot/output/build/host-gdk-pixbuf-2.42.8/build/gdk-pixbuf/loaders.cache
 > --sourcedir=/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests
 > --source ../tests/resources.gresource.xml tests/resources.c
 > failed to load
 > "/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests/icc-profile.png":
 > Couldn?t recognize the image file format for file
 > ?/buildroot/output/build/host-gdk-pixbuf-2.42.8/tests/icc-profile.png?
 > ../tests/resources.gresource.xml: Child process exited with code 1.
 > ```

 > Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
index 7a75ed23f6..4a513effbd 100644
--- a/package/gdk-pixbuf/gdk-pixbuf.mk
+++ b/package/gdk-pixbuf/gdk-pixbuf.mk
@@ -19,11 +19,13 @@  HOST_GDK_PIXBUF_DEPENDENCIES = host-libpng host-pkgconf host-libglib2
 
 GDK_PIXBUF_CONF_OPTS = \
 	-Dgio_sniffing=false \
+	-Dtests=false \
 	-Dinstalled_tests=false \
 	-Dman=false
 
 HOST_GDK_PIXBUF_CONF_OPTS = \
 	-Dgio_sniffing=false \
+	-Dtests=false \
 	-Dinstalled_tests=false \
 	-Dintrospection=disabled \
 	-Drelocatable=true \