diff mbox series

package/coremark: Set cflags

Message ID 20220913072303.1698887-1-joel@jms.id.au
State Accepted
Headers show
Series package/coremark: Set cflags | expand

Commit Message

Joel Stanley Sept. 13, 2022, 7:23 a.m. UTC
The coremark build needs to set PORT_CFLAGS explicitly in order to pick
up the configured optmisation level, and other flags.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
 package/coremark/coremark.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Chris Packham Sept. 16, 2022, 5:02 a.m. UTC | #1
On Tue, Sep 13, 2022 at 7:23 PM Joel Stanley <joel@jms.id.au> wrote:
>
> The coremark build needs to set PORT_CFLAGS explicitly in order to pick
> up the configured optmisation level, and other flags.
>
> Signed-off-by: Joel Stanley <joel@jms.id.au>

Acked-by: Chris Packham <judge.packham@gmail.com>

> ---
>  package/coremark/coremark.mk | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/package/coremark/coremark.mk b/package/coremark/coremark.mk
> index 418fd5c8d39b..9ea8693e7189 100644
> --- a/package/coremark/coremark.mk
> +++ b/package/coremark/coremark.mk
> @@ -11,6 +11,7 @@ COREMARK_LICENSE_FILES = LICENSE.md
>
>  define COREMARK_BUILD_CMDS
>         $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D) \
> +               PORT_CFLAGS="$(TARGET_CFLAGS)" \
>                 PORT_DIR=linux$(if $(BR2_ARCH_IS_64),64) EXE= link
>  endef
>
> --
> 2.35.1
>
Joel Stanley Oct. 16, 2022, 4:50 a.m. UTC | #2
On Fri, 16 Sept 2022 at 05:03, Chris Packham <judge.packham@gmail.com> wrote:
>
> On Tue, Sep 13, 2022 at 7:23 PM Joel Stanley <joel@jms.id.au> wrote:
> >
> > The coremark build needs to set PORT_CFLAGS explicitly in order to pick
> > up the configured optmisation level, and other flags.
> >
> > Signed-off-by: Joel Stanley <joel@jms.id.au>
>
> Acked-by: Chris Packham <judge.packham@gmail.com>

ping

>
> > ---
> >  package/coremark/coremark.mk | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/package/coremark/coremark.mk b/package/coremark/coremark.mk
> > index 418fd5c8d39b..9ea8693e7189 100644
> > --- a/package/coremark/coremark.mk
> > +++ b/package/coremark/coremark.mk
> > @@ -11,6 +11,7 @@ COREMARK_LICENSE_FILES = LICENSE.md
> >
> >  define COREMARK_BUILD_CMDS
> >         $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D) \
> > +               PORT_CFLAGS="$(TARGET_CFLAGS)" \
> >                 PORT_DIR=linux$(if $(BR2_ARCH_IS_64),64) EXE= link
> >  endef
> >
> > --
> > 2.35.1
> >
Yann E. MORIN April 16, 2023, 7:12 p.m. UTC | #3
Joel, All,

On 2022-09-13 16:53 +0930, Joel Stanley spake thusly:
> The coremark build needs to set PORT_CFLAGS explicitly in order to pick
> up the configured optmisation level, and other flags.
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>

Applied to master, thanks.

Sorry for the delay in reviewing and applying such a simple patch. :-(

Regards,
Yann E. MORIN.

> ---
>  package/coremark/coremark.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/coremark/coremark.mk b/package/coremark/coremark.mk
> index 418fd5c8d39b..9ea8693e7189 100644
> --- a/package/coremark/coremark.mk
> +++ b/package/coremark/coremark.mk
> @@ -11,6 +11,7 @@ COREMARK_LICENSE_FILES = LICENSE.md
>  
>  define COREMARK_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D) \
> +		PORT_CFLAGS="$(TARGET_CFLAGS)" \
>  		PORT_DIR=linux$(if $(BR2_ARCH_IS_64),64) EXE= link
>  endef
>  
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard April 23, 2023, 10:29 a.m. UTC | #4
>>>>> "Joel" == Joel Stanley <joel@jms.id.au> writes:

 > The coremark build needs to set PORT_CFLAGS explicitly in order to pick
 > up the configured optmisation level, and other flags.

 > Signed-off-by: Joel Stanley <joel@jms.id.au>

Committed to 2023.02.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/coremark/coremark.mk b/package/coremark/coremark.mk
index 418fd5c8d39b..9ea8693e7189 100644
--- a/package/coremark/coremark.mk
+++ b/package/coremark/coremark.mk
@@ -11,6 +11,7 @@  COREMARK_LICENSE_FILES = LICENSE.md
 
 define COREMARK_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D) \
+		PORT_CFLAGS="$(TARGET_CFLAGS)" \
 		PORT_DIR=linux$(if $(BR2_ARCH_IS_64),64) EXE= link
 endef