diff mbox series

[v2,07/29] package/qt6/qt6base: add support for building examples

Message ID 20220826064758.3968647-8-jesseevg@gmail.com
State Changes Requested
Headers show
Series [v2,01/29] package/qt6/qt6base: Add qt6base hash file | expand

Commit Message

Jesse Van Gavere Aug. 26, 2022, 6:47 a.m. UTC
---
 package/qt6/qt6base/Config.in  | 7 +++++++
 package/qt6/qt6base/qt6base.mk | 6 ++++++
 2 files changed, 13 insertions(+)

Comments

Thomas Petazzoni Aug. 26, 2022, 8:07 a.m. UTC | #1
On Fri, 26 Aug 2022 08:47:36 +0200
Jesse Van Gavere <jesseevg@gmail.com> wrote:

> ---
>  package/qt6/qt6base/Config.in  | 7 +++++++
>  package/qt6/qt6base/qt6base.mk | 6 ++++++
>  2 files changed, 13 insertions(+)
> 
> diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
> index 2ed780e913..061861880c 100644
> --- a/package/qt6/qt6base/Config.in
> +++ b/package/qt6/qt6base/Config.in
> @@ -17,6 +17,13 @@ config BR2_PACKAGE_QT6BASE
>  
>  if BR2_PACKAGE_QT6BASE
>  
> +config BR2_PACKAGE_QT6BASE_EXAMPLES
> +	bool "Compile and install examples (with code)"

Did you check that indeed with qt6 examples are still installed with
their source code?

> +	select BR2_PACKAGE_QT6BASE_NETWORK
> +	select BR2_PACKAGE_QT6BASE_XML

Did you check that with qt6 examples indeed need network and xml, and
just that?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
index 2ed780e913..061861880c 100644
--- a/package/qt6/qt6base/Config.in
+++ b/package/qt6/qt6base/Config.in
@@ -17,6 +17,13 @@  config BR2_PACKAGE_QT6BASE
 
 if BR2_PACKAGE_QT6BASE
 
+config BR2_PACKAGE_QT6BASE_EXAMPLES
+	bool "Compile and install examples (with code)"
+	select BR2_PACKAGE_QT6BASE_NETWORK
+	select BR2_PACKAGE_QT6BASE_XML
+	help
+	  If unsure, say N.
+
 config BR2_PACKAGE_QT6BASE_NETWORK
 	bool "network module"
 	help
diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index fd1e0a2847..f66610ea0c 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -77,6 +77,12 @@  define HOST_QT6BASE_INSTALL_CMDS
 	$(HOST_MAKE_ENV) $(BR2_CMAKE) --install $(HOST_QT6BASE_BUILDDIR)
 endef
 
+ifeq ($(BR2_PACKAGE_QT6BASE_EXAMPLES),y)
+QT6BASE_CONF_OPTS += -DQT_BUILD_EXAMPLES=ON
+else
+QT6BASE_CONF_OPTS += -DQT_BUILD_EXAMPLES=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_QT6BASE_NETWORK),y)
 QT6BASE_CONF_OPTS += -DFEATURE_network=ON
 else