diff mbox series

[1/1] package/igh-ethercat: fix build without C++

Message ID 20220824215318.389653-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/igh-ethercat: fix build without C++ | expand

Commit Message

Fabrice Fontaine Aug. 24, 2022, 9:53 p.m. UTC
tools needs C++ since the addition of the package in commit
27ad470d7df5509ae4a96edd04521211900090e4 resulting in the following
build failure:

no -DHAVE_CONFIG_H -I. -I..   -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -I../include -I../master -Wall -DREV=`if test -s ../revision; then cat ../revision; else hg id -i .. 2>/dev/null || echo "unknown"; fi` -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Ofast -g0  -c -o ethercat-Command.o `test -f 'Command.cpp' || echo './'`Command.cpp
/bin/bash: line 1: no: command not found

Fixes:
 - http://autobuild.buildroot.org/results/89d096006839f32a3d03786e69e51ec3c5ea70f6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/igh-ethercat/igh-ethercat.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN Aug. 27, 2022, 10:06 a.m. UTC | #1
Fabrice, All,

On 2022-08-24 23:53 +0200, Fabrice Fontaine spake thusly:
> tools needs C++ since the addition of the package in commit
> 27ad470d7df5509ae4a96edd04521211900090e4 resulting in the following
> build failure:
> 
> no -DHAVE_CONFIG_H -I. -I..   -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -I../include -I../master -Wall -DREV=`if test -s ../revision; then cat ../revision; else hg id -i .. 2>/dev/null || echo "unknown"; fi` -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Ofast -g0  -c -o ethercat-Command.o `test -f 'Command.cpp' || echo './'`Command.cpp
> /bin/bash: line 1: no: command not found
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/89d096006839f32a3d03786e69e51ec3c5ea70f6
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks. I just move the assignment first, before the
package's own options, in the spirit of "handle inherited dependencies
then one's owns".

I've also pushed a follow-up patch that cleans up this conditional multi
assignment ugliness, so that it looks more like we are doing elsewhere,
using a multi-line assignment.

Regards,
Yann E. MORIN.

> ---
>  package/igh-ethercat/igh-ethercat.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/igh-ethercat/igh-ethercat.mk b/package/igh-ethercat/igh-ethercat.mk
> index b9771e8f8c..5004e4aa75 100644
> --- a/package/igh-ethercat/igh-ethercat.mk
> +++ b/package/igh-ethercat/igh-ethercat.mk
> @@ -20,6 +20,7 @@ IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E100),--enable-e100,--
>  IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000),--enable-e1000,--disable-e1000)
>  IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000E),--enable-e1000e,--disable-e1000e)
>  IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_R8169),--enable-r8169,--disable-r8169)
> +IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_INSTALL_LIBSTDCPP),--enable-tool,--disable-tool)
>  
>  $(eval $(kernel-module))
>  $(eval $(autotools-package))
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Sept. 17, 2022, 6:30 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > tools needs C++ since the addition of the package in commit
 > 27ad470d7df5509ae4a96edd04521211900090e4 resulting in the following
 > build failure:

 > no -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
 > -D_FILE_OFFSET_BITS=64 -I../include -I../master -Wall -DREV=`if test
 > -s ../revision; then cat ../revision; else hg id -i .. 2>/dev/null ||
 > echo "unknown"; fi` -fno-strict-aliasing -D_LARGEFILE_SOURCE
 > -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Ofast -g0 -c -o
 > ethercat-Command.o `test -f 'Command.cpp' || echo './'`Command.cpp
 > /bin/bash: line 1: no: command not found

 > Fixes:
 >  - http://autobuild.buildroot.org/results/89d096006839f32a3d03786e69e51ec3c5ea70f6

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/igh-ethercat/igh-ethercat.mk b/package/igh-ethercat/igh-ethercat.mk
index b9771e8f8c..5004e4aa75 100644
--- a/package/igh-ethercat/igh-ethercat.mk
+++ b/package/igh-ethercat/igh-ethercat.mk
@@ -20,6 +20,7 @@  IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E100),--enable-e100,--
 IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000),--enable-e1000,--disable-e1000)
 IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000E),--enable-e1000e,--disable-e1000e)
 IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_PACKAGE_IGH_ETHERCAT_R8169),--enable-r8169,--disable-r8169)
+IGH_ETHERCAT_CONF_OPTS += $(if $(BR2_INSTALL_LIBSTDCPP),--enable-tool,--disable-tool)
 
 $(eval $(kernel-module))
 $(eval $(autotools-package))