diff mbox series

[2/7] package/weston: add BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL config

Message ID 20220824192604.2549356-9-chris.dimich@boundarydevices.com
State Rejected
Headers show
Series None | expand

Commit Message

Chris Dimich Aug. 24, 2022, 7:25 p.m. UTC
In the case of the vivante sdk, the deprecated-wl-shell option needs to
be enabled. Otherwise, apps using the sdk cannot run on weston/wayland.

Signed-off-by: Chris Dimich <chris.dimich@boundarydevices.com>
---
 package/weston/Config.in | 7 +++++++
 package/weston/weston.mk | 4 ++++
 2 files changed, 11 insertions(+)

Comments

Yann E. MORIN Aug. 28, 2022, 3:15 p.m. UTC | #1
Chris, All,

On 2022-08-24 12:25 -0700, Chris Dimich spake thusly:
> In the case of the vivante sdk, the deprecated-wl-shell option needs to
> be enabled. Otherwise, apps using the sdk cannot run on weston/wayland.

Note that this option has been entirely removed upstream in e6b8f5a5e40c
(remove wl_shell), commited 2022-03-08, and present in tag 10.0.91,
which means that the next release of weston will no longer have that
option.

I am a bit relunctant at adding this in Buildroot, because that means
the vivante stuff will be broken when we bump weston, or we won't be
able to bump weston.

Besides, your series does not even make use of that new option; i.e.
nothing selects BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL.

So, I would prefer not to add that option at all, knowing that it will
soon be removed.

Regards,
Yann E. MORIN.

> Signed-off-by: Chris Dimich <chris.dimich@boundarydevices.com>
> ---
>  package/weston/Config.in | 7 +++++++
>  package/weston/weston.mk | 4 ++++
>  2 files changed, 11 insertions(+)
> 
> diff --git a/package/weston/Config.in b/package/weston/Config.in
> index 3b4e932b7d..c560c32b50 100644
> --- a/package/weston/Config.in
> +++ b/package/weston/Config.in
> @@ -164,4 +164,11 @@ comment "demo clients needs an OpenGL ES provider, an OpenEGL-capable Wayland ba
>  		!BR2_USE_WCHAR || !BR2_PACKAGE_HAS_LIBGLES || \
>  		!BR2_PACKAGE_HAS_LIBEGL_WAYLAND || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
>  
> +config BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL
> +	bool "deprecated wl shell"
> +	help
> +	  In the case of the vivante sdk, the deprecated-wl-shell option
> +	  needs to be enabled. Otherwise, apps using the sdk cannot
> +	  run on weston/wayland.
> +
>  endif
> diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> index e6c54ee7aa..ad4d81425e 100644
> --- a/package/weston/weston.mk
> +++ b/package/weston/weston.mk
> @@ -186,4 +186,8 @@ else
>  WESTON_CONF_OPTS += -Ddemo-clients=false
>  endif
>  
> +ifeq ($(BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL),y)
> +WESTON_CONF_OPTS += -Ddeprecated-wl-shell=true
> +endif
> +
>  $(eval $(meson-package))
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Chris Dimich Sept. 2, 2022, 6:22 p.m. UTC | #2
Hi Yann,

Okay, understood. This should be dropped if mainline removed it completely.

Thanks,

Chris Dimich
Boundary Devices, LLC
www.boundarydevices.com
7 Orchard Road, Suite 102*|*Lake Forest, CA 92630



On Sun, Aug 28, 2022 at 8:15 AM Yann E. MORIN <yann.morin.1998@free.fr>
wrote:

> Chris, All,
>
> On 2022-08-24 12:25 -0700, Chris Dimich spake thusly:
> > In the case of the vivante sdk, the deprecated-wl-shell option needs to
> > be enabled. Otherwise, apps using the sdk cannot run on weston/wayland.
>
> Note that this option has been entirely removed upstream in e6b8f5a5e40c
> (remove wl_shell), commited 2022-03-08, and present in tag 10.0.91,
> which means that the next release of weston will no longer have that
> option.
>
> I am a bit relunctant at adding this in Buildroot, because that means
> the vivante stuff will be broken when we bump weston, or we won't be
> able to bump weston.
>
> Besides, your series does not even make use of that new option; i.e.
> nothing selects BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL.
>
> So, I would prefer not to add that option at all, knowing that it will
> soon be removed.
>
> Regards,
> Yann E. MORIN.
>
> > Signed-off-by: Chris Dimich <chris.dimich@boundarydevices.com>
> > ---
> >  package/weston/Config.in | 7 +++++++
> >  package/weston/weston.mk | 4 ++++
> >  2 files changed, 11 insertions(+)
> >
> > diff --git a/package/weston/Config.in b/package/weston/Config.in
> > index 3b4e932b7d..c560c32b50 100644
> > --- a/package/weston/Config.in
> > +++ b/package/weston/Config.in
> > @@ -164,4 +164,11 @@ comment "demo clients needs an OpenGL ES provider,
> an OpenEGL-capable Wayland ba
> >               !BR2_USE_WCHAR || !BR2_PACKAGE_HAS_LIBGLES || \
> >               !BR2_PACKAGE_HAS_LIBEGL_WAYLAND ||
> !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
> >
> > +config BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL
> > +     bool "deprecated wl shell"
> > +     help
> > +       In the case of the vivante sdk, the deprecated-wl-shell option
> > +       needs to be enabled. Otherwise, apps using the sdk cannot
> > +       run on weston/wayland.
> > +
> >  endif
> > diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> > index e6c54ee7aa..ad4d81425e 100644
> > --- a/package/weston/weston.mk
> > +++ b/package/weston/weston.mk
> > @@ -186,4 +186,8 @@ else
> >  WESTON_CONF_OPTS += -Ddemo-clients=false
> >  endif
> >
> > +ifeq ($(BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL),y)
> > +WESTON_CONF_OPTS += -Ddeprecated-wl-shell=true
> > +endif
> > +
> >  $(eval $(meson-package))
> > --
> > 2.34.1
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
>
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics'
> conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___
>      |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is
> no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v
>  conspiracy.  |
>
> '------------------------------^-------^------------------^--------------------'
>
diff mbox series

Patch

diff --git a/package/weston/Config.in b/package/weston/Config.in
index 3b4e932b7d..c560c32b50 100644
--- a/package/weston/Config.in
+++ b/package/weston/Config.in
@@ -164,4 +164,11 @@  comment "demo clients needs an OpenGL ES provider, an OpenEGL-capable Wayland ba
 		!BR2_USE_WCHAR || !BR2_PACKAGE_HAS_LIBGLES || \
 		!BR2_PACKAGE_HAS_LIBEGL_WAYLAND || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
 
+config BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL
+	bool "deprecated wl shell"
+	help
+	  In the case of the vivante sdk, the deprecated-wl-shell option
+	  needs to be enabled. Otherwise, apps using the sdk cannot
+	  run on weston/wayland.
+
 endif
diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index e6c54ee7aa..ad4d81425e 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -186,4 +186,8 @@  else
 WESTON_CONF_OPTS += -Ddemo-clients=false
 endif
 
+ifeq ($(BR2_PACKAGE_WESTON_DEPRECATED_WL_SHELL),y)
+WESTON_CONF_OPTS += -Ddeprecated-wl-shell=true
+endif
+
 $(eval $(meson-package))