diff mbox series

[06/33] package/kvm-unit-tests: do not use "select...if SYMBOL=y"

Message ID 20220814233845.2247022-7-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series fix typos | expand

Commit Message

Ricardo Martincoski Aug. 14, 2022, 11:38 p.m. UTC
All other occurrencies in the tree simply do:
select SYMBOL1 if SYMBOL2
instead of
select SYMBOL1 if SYMBOL2=y

So do the same here for consistency.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
 package/kvm-unit-tests/Config.in | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Huth Aug. 15, 2022, 9:51 a.m. UTC | #1
Am Sun, 14 Aug 2022 20:38:18 -0300
schrieb Ricardo Martincoski <ricardo.martincoski@gmail.com>:

> All other occurrencies in the tree simply do:
> select SYMBOL1 if SYMBOL2
> instead of
> select SYMBOL1 if SYMBOL2=y
> 
> So do the same here for consistency.
> 
> Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
> ---
>  package/kvm-unit-tests/Config.in | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/kvm-unit-tests/Config.in b/package/kvm-unit-tests/Config.in
> index 7658877ce9..02ea8dd58c 100644
> --- a/package/kvm-unit-tests/Config.in
> +++ b/package/kvm-unit-tests/Config.in
> @@ -20,7 +20,7 @@ config BR2_PACKAGE_KVM_UNIT_TESTS
>  	# x86-64 we use the host gcc (see .mk file for details)
>  	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5 || !BR2_i386
>  	depends on BR2_HOSTARCH = "x86_64" || !BR2_x86_64
> -	select BR2_HOSTARCH_NEEDS_IA32_COMPILER if BR2_x86_64=y
> +	select BR2_HOSTARCH_NEEDS_IA32_COMPILER if BR2_x86_64
>  	help
>  	  kvm-unit-tests is a project as old as KVM. As its name
>  	  suggests, it's purpose is to provide unit tests for KVM. The

Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Peter Korsgaard Sept. 16, 2022, 11:39 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > All other occurrencies in the tree simply do:
 > select SYMBOL1 if SYMBOL2
 > instead of
 > select SYMBOL1 if SYMBOL2=y

 > So do the same here for consistency.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/kvm-unit-tests/Config.in b/package/kvm-unit-tests/Config.in
index 7658877ce9..02ea8dd58c 100644
--- a/package/kvm-unit-tests/Config.in
+++ b/package/kvm-unit-tests/Config.in
@@ -20,7 +20,7 @@  config BR2_PACKAGE_KVM_UNIT_TESTS
 	# x86-64 we use the host gcc (see .mk file for details)
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5 || !BR2_i386
 	depends on BR2_HOSTARCH = "x86_64" || !BR2_x86_64
-	select BR2_HOSTARCH_NEEDS_IA32_COMPILER if BR2_x86_64=y
+	select BR2_HOSTARCH_NEEDS_IA32_COMPILER if BR2_x86_64
 	help
 	  kvm-unit-tests is a project as old as KVM. As its name
 	  suggests, it's purpose is to provide unit tests for KVM. The