diff mbox series

[1/1] package/syslinux: disable documentation

Message ID 20220814202057.3698507-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/syslinux: disable documentation | expand

Commit Message

Fabrice Fontaine Aug. 14, 2022, 8:20 p.m. UTC
Disable documentation to avoid the following build failure if a non
working asciidoc or a2x is found on the system:

asciidoc -o html/syslinux.html /nvmedata/autobuild/instance-3/output-1/build/syslinux-6.03/txt/syslinux.txt
/nvmedata/autobuild/instance-3/output-1/per-package/syslinux/host/bin/python3: No module named asciidoc

Setting {ASCIIDOC,A2X_XML}_OK to a value different of 0 will disable
html, man, xhtml and text documentation

Fixes:
 - http://autobuild.buildroot.org/results/47f876ccb56831cc1bb9e6c2f7dbce423581a0dd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 boot/syslinux/syslinux.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yann E. MORIN Aug. 14, 2022, 8:43 p.m. UTC | #1
Fabrice, All,

On 2022-08-14 22:20 +0200, Fabrice Fontaine spake thusly:
> Disable documentation to avoid the following build failure if a non
> working asciidoc or a2x is found on the system:
> 
> asciidoc -o html/syslinux.html /nvmedata/autobuild/instance-3/output-1/build/syslinux-6.03/txt/syslinux.txt
> /nvmedata/autobuild/instance-3/output-1/per-package/syslinux/host/bin/python3: No module named asciidoc
> 
> Setting {ASCIIDOC,A2X_XML}_OK to a value different of 0 will disable
> html, man, xhtml and text documentation
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/47f876ccb56831cc1bb9e6c2f7dbce423581a0dd
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  boot/syslinux/syslinux.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
> index 2df415fcfd..cc52c49aee 100644
> --- a/boot/syslinux/syslinux.mk
> +++ b/boot/syslinux/syslinux.mk
> @@ -58,6 +58,8 @@ SYSLINUX_POST_PATCH_HOOKS += SYSLINUX_CLEANUP
>  # be used.
>  define SYSLINUX_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE1) \
> +		ASCIIDOC_OK=-1 \
> +		A2X_XML_OK=-1 \
>  		CC="$(TARGET_CC)" \
>  		LD="$(TARGET_LD)" \
>  		OBJCOPY="$(TARGET_OBJCOPY)" \
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Sept. 16, 2022, 8:52 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable documentation to avoid the following build failure if a non
 > working asciidoc or a2x is found on the system:

 > asciidoc -o html/syslinux.html
 > /nvmedata/autobuild/instance-3/output-1/build/syslinux-6.03/txt/syslinux.txt
 > /nvmedata/autobuild/instance-3/output-1/per-package/syslinux/host/bin/python3:
 > No module named asciidoc

 > Setting {ASCIIDOC,A2X_XML}_OK to a value different of 0 will disable
 > html, man, xhtml and text documentation

 > Fixes:
 >  - http://autobuild.buildroot.org/results/47f876ccb56831cc1bb9e6c2f7dbce423581a0dd

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index 2df415fcfd..cc52c49aee 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -58,6 +58,8 @@  SYSLINUX_POST_PATCH_HOOKS += SYSLINUX_CLEANUP
 # be used.
 define SYSLINUX_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE1) \
+		ASCIIDOC_OK=-1 \
+		A2X_XML_OK=-1 \
 		CC="$(TARGET_CC)" \
 		LD="$(TARGET_LD)" \
 		OBJCOPY="$(TARGET_OBJCOPY)" \