diff mbox series

[1/1] package/waffle: fix build without C++

Message ID 20220807211541.178167-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/waffle: fix build without C++ | expand

Commit Message

Fabrice Fontaine Aug. 7, 2022, 9:15 p.m. UTC
Drop C++ dependency as nacl is disabled (and will be dropped by upstream
in next release) to avoid the following build failure raised since bump
to version 1.6.1 in commit 814f36fdcc39bbafa1e2aaf637c7c6b59e7f37dd:

CMake Error at /usr/share/cmake-3.22/Modules/CMakeTestCXXCompiler.cmake:62 (message):
  The C++ compiler

    "/usr/bin/clang++"

  is not able to compile a simple test program.

Fixes:
 - http://autobuild.buildroot.org/results/a702495074b0393682c619781c349ce62e123133

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/waffle/0003-drop-C-dependency.patch | 46 +++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 package/waffle/0003-drop-C-dependency.patch

Comments

Thomas Petazzoni Aug. 9, 2022, 11:33 a.m. UTC | #1
On Sun,  7 Aug 2022 23:15:41 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Drop C++ dependency as nacl is disabled (and will be dropped by upstream
> in next release) to avoid the following build failure raised since bump
> to version 1.6.1 in commit 814f36fdcc39bbafa1e2aaf637c7c6b59e7f37dd:
> 
> CMake Error at /usr/share/cmake-3.22/Modules/CMakeTestCXXCompiler.cmake:62 (message):
>   The C++ compiler
> 
>     "/usr/bin/clang++"
> 
>   is not able to compile a simple test program.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/a702495074b0393682c619781c349ce62e123133
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/waffle/0003-drop-C-dependency.patch | 46 +++++++++++++++++++++
>  1 file changed, 46 insertions(+)
>  create mode 100644 package/waffle/0003-drop-C-dependency.patch

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 14, 2022, 10:26 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Drop C++ dependency as nacl is disabled (and will be dropped by upstream
 > in next release) to avoid the following build failure raised since bump
 > to version 1.6.1 in commit 814f36fdcc39bbafa1e2aaf637c7c6b59e7f37dd:

 > CMake Error at /usr/share/cmake-3.22/Modules/CMakeTestCXXCompiler.cmake:62 (message):
 >   The C++ compiler

 >     "/usr/bin/clang++"

 >   is not able to compile a simple test program.

 > Fixes:
 >  - http://autobuild.buildroot.org/results/a702495074b0393682c619781c349ce62e123133

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x, thanks.
diff mbox series

Patch

diff --git a/package/waffle/0003-drop-C-dependency.patch b/package/waffle/0003-drop-C-dependency.patch
new file mode 100644
index 0000000000..89c0cd09f2
--- /dev/null
+++ b/package/waffle/0003-drop-C-dependency.patch
@@ -0,0 +1,46 @@ 
+From a54a5d086c5f7e0751f68ac1a2942d8077922ebc Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 7 Aug 2022 16:18:22 +0200
+Subject: [PATCH] drop C++ dependency
+
+C++ dependency has been added for nacl backend which has been added by
+https://gitlab.freedesktop.org/mesa/waffle/-/commit/6ca943584e593aec2bd4f9c66d91859e63e02d61
+and dropped by
+https://gitlab.freedesktop.org/mesa/waffle/-/commit/a7c7152b054e6d2b9af36ed9db9a0df44731b279
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: not sent yet]
+---
+ CMakeLists.txt            | 2 +-
+ src/waffle/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index acece86..04ea68c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@
+ # OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ 
+-project(waffle1 C CXX)
++project(waffle1 C)
+ 
+ cmake_minimum_required(VERSION 2.8.12)
+ 
+diff --git a/src/waffle/CMakeLists.txt b/src/waffle/CMakeLists.txt
+index 8014b51..276f276 100644
+--- a/src/waffle/CMakeLists.txt
++++ b/src/waffle/CMakeLists.txt
+@@ -238,7 +238,7 @@ include_directories(
+     ${XCB_INCLUDE_DIRS}
+     )
+ 
+-add_library(${waffle_libname} SHARED ${waffle_sources} ${waffle_cxx_sources})
++add_library(${waffle_libname} SHARED ${waffle_sources})
+ 
+ # Debian's packaging system emits warnings if wflinfo directly links to any
+ # library that it doesn't directly use. Silence the warnings by annotating
+-- 
+2.35.1
+