diff mbox series

[1/1] package/rsyslog: imhttp needs apr-util

Message ID 20220807123652.3750380-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/rsyslog: imhttp needs apr-util | expand

Commit Message

Fabrice Fontaine Aug. 7, 2022, 12:36 p.m. UTC
imhttp needs apr-util since bump to version 8.2204.1 in commit
bc469ee6329555284b2fe9162597917122fbbe3a and
https://github.com/rsyslog/rsyslog/commit/a8b8d6c1f969286adac3d465e6ac018968550667
resulting in the following build failure:

configure: error: Package requirements (apr-util-1 >= 1.0) were not met:

Package 'apr-util-1', required by 'virtual:world', not found

Instead of having the user needs to figure out that apr-util is needed
for imhttp support, have the top-level rsyslog option selects apr-util
when civetweb-lib is enabled

Fixes:
 - http://autobuild.buildroot.org/results/4454ae5321df0c04c9dee19693f3908e69fbf23d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/rsyslog/Config.in  | 1 +
 package/rsyslog/rsyslog.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Sept. 14, 2022, 9:15 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > imhttp needs apr-util since bump to version 8.2204.1 in commit
 > bc469ee6329555284b2fe9162597917122fbbe3a and
 > https://github.com/rsyslog/rsyslog/commit/a8b8d6c1f969286adac3d465e6ac018968550667
 > resulting in the following build failure:

 > configure: error: Package requirements (apr-util-1 >= 1.0) were not met:

 > Package 'apr-util-1', required by 'virtual:world', not found

 > Instead of having the user needs to figure out that apr-util is needed
 > for imhttp support, have the top-level rsyslog option selects apr-util
 > when civetweb-lib is enabled

 > Fixes:
 >  - http://autobuild.buildroot.org/results/4454ae5321df0c04c9dee19693f3908e69fbf23d

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/rsyslog/Config.in b/package/rsyslog/Config.in
index 8c024e69c7..3ba326191a 100644
--- a/package/rsyslog/Config.in
+++ b/package/rsyslog/Config.in
@@ -8,6 +8,7 @@  config BR2_PACKAGE_RSYSLOG
 	# even though rsyslog already depends on threads for itself:
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4 || BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
+	select BR2_PACKAGE_APR_UTIL if BR2_PACKAGE_CIVETWEB_LIB
 	select BR2_PACKAGE_ZLIB
 	select BR2_PACKAGE_LIBESTR
 	select BR2_PACKAGE_LIBLOGGING
diff --git a/package/rsyslog/rsyslog.mk b/package/rsyslog/rsyslog.mk
index b87ab891da..84fd2d2e5e 100644
--- a/package/rsyslog/rsyslog.mk
+++ b/package/rsyslog/rsyslog.mk
@@ -53,7 +53,7 @@  RSYSLOG_CONF_OPTS += \
 endif
 
 ifeq ($(BR2_PACKAGE_CIVETWEB_LIB),y)
-RSYSLOG_DEPENDENCIES += civetweb
+RSYSLOG_DEPENDENCIES += apr-util civetweb
 RSYSLOG_CONF_OPTS += --enable-imhttp
 else
 RSYSLOG_CONF_OPTS += --disable-imhttp