diff mbox series

[2/3] package/qoriq-cadence-dp-firmware: add install in target

Message ID 20220731094808.1347975-3-francois.perrad@gadz.org
State Superseded
Headers show
Series new board LS1028ARDB | expand

Commit Message

Francois Perrad July 31, 2022, 9:48 a.m. UTC
this firmware must be installed with the kernel,
there are 2 cases:
- in $(TARGET_DIR)/boot
- in $(BINARIES), in order to be bundled into a boot partition

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 .../qoriq-cadence-dp-firmware/qoriq-cadence-dp-firmware.mk  | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Giulio Benetti Aug. 2, 2022, 9:34 p.m. UTC | #1
Hi Francois,

On 31/07/22 11:48, fperrad at gmail.com (Francois Perrad) wrote:
> this firmware must be installed with the kernel,
> there are 2 cases:
> - in $(TARGET_DIR)/boot
> - in $(BINARIES), in order to be bundled into a boot partition

What about:
"
This patch adds the built firmware to $(TARGET_DIR)/boot other than
to $(BINARIES) folder. This is needed in the case 
BR2_LINUX_KERNEL_INSTALL_TARGET is not set
"

Is it like this ^^^?

Best regards
diff mbox series

Patch

diff --git a/package/qoriq-cadence-dp-firmware/qoriq-cadence-dp-firmware.mk b/package/qoriq-cadence-dp-firmware/qoriq-cadence-dp-firmware.mk
index 23643d24e..a8172cb1d 100644
--- a/package/qoriq-cadence-dp-firmware/qoriq-cadence-dp-firmware.mk
+++ b/package/qoriq-cadence-dp-firmware/qoriq-cadence-dp-firmware.mk
@@ -10,8 +10,10 @@  QORIQ_CADENCE_DP_FIRMWARE_SOURCE = firmware-cadence-$(QORIQ_CADENCE_DP_FIRMWARE_
 QORIQ_CADENCE_DP_FIRMWARE_LICENSE = NXP-Binary-EULA
 QORIQ_CADENCE_DP_FIRMWARE_LICENSE_FILES = COPYING
 QORIQ_CADENCE_DP_FIRMWARE_REDISTRIBUTE = NO
+ifeq ($(BR2_LINUX_KERNEL_INSTALL_TARGET),)
 QORIQ_CADENCE_DP_FIRMWARE_INSTALL_IMAGES = YES
 QORIQ_CADENCE_DP_FIRMWARE_INSTALL_TARGET = NO
+endif
 
 # Helper for self-extracting binaries distributed by NXP.
 #
@@ -42,6 +44,10 @@  define QORIQ_CADENCE_DP_FIRMWARE_EXTRACT_CMDS
 	$(call QORIQ_CADENCE_DP_FIRMWARE_EXTRACT_HELPER,$(QORIQ_CADENCE_DP_FIRMWARE_DL_DIR)/$(QORIQ_CADENCE_DP_FIRMWARE_SOURCE))
 endef
 
+define QORIQ_CADENCE_DP_FIRMWARE_INSTALL_TARGET_CMDS
+	$(INSTALL) -D -m 0644 $(@D)/dp/ls1028a-dp-fw.bin $(TARGET_DIR)/boot/ls1028a-dp-fw.bin
+endef
+
 define QORIQ_CADENCE_DP_FIRMWARE_INSTALL_IMAGES_CMDS
 	$(INSTALL) -D -m 0644 $(@D)/dp/ls1028a-dp-fw.bin $(BINARIES_DIR)/ls1028a-dp-fw.bin
 endef