diff mbox series

[1/1] package/pkg-autotools: fix runtime path

Message ID 20220729114137.7774-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/pkg-autotools: fix runtime path | expand

Commit Message

Fabrice Fontaine July 29, 2022, 11:41 a.m. UTC
Commit 505b5a6cdd337c2fd5965aa875a1a53419d62ed1 wrongly stated that "a
configure script bundled with a package may be generated with an older
version of Autotools, that may not yet support the --runstatedir option.
This will give an "Unsupported arguments" warning and the option will be
ignored.". Indeed, this will raise the following build failure with
attr, libtirpc, readline, etc.:

configure: error: unrecognized option: `--runstatedir=/run'

So to support configure scripts using older version, the variable is set
directly instead of using the --runstatedir argument.

Fixes:
 - http://autobuild.buildroot.org/results/c853f14773d875be30e32ae24daf80e181fef34e
 - http://autobuild.buildroot.org/results/045211cd66cf78c3d89d2d8ac41ec4edf0b0ee58
 - http://autobuild.buildroot.org/results/8c5160eef99de2f1f72f33d5e5ea94d417855b2c

This reverts commit 505b5a6cdd337c2fd5965aa875a1a53419d62ed1.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pkg-autotools.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 29, 2022, 12:30 p.m. UTC | #1
Hello Fabrice,

On Fri, 29 Jul 2022 13:41:37 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit 505b5a6cdd337c2fd5965aa875a1a53419d62ed1 wrongly stated that "a
> configure script bundled with a package may be generated with an older
> version of Autotools, that may not yet support the --runstatedir option.
> This will give an "Unsupported arguments" warning and the option will be
> ignored.". Indeed, this will raise the following build failure with
> attr, libtirpc, readline, etc.:
> 
> configure: error: unrecognized option: `--runstatedir=/run'
> 
> So to support configure scripts using older version, the variable is set
> directly instead of using the --runstatedir argument.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/c853f14773d875be30e32ae24daf80e181fef34e
>  - http://autobuild.buildroot.org/results/045211cd66cf78c3d89d2d8ac41ec4edf0b0ee58
>  - http://autobuild.buildroot.org/results/8c5160eef99de2f1f72f33d5e5ea94d417855b2c
> 
> This reverts commit 505b5a6cdd337c2fd5965aa875a1a53419d62ed1.

Thanks for the fix, but you are not reverting
505b5a6cdd337c2fd5965aa875a1a53419d62ed1. Commit
505b5a6cdd337c2fd5965aa875a1a53419d62ed1 added --runstatedir=/run, you
are changing it to runstatedir=/run. So yes, you are reverting to the
initial patch proposal, but strictly speaking, your patch is not
reverting 505b5a6cdd337c2fd5965aa875a1a53419d62ed1, i.e git revert
505b5a6cdd337c2fd5965aa875a1a53419d62ed1 would not have the same effect
as your patch.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 548f69cbb8..b6224b349d 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -187,7 +187,7 @@  define $(2)_CONFIGURE_CMDS
 		--exec-prefix=/usr \
 		--sysconfdir=/etc \
 		--localstatedir=/var \
-		--runstatedir=/run \
+		runstatedir=/run \
 		--program-prefix="" \
 		--disable-gtk-doc \
 		--disable-gtk-doc-html \