diff mbox series

package/zsh: add more cache variables for TRY_RUN

Message ID 20220728191648.1201217-1-arnout@mind.be
State Accepted
Headers show
Series package/zsh: add more cache variables for TRY_RUN | expand

Commit Message

Arnout Vandecappelle July 28, 2022, 7:16 p.m. UTC
It turns out that zsh has a number of additional TRY_RUN calls. We
already set a few with cache variables, add a few more. They are found
based on reading the configure.ac, aczsh.m4, and the configure output.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Phil Eichinger <phil.eichinger@gmail.com>
Cc: Norbert Lange <nolange79@gmail.com>
---
 package/zsh/zsh.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni July 28, 2022, 9:01 p.m. UTC | #1
On Thu, 28 Jul 2022 21:16:48 +0200
"Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be> wrote:

> It turns out that zsh has a number of additional TRY_RUN calls. We
> already set a few with cache variables, add a few more. They are found
> based on reading the configure.ac, aczsh.m4, and the configure output.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Cc: Phil Eichinger <phil.eichinger@gmail.com>
> Cc: Norbert Lange <nolange79@gmail.com>
> ---
>  package/zsh/zsh.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/zsh/zsh.mk b/package/zsh/zsh.mk
index 4897620a00..688c6366e8 100644
--- a/package/zsh/zsh.mk
+++ b/package/zsh/zsh.mk
@@ -14,6 +14,14 @@  ZSH_LICENSE = MIT-like
 ZSH_LICENSE_FILES = LICENCE
 ZSH_CPE_ID_VENDOR = zsh
 
+# zsh uses TRY_RUN to determine these
+ZSH_CONF_OPTS += \
+	zsh_cv_long_is_64_bit=$(if $(BR2_ARCH_IS_64),yes,no) \
+	zsh_cv_off_t_is_64_bit=yes \
+	zsh_cv_64_bit_type='long long' \
+	zsh_cv_64_bit_utype='unsigned long long' \
+	zsh_cv_printf_has_lld=yes
+
 ifeq ($(BR2_PACKAGE_GDBM),y)
 ZSH_CONF_OPTS += --enable-gdbm
 ZSH_DEPENDENCIES += gdbm