diff mbox series

[4/5] package/binutils: remove BR2_BINUTILS_ENABLE_LTO

Message ID 20220725152229.3370033-4-arnout@mind.be
State Accepted
Headers show
Series [1/5] Config.in: add new option BR2_ENABLE_LTO to globally enable LTO | expand

Commit Message

Arnout Vandecappelle July 25, 2022, 3:22 p.m. UTC
Currently, this option doesn't do anything. It only adds
--enable-plugins --enable-lto to the configure flags, but doesn't
disable them if it is not set. Since both of these default to enabled,
plugins and lto are effectively always enabled.

There really is no need to make this configurable: it adds a bit of size
and build time to host-binutils, but we don't care about that for host
tools. It's still up to individual builds to enable the LTO options.

Therefore, remove the option entirely. For clarity, explicitly pass
--enable-plugins --enable-lto to configure.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/binutils/Config.in.host | 3 ---
 package/binutils/binutils.mk    | 6 ++----
 package/gcc/Config.in.host      | 1 -
 3 files changed, 2 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/package/binutils/Config.in.host b/package/binutils/Config.in.host
index ef1b2a94db..5bdda25faf 100644
--- a/package/binutils/Config.in.host
+++ b/package/binutils/Config.in.host
@@ -35,9 +35,6 @@  config BR2_BINUTILS_VERSION
 	default "2.37"		if BR2_BINUTILS_VERSION_2_37_X
 	default "2.38"		if BR2_BINUTILS_VERSION_2_38_X
 
-config BR2_BINUTILS_ENABLE_LTO
-	bool
-
 config BR2_BINUTILS_EXTRA_CONFIG_OPTIONS
 	string "Additional binutils options"
 	default ""
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index c94ebe0995..6362cb1641 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -86,6 +86,8 @@  HOST_BINUTILS_CONF_OPTS = \
 	--with-sysroot=$(STAGING_DIR) \
 	--enable-poison-system-directories \
 	--without-debuginfod \
+	--enable-plugins \
+	--enable-lto \
 	$(BINUTILS_DISABLE_GDB_CONF_OPTS) \
 	$(BINUTILS_EXTRA_CONFIG_OPTIONS)
 
@@ -120,10 +122,6 @@  HOST_BINUTILS_POST_EXTRACT_HOOKS += BINUTILS_XTENSA_OVERLAY_EXTRACT
 HOST_BINUTILS_EXTRA_DOWNLOADS += $(ARCH_XTENSA_OVERLAY_URL)
 endif
 
-ifeq ($(BR2_BINUTILS_ENABLE_LTO),y)
-HOST_BINUTILS_CONF_OPTS += --enable-plugins --enable-lto
-endif
-
 # Hardlinks between binaries in different directories cause a problem
 # with rpath fixup, so we de-hardlink those binaries, and replace them
 # with copies instead.
diff --git a/package/gcc/Config.in.host b/package/gcc/Config.in.host
index a7e237c3f7..20187db6fd 100644
--- a/package/gcc/Config.in.host
+++ b/package/gcc/Config.in.host
@@ -132,7 +132,6 @@  config BR2_TOOLCHAIN_BUILDROOT_DLANG
 
 config BR2_GCC_ENABLE_LTO
 	bool "Enable compiler link-time-optimization support"
-	select BR2_BINUTILS_ENABLE_LTO
 	help
 	  This option enables link-time optimization (LTO) support in
 	  gcc.