diff mbox series

[11/16] utils/check-package: check files in utils/

Message ID 20220724054912.2354219-12-ricardo.martincoski@gmail.com
State Changes Requested
Headers show
Series Preventing style regressions using check-package | expand

Commit Message

Ricardo Martincoski July 24, 2022, 5:49 a.m. UTC
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
NOTE to the maintainer applying this patch: please re-generate the list
of ignored warnings while applying:
$ ./utils/docker-run
br-user@...$ ./utils/check-package --failed-only `git ls-tree -r --name-only HEAD` > .checkpackageignore
---
 .checkpackageignore | 4 ++++
 utils/check-package | 1 +
 2 files changed, 5 insertions(+)

Comments

Arnout Vandecappelle April 9, 2023, 9:02 p.m. UTC | #1
On 24/07/2022 07:49, Ricardo Martincoski wrote:
> Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
> ---
> NOTE to the maintainer applying this patch: please re-generate the list
> of ignored warnings while applying:
> $ ./utils/docker-run
> br-user@...$ ./utils/check-package --failed-only `git ls-tree -r --name-only HEAD` > .checkpackageignore

  Applied to master after updating the ignore list, thanks.

  Regards,
  Arnout

> ---
>   .checkpackageignore | 4 ++++
>   utils/check-package | 1 +
>   2 files changed, 5 insertions(+)
> 
> diff --git a/.checkpackageignore b/.checkpackageignore
> index 541f234bfd..765e5c1cba 100644
> --- a/.checkpackageignore
> +++ b/.checkpackageignore
> @@ -940,3 +940,7 @@ toolchain/toolchain-external/toolchain-external-linaro-aarch64/toolchain-externa
>   toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.hash HashSpaces
>   toolchain/toolchain-external/toolchain-external-linaro-armeb/toolchain-external-linaro-armeb.hash HashSpaces
>   toolchain/toolchain-external/toolchain-external-synopsys-arc/toolchain-external-synopsys-arc.hash HashSpaces
> +utils/brmake Shellcheck
> +utils/config Shellcheck
> +utils/docker-run Shellcheck
> +utils/test-pkg Shellcheck
> diff --git a/utils/check-package b/utils/check-package
> index 6612cee24e..880fcfa21e 100755
> --- a/utils/check-package
> +++ b/utils/check-package
> @@ -107,6 +107,7 @@ DO_CHECK_INTREE = re.compile(r"|".join([
>       r"package/",
>       r"system/",
>       r"toolchain/",
> +    r"utils/",
>       ]))
>   DO_NOT_CHECK_INTREE = re.compile(r"|".join([
>       r"boot/barebox/barebox\.mk$",
diff mbox series

Patch

diff --git a/.checkpackageignore b/.checkpackageignore
index 541f234bfd..765e5c1cba 100644
--- a/.checkpackageignore
+++ b/.checkpackageignore
@@ -940,3 +940,7 @@  toolchain/toolchain-external/toolchain-external-linaro-aarch64/toolchain-externa
 toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.hash HashSpaces
 toolchain/toolchain-external/toolchain-external-linaro-armeb/toolchain-external-linaro-armeb.hash HashSpaces
 toolchain/toolchain-external/toolchain-external-synopsys-arc/toolchain-external-synopsys-arc.hash HashSpaces
+utils/brmake Shellcheck
+utils/config Shellcheck
+utils/docker-run Shellcheck
+utils/test-pkg Shellcheck
diff --git a/utils/check-package b/utils/check-package
index 6612cee24e..880fcfa21e 100755
--- a/utils/check-package
+++ b/utils/check-package
@@ -107,6 +107,7 @@  DO_CHECK_INTREE = re.compile(r"|".join([
     r"package/",
     r"system/",
     r"toolchain/",
+    r"utils/",
     ]))
 DO_NOT_CHECK_INTREE = re.compile(r"|".join([
     r"boot/barebox/barebox\.mk$",