diff mbox series

package/zfs: fix pam support

Message ID 20220723134249.268212-1-arnout@mind.be
State Accepted
Headers show
Series package/zfs: fix pam support | expand

Commit Message

Arnout Vandecappelle July 23, 2022, 1:42 p.m. UTC
The --enable option was added to CONF_ENV instead of CONF_OPTS. For this
defconfig

BR2_arm=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_LINUX_KERNEL=y
BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
BR2_PACKAGE_ZFS=y
BR2_PACKAGE_LINUX_PAM=y

this yields

/bin/sh: line 1: --enable-pam=yes: command not found

While we're at it, also remove the =yes which we usually don't add.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/zfs/zfs.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN July 23, 2022, 3:04 p.m. UTC | #1
Arnout, All,

On 2022-07-23 15:42 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
> The --enable option was added to CONF_ENV instead of CONF_OPTS. For this
> defconfig
> 
> BR2_arm=y
> BR2_TOOLCHAIN_EXTERNAL=y
> BR2_LINUX_KERNEL=y
> BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
> BR2_PACKAGE_ZFS=y
> BR2_PACKAGE_LINUX_PAM=y
> 
> this yields
> 
> /bin/sh: line 1: --enable-pam=yes: command not found
> 
> While we're at it, also remove the =yes which we usually don't add.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/zfs/zfs.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
> index 07ce3295ec..0a6e4a3cfa 100644
> --- a/package/zfs/zfs.mk
> +++ b/package/zfs/zfs.mk
> @@ -52,7 +52,7 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
>  ZFS_DEPENDENCIES += linux-pam
> -ZFS_CONF_ENV += --enable-pam=yes
> +ZFS_CONF_OPTS += --enable-pam
>  else
>  ZFS_CONF_OPTS += --disable-pam
>  endif
> -- 
> 2.35.3
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Aug. 14, 2022, 7:01 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 > The --enable option was added to CONF_ENV instead of CONF_OPTS. For this
 > defconfig

 > BR2_arm=y
 > BR2_TOOLCHAIN_EXTERNAL=y
 > BR2_LINUX_KERNEL=y
 > BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
 > BR2_PACKAGE_ZFS=y
 > BR2_PACKAGE_LINUX_PAM=y

 > this yields

 > /bin/sh: line 1: --enable-pam=yes: command not found

 > While we're at it, also remove the =yes which we usually don't add.

 > Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
index 07ce3295ec..0a6e4a3cfa 100644
--- a/package/zfs/zfs.mk
+++ b/package/zfs/zfs.mk
@@ -52,7 +52,7 @@  endif
 
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 ZFS_DEPENDENCIES += linux-pam
-ZFS_CONF_ENV += --enable-pam=yes
+ZFS_CONF_OPTS += --enable-pam
 else
 ZFS_CONF_OPTS += --disable-pam
 endif