diff mbox series

[1/3] boot/uboot: add BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX option

Message ID 20220719190051.555180-1-heiko.thiery@gmail.com
State Accepted
Headers show
Series [1/3] boot/uboot: add BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX option | expand

Commit Message

Heiko Thiery July 19, 2022, 7 p.m. UTC
Since U-Boot 2022.04 a host dependency to util-linux (-luuid) is required if
the U-Boot board configuration has CONFIG_TOOLS_MKEFICAPSULE enabled. So
introduce a new BR U-Boot config option
BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX to solve this problem.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 boot/uboot/Config.in | 8 ++++++++
 boot/uboot/uboot.mk  | 4 ++++
 2 files changed, 12 insertions(+)

Comments

Yann E. MORIN July 19, 2022, 8:47 p.m. UTC | #1
Heiko, All,

On 2022-07-19 21:00 +0200, Heiko Thiery spake thusly:
> Since U-Boot 2022.04 a host dependency to util-linux (-luuid) is required if
> the U-Boot board configuration has CONFIG_TOOLS_MKEFICAPSULE enabled. So
> introduce a new BR U-Boot config option
> BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX to solve this problem.
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
>  boot/uboot/Config.in | 8 ++++++++
>  boot/uboot/uboot.mk  | 4 ++++
>  2 files changed, 12 insertions(+)
> 
> diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
> index 91d98c7e63..340b2d17ff 100644
> --- a/boot/uboot/Config.in
> +++ b/boot/uboot/Config.in
> @@ -190,6 +190,14 @@ config BR2_TARGET_UBOOT_NEEDS_GNUTLS
>  	  typically the case when the board configuration has
>  	  CONFIG_TOOLS_MKEFICAPSULE enabled.
>  
> +config BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX
> +	bool "U-Boot needs util-linux"
> +	help
> +	  Select this option if your U-Boot board configuration
> +	  requires util-linux (-luuid) to be available on the host. This is
> +	  typically the case when the board configuration has
> +	  CONFIG_TOOLS_MKEFICAPSULE enabled.

    $ make check-package
    boot/uboot/Config.in:197: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in)

Fixed, and applied to master, as well as the two following patches.
Thanks.

Regards,
Yann E. MORIN.

>  config BR2_TARGET_UBOOT_NEEDS_ATF_BL31
>  	bool "U-Boot needs ATF BL31"
>  	depends on BR2_TARGET_ARM_TRUSTED_FIRMWARE
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index 5808e30818..70d4d585f7 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -231,6 +231,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_GNUTLS),y)
>  UBOOT_DEPENDENCIES += host-gnutls
>  endif
>  
> +ifeq ($(BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX),y)
> +UBOOT_DEPENDENCIES += host-util-linux
> +endif
> +
>  # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
>  # legal-info finds it
>  define UBOOT_COPY_OLD_LICENSE_FILE
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 91d98c7e63..340b2d17ff 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -190,6 +190,14 @@  config BR2_TARGET_UBOOT_NEEDS_GNUTLS
 	  typically the case when the board configuration has
 	  CONFIG_TOOLS_MKEFICAPSULE enabled.
 
+config BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX
+	bool "U-Boot needs util-linux"
+	help
+	  Select this option if your U-Boot board configuration
+	  requires util-linux (-luuid) to be available on the host. This is
+	  typically the case when the board configuration has
+	  CONFIG_TOOLS_MKEFICAPSULE enabled.
+
 config BR2_TARGET_UBOOT_NEEDS_ATF_BL31
 	bool "U-Boot needs ATF BL31"
 	depends on BR2_TARGET_ARM_TRUSTED_FIRMWARE
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 5808e30818..70d4d585f7 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -231,6 +231,10 @@  ifeq ($(BR2_TARGET_UBOOT_NEEDS_GNUTLS),y)
 UBOOT_DEPENDENCIES += host-gnutls
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX),y)
+UBOOT_DEPENDENCIES += host-util-linux
+endif
+
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE