diff mbox series

package/libcamera: bump to latest master commit ba6435930f08e802cffc688d90f156a8959a0f86

Message ID 20220707093734.34465-1-foss+buildroot@0leil.net
State Accepted
Headers show
Series package/libcamera: bump to latest master commit ba6435930f08e802cffc688d90f156a8959a0f86 | expand

Commit Message

Quentin Schulz July 7, 2022, 9:37 a.m. UTC
From: Quentin Schulz <quentin.schulz@theobroma-systems.com>

This brings in support for OV5675 and IMX477 camera sensors, exposes
autofocus controls through the libcamera API, adds support for more
pixel and media bus formats, fixes AWB on IPU3, improves gstreamer
support and numerous other improvements and fixes.

Since commit fcb0ea001a2d "libcamera: Introduce YamlParser as a helper
to parse yaml files", libyaml is a required dependency since YAML is
used for configuration/tuning files.

Cc: Quentin Schulz <foss+buildroot@0leil.net>
Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
---
 package/libcamera/Config.in      | 1 +
 package/libcamera/libcamera.hash | 2 +-
 package/libcamera/libcamera.mk   | 3 ++-
 3 files changed, 4 insertions(+), 2 deletions(-)

Comments

Kieran Bingham July 11, 2022, 11:31 a.m. UTC | #1
Quoting Quentin Schulz (2022-07-07 10:37:34)
> From: Quentin Schulz <quentin.schulz@theobroma-systems.com>
> 
> This brings in support for OV5675 and IMX477 camera sensors, exposes
> autofocus controls through the libcamera API, adds support for more
> pixel and media bus formats, fixes AWB on IPU3, improves gstreamer
> support and numerous other improvements and fixes.
> 
> Since commit fcb0ea001a2d "libcamera: Introduce YamlParser as a helper
> to parse yaml files", libyaml is a required dependency since YAML is
> used for configuration/tuning files.
> 

Thanks, nicely summarised.

> Cc: Quentin Schulz <foss+buildroot@0leil.net>
> Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>

Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>

> ---
>  package/libcamera/Config.in      | 1 +
>  package/libcamera/libcamera.hash | 2 +-
>  package/libcamera/libcamera.mk   | 3 ++-
>  3 files changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/package/libcamera/Config.in b/package/libcamera/Config.in
> index fd7b3c92c4..0febfef4bc 100644
> --- a/package/libcamera/Config.in
> +++ b/package/libcamera/Config.in
> @@ -14,6 +14,7 @@ menuconfig BR2_PACKAGE_LIBCAMERA
>         depends on !BR2_STATIC_LIBS # gnutls
>         depends on BR2_USE_WCHAR # gnutls
>         select BR2_PACKAGE_GNUTLS
> +       select BR2_PACKAGE_LIBYAML
>         select BR2_PACKAGE_LIBCAMERA_PIPELINE_UVCVIDEO if !BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
>         help
>           libcamera provides a software stack to support
> diff --git a/package/libcamera/libcamera.hash b/package/libcamera/libcamera.hash
> index 181bb1349a..68c9c1f005 100644
> --- a/package/libcamera/libcamera.hash
> +++ b/package/libcamera/libcamera.hash
> @@ -1,4 +1,4 @@
> -sha256  9aa62d41470238ac8c3bb847601d1a803ac7a270d3b5e87f722e9c93c867d18d  libcamera-8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98-br1.tar.gz
> +sha256  59318208a9c1b183cacaf5a7175568d8a9fa094f2dd8c9794269bb6e9636986e  libcamera-ba6435930f08e802cffc688d90f156a8959a0f86-br1.tar.gz
>  
>  # license files
>  sha256  fd38b2c053c0cce46d9c5ef3545a6e34d157a240ba99c9b8dca5d37a8147da6c  LICENSES/BSD-2-Clause.txt
> diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
> index 41d6a5abef..58f7307a23 100644
> --- a/package/libcamera/libcamera.mk
> +++ b/package/libcamera/libcamera.mk
> @@ -5,7 +5,7 @@
>  ################################################################################
>  
>  LIBCAMERA_SITE = https://git.linuxtv.org/libcamera.git
> -LIBCAMERA_VERSION = 8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98
> +LIBCAMERA_VERSION = ba6435930f08e802cffc688d90f156a8959a0f86
>  LIBCAMERA_SITE_METHOD = git
>  LIBCAMERA_DEPENDENCIES = \
>         host-openssl \
> @@ -13,6 +13,7 @@ LIBCAMERA_DEPENDENCIES = \
>         host-python-jinja2 \
>         host-python-ply \
>         host-python-pyyaml \
> +       libyaml \
>         gnutls
>  LIBCAMERA_CONF_OPTS = \
>         -Dandroid=disabled \
> -- 
> 2.36.1
>
Yann E. MORIN July 17, 2022, 1 p.m. UTC | #2
Quentin, All,

On 2022-07-07 11:37 +0200, Quentin Schulz spake thusly:
> From: Quentin Schulz <quentin.schulz@theobroma-systems.com>
> 
> This brings in support for OV5675 and IMX477 camera sensors, exposes
> autofocus controls through the libcamera API, adds support for more
> pixel and media bus formats, fixes AWB on IPU3, improves gstreamer
> support and numerous other improvements and fixes.
> 
> Since commit fcb0ea001a2d "libcamera: Introduce YamlParser as a helper
> to parse yaml files", libyaml is a required dependency since YAML is
> used for configuration/tuning files.
> 
> Cc: Quentin Schulz <foss+buildroot@0leil.net>
> Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libcamera/Config.in      | 1 +
>  package/libcamera/libcamera.hash | 2 +-
>  package/libcamera/libcamera.mk   | 3 ++-
>  3 files changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/package/libcamera/Config.in b/package/libcamera/Config.in
> index fd7b3c92c4..0febfef4bc 100644
> --- a/package/libcamera/Config.in
> +++ b/package/libcamera/Config.in
> @@ -14,6 +14,7 @@ menuconfig BR2_PACKAGE_LIBCAMERA
>  	depends on !BR2_STATIC_LIBS # gnutls
>  	depends on BR2_USE_WCHAR # gnutls
>  	select BR2_PACKAGE_GNUTLS
> +	select BR2_PACKAGE_LIBYAML
>  	select BR2_PACKAGE_LIBCAMERA_PIPELINE_UVCVIDEO if !BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
>  	help
>  	  libcamera provides a software stack to support
> diff --git a/package/libcamera/libcamera.hash b/package/libcamera/libcamera.hash
> index 181bb1349a..68c9c1f005 100644
> --- a/package/libcamera/libcamera.hash
> +++ b/package/libcamera/libcamera.hash
> @@ -1,4 +1,4 @@
> -sha256  9aa62d41470238ac8c3bb847601d1a803ac7a270d3b5e87f722e9c93c867d18d  libcamera-8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98-br1.tar.gz
> +sha256  59318208a9c1b183cacaf5a7175568d8a9fa094f2dd8c9794269bb6e9636986e  libcamera-ba6435930f08e802cffc688d90f156a8959a0f86-br1.tar.gz
>  
>  # license files
>  sha256  fd38b2c053c0cce46d9c5ef3545a6e34d157a240ba99c9b8dca5d37a8147da6c  LICENSES/BSD-2-Clause.txt
> diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
> index 41d6a5abef..58f7307a23 100644
> --- a/package/libcamera/libcamera.mk
> +++ b/package/libcamera/libcamera.mk
> @@ -5,7 +5,7 @@
>  ################################################################################
>  
>  LIBCAMERA_SITE = https://git.linuxtv.org/libcamera.git
> -LIBCAMERA_VERSION = 8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98
> +LIBCAMERA_VERSION = ba6435930f08e802cffc688d90f156a8959a0f86
>  LIBCAMERA_SITE_METHOD = git
>  LIBCAMERA_DEPENDENCIES = \
>  	host-openssl \
> @@ -13,6 +13,7 @@ LIBCAMERA_DEPENDENCIES = \
>  	host-python-jinja2 \
>  	host-python-ply \
>  	host-python-pyyaml \
> +	libyaml \
>  	gnutls
>  LIBCAMERA_CONF_OPTS = \
>  	-Dandroid=disabled \
> -- 
> 2.36.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libcamera/Config.in b/package/libcamera/Config.in
index fd7b3c92c4..0febfef4bc 100644
--- a/package/libcamera/Config.in
+++ b/package/libcamera/Config.in
@@ -14,6 +14,7 @@  menuconfig BR2_PACKAGE_LIBCAMERA
 	depends on !BR2_STATIC_LIBS # gnutls
 	depends on BR2_USE_WCHAR # gnutls
 	select BR2_PACKAGE_GNUTLS
+	select BR2_PACKAGE_LIBYAML
 	select BR2_PACKAGE_LIBCAMERA_PIPELINE_UVCVIDEO if !BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
 	help
 	  libcamera provides a software stack to support
diff --git a/package/libcamera/libcamera.hash b/package/libcamera/libcamera.hash
index 181bb1349a..68c9c1f005 100644
--- a/package/libcamera/libcamera.hash
+++ b/package/libcamera/libcamera.hash
@@ -1,4 +1,4 @@ 
-sha256  9aa62d41470238ac8c3bb847601d1a803ac7a270d3b5e87f722e9c93c867d18d  libcamera-8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98-br1.tar.gz
+sha256  59318208a9c1b183cacaf5a7175568d8a9fa094f2dd8c9794269bb6e9636986e  libcamera-ba6435930f08e802cffc688d90f156a8959a0f86-br1.tar.gz
 
 # license files
 sha256  fd38b2c053c0cce46d9c5ef3545a6e34d157a240ba99c9b8dca5d37a8147da6c  LICENSES/BSD-2-Clause.txt
diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
index 41d6a5abef..58f7307a23 100644
--- a/package/libcamera/libcamera.mk
+++ b/package/libcamera/libcamera.mk
@@ -5,7 +5,7 @@ 
 ################################################################################
 
 LIBCAMERA_SITE = https://git.linuxtv.org/libcamera.git
-LIBCAMERA_VERSION = 8a845ab078c3fe12ac4edd16c8cbac5b7ec03b98
+LIBCAMERA_VERSION = ba6435930f08e802cffc688d90f156a8959a0f86
 LIBCAMERA_SITE_METHOD = git
 LIBCAMERA_DEPENDENCIES = \
 	host-openssl \
@@ -13,6 +13,7 @@  LIBCAMERA_DEPENDENCIES = \
 	host-python-jinja2 \
 	host-python-ply \
 	host-python-pyyaml \
+	libyaml \
 	gnutls
 LIBCAMERA_CONF_OPTS = \
 	-Dandroid=disabled \