diff mbox series

[1/1] package/libnetconf2: doesn't build with libressl

Message ID 20220611145715.879538-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libnetconf2: doesn't build with libressl | expand

Commit Message

Fabrice Fontaine June 11, 2022, 2:57 p.m. UTC
libnetconf2 doesn't build with libressl which doesn't provide
X509_STORE_CTX_get1_certs resulting in the following build failure with
netopeer2:

[100%] Linking C executable netopeer2-server
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/microblaze-buildroot-linux-gnu/11.2.0/../../../../microblaze-buildroot-linux-gnu/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/microblaze-buildroot-linux-gnu/sysroot/usr/lib/libnetconf2.so: undefined reference to `X509_STORE_CTX_get1_certs'

Fixes:
 - http://autobuild.buildroot.org/results/7f9a114a477e859dfbc62a53ab66c58eddb2318b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libnetconf2/libnetconf2.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN June 12, 2022, 3:50 p.m. UTC | #1
Fabrice, All,

On 2022-06-11 16:57 +0200, Fabrice Fontaine spake thusly:
> libnetconf2 doesn't build with libressl which doesn't provide
> X509_STORE_CTX_get1_certs resulting in the following build failure with
> netopeer2:
> 
> [100%] Linking C executable netopeer2-server
> /home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/microblaze-buildroot-linux-gnu/11.2.0/../../../../microblaze-buildroot-linux-gnu/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/microblaze-buildroot-linux-gnu/sysroot/usr/lib/libnetconf2.so: undefined reference to `X509_STORE_CTX_get1_certs'
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/7f9a114a477e859dfbc62a53ab66c58eddb2318b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libnetconf2/libnetconf2.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libnetconf2/libnetconf2.mk b/package/libnetconf2/libnetconf2.mk
> index 11a1995ea1..00d2c08f63 100644
> --- a/package/libnetconf2/libnetconf2.mk
> +++ b/package/libnetconf2/libnetconf2.mk
> @@ -23,7 +23,7 @@ else
>  LIBNETCONF2_CONF_OPTS += -DENABLE_SSH=OFF
>  endif
>  
> -ifeq ($(BR2_PACKAGE_OPENSSL), y)
> +ifeq ($(BR2_PACKAGE_LIBOPENSSL), y)

I was wondering if libnetconf2 should instead just select
BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL so that it is obvious in the
menuconfig.

I mena, by selecting BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL, a user who
enables openssl will see that libressl is not availble, while with your
solution, openssl is enabled with libressl, yet libnetconf2 is not built
with ssl support, which can be a bit confusing to some.

Yet, I am not sure what the proper solution is, and I cold not find a
precedent either way. So, applied to master, thanks.

Regards,
Yann E. MORIN.

>  LIBNETCONF2_CONF_OPTS += -DENABLE_TLS=ON
>  LIBNETCONF2_DEPENDENCIES += openssl
>  else
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard June 19, 2022, 1:37 p.m. UTC | #2
On 11/06/2022 16.57, Fabrice Fontaine wrote:
> libnetconf2 doesn't build with libressl which doesn't provide
> X509_STORE_CTX_get1_certs resulting in the following build failure with
> netopeer2:
> 
> [100%] Linking C executable netopeer2-server
> /home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/microblaze-buildroot-linux-gnu/11.2.0/../../../../microblaze-buildroot-linux-gnu/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/microblaze-buildroot-linux-gnu/sysroot/usr/lib/libnetconf2.so: undefined reference to `X509_STORE_CTX_get1_certs'
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/7f9a114a477e859dfbc62a53ab66c58eddb2318b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libnetconf2/libnetconf2.mk b/package/libnetconf2/libnetconf2.mk
index 11a1995ea1..00d2c08f63 100644
--- a/package/libnetconf2/libnetconf2.mk
+++ b/package/libnetconf2/libnetconf2.mk
@@ -23,7 +23,7 @@  else
 LIBNETCONF2_CONF_OPTS += -DENABLE_SSH=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_OPENSSL), y)
+ifeq ($(BR2_PACKAGE_LIBOPENSSL), y)
 LIBNETCONF2_CONF_OPTS += -DENABLE_TLS=ON
 LIBNETCONF2_DEPENDENCIES += openssl
 else