diff mbox series

[2/2] package/powerpc-utils: Bump to v1.3.10

Message ID 20220606085108.1628288-3-joel@jms.id.au
State Accepted
Headers show
Series powerpc utils and librtas bump | expand

Commit Message

Joel Stanley June 6, 2022, 8:51 a.m. UTC
Since v1.3.9 the package requires numa.h from numctl, so add this as a
dependency.

This bump fixes a missing limits.h for PATH_MAX when building with musl
as detected by the autobuilder.

librtas now builds fine with musl too, so remove the glibc restriction
for enabling that support.

Fixes:

 http://autobuild.buildroot.net/results/613ec647e251ac52a01f222044bd675ce36c1b5b/

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
 package/powerpc-utils/Config.in          | 5 +----
 package/powerpc-utils/powerpc-utils.hash | 2 +-
 package/powerpc-utils/powerpc-utils.mk   | 4 ++--
 3 files changed, 4 insertions(+), 7 deletions(-)

Comments

Arnout Vandecappelle June 6, 2022, 6:19 p.m. UTC | #1
Hi Joel,

On 06/06/2022 10:51, Joel Stanley wrote:
> Since v1.3.9 the package requires numa.h from numctl, so add this as a
> dependency.
> 
> This bump fixes a missing limits.h for PATH_MAX when building with musl
> as detected by the autobuilder.
> 
> librtas now builds fine with musl too, so remove the glibc restriction
> for enabling that support.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/613ec647e251ac52a01f222044bd675ce36c1b5b/

  Since we're about to release 2022.05, it's inconvenient to bump the package 
version...

  Also, it's not clear if this bump depends on the librtas bump. For sure, the 
removal of the glibc requirement does depend on it.

  Is there a possibility to backport the patch that fixes the build issue instead?

  Regards,
  Arnout


> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>
> ---
>   package/powerpc-utils/Config.in          | 5 +----
>   package/powerpc-utils/powerpc-utils.hash | 2 +-
>   package/powerpc-utils/powerpc-utils.mk   | 4 ++--
>   3 files changed, 4 insertions(+), 7 deletions(-)
> 
> diff --git a/package/powerpc-utils/Config.in b/package/powerpc-utils/Config.in
> index d04d81c08acb..9034ea2e0fdd 100644
> --- a/package/powerpc-utils/Config.in
> +++ b/package/powerpc-utils/Config.in
> @@ -7,6 +7,7 @@ config BR2_PACKAGE_POWERPC_UTILS
>   	depends on !BR2_STATIC_LIBS # dlfcn.h
>   	depends on BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
>   	select BR2_PACKAGE_ZLIB
> +	select BR2_PACKAGE_NUMACTL
>   	help
>   	  System utilities for PowerPC machines.
>   
> @@ -16,7 +17,6 @@ if BR2_PACKAGE_POWERPC_UTILS
>   
>   config BR2_PACKAGE_POWERPC_UTILS_RTAS
>   	bool "RTAS support"
> -	depends on BR2_TOOLCHAIN_USES_GLIBC
>   	select BR2_PACKAGE_LIBRTAS
>   	help
>   	  Enable support for functions that require RTAS.
> @@ -28,7 +28,4 @@ config BR2_PACKAGE_POWERPC_UTILS_RTAS
>   	  lsslot, activate_firmware, rtas_ibm_get_vpd, serv_config,
>   	  rtas_event_decode, sys_ident.
>   
> -comment "RTAS support needs a glibc toolchain"
> -	depends on !BR2_TOOLCHAIN_USES_GLIBC
> -
>   endif
> diff --git a/package/powerpc-utils/powerpc-utils.hash b/package/powerpc-utils/powerpc-utils.hash
> index 8d0b10425b6d..b3c77fb223ba 100644
> --- a/package/powerpc-utils/powerpc-utils.hash
> +++ b/package/powerpc-utils/powerpc-utils.hash
> @@ -1,3 +1,3 @@
>   # Locally calculated
> -sha256  4e3a21419863c08adde49f0795eff0fbfe4597ce82593fa5fe1f1177913fb7b9  powerpc-utils-1.3.8.tar.gz
> +sha256  d64d9016a3e63a1e44c6e0833742cf964ae6bb1c6a9c7f0c7c5748aa335dc3db  powerpc-utils-1.3.10.tar.gz
>   sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
> diff --git a/package/powerpc-utils/powerpc-utils.mk b/package/powerpc-utils/powerpc-utils.mk
> index b12194ae8e73..19fa84946c91 100644
> --- a/package/powerpc-utils/powerpc-utils.mk
> +++ b/package/powerpc-utils/powerpc-utils.mk
> @@ -4,9 +4,9 @@
>   #
>   ################################################################################
>   
> -POWERPC_UTILS_VERSION = 1.3.8
> +POWERPC_UTILS_VERSION = 1.3.10
>   POWERPC_UTILS_SITE = $(call github,ibm-power-utilities,powerpc-utils,v$(POWERPC_UTILS_VERSION))
> -POWERPC_UTILS_DEPENDENCIES = zlib
> +POWERPC_UTILS_DEPENDENCIES = zlib numactl
>   POWERPC_UTILS_AUTORECONF = YES
>   POWERPC_UTILS_LICENSE = GPL-2.0+
>   POWERPC_UTILS_LICENSE_FILES = COPYING
Thomas Petazzoni July 23, 2022, 5:15 p.m. UTC | #2
On Mon,  6 Jun 2022 18:21:08 +0930
Joel Stanley <joel@jms.id.au> wrote:

> Since v1.3.9 the package requires numa.h from numctl, so add this as a
> dependency.
> 
> This bump fixes a missing limits.h for PATH_MAX when building with musl
> as detected by the autobuilder.
> 
> librtas now builds fine with musl too, so remove the glibc restriction
> for enabling that support.
> 
> Fixes:
> 
>  http://autobuild.buildroot.net/results/613ec647e251ac52a01f222044bd675ce36c1b5b/
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>
> ---
>  package/powerpc-utils/Config.in          | 5 +----
>  package/powerpc-utils/powerpc-utils.hash | 2 +-
>  package/powerpc-utils/powerpc-utils.mk   | 4 ++--
>  3 files changed, 4 insertions(+), 7 deletions(-)

So, as Arnout suggested, I split this into two commits:

 - One backporting the musl fix, and just that, so that it can be
   backported to our LTS branch.

 - One doing the bump to 1.3.10, which obviously removes the patch as
   it is upstream.

Note that you had forgotten to propagate the numactl Config.in
dependencies to powerpc-utils, so I did that as well.

Applied with those changes. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/powerpc-utils/Config.in b/package/powerpc-utils/Config.in
index d04d81c08acb..9034ea2e0fdd 100644
--- a/package/powerpc-utils/Config.in
+++ b/package/powerpc-utils/Config.in
@@ -7,6 +7,7 @@  config BR2_PACKAGE_POWERPC_UTILS
 	depends on !BR2_STATIC_LIBS # dlfcn.h
 	depends on BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
 	select BR2_PACKAGE_ZLIB
+	select BR2_PACKAGE_NUMACTL
 	help
 	  System utilities for PowerPC machines.
 
@@ -16,7 +17,6 @@  if BR2_PACKAGE_POWERPC_UTILS
 
 config BR2_PACKAGE_POWERPC_UTILS_RTAS
 	bool "RTAS support"
-	depends on BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_LIBRTAS
 	help
 	  Enable support for functions that require RTAS.
@@ -28,7 +28,4 @@  config BR2_PACKAGE_POWERPC_UTILS_RTAS
 	  lsslot, activate_firmware, rtas_ibm_get_vpd, serv_config,
 	  rtas_event_decode, sys_ident.
 
-comment "RTAS support needs a glibc toolchain"
-	depends on !BR2_TOOLCHAIN_USES_GLIBC
-
 endif
diff --git a/package/powerpc-utils/powerpc-utils.hash b/package/powerpc-utils/powerpc-utils.hash
index 8d0b10425b6d..b3c77fb223ba 100644
--- a/package/powerpc-utils/powerpc-utils.hash
+++ b/package/powerpc-utils/powerpc-utils.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  4e3a21419863c08adde49f0795eff0fbfe4597ce82593fa5fe1f1177913fb7b9  powerpc-utils-1.3.8.tar.gz
+sha256  d64d9016a3e63a1e44c6e0833742cf964ae6bb1c6a9c7f0c7c5748aa335dc3db  powerpc-utils-1.3.10.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/powerpc-utils/powerpc-utils.mk b/package/powerpc-utils/powerpc-utils.mk
index b12194ae8e73..19fa84946c91 100644
--- a/package/powerpc-utils/powerpc-utils.mk
+++ b/package/powerpc-utils/powerpc-utils.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-POWERPC_UTILS_VERSION = 1.3.8
+POWERPC_UTILS_VERSION = 1.3.10
 POWERPC_UTILS_SITE = $(call github,ibm-power-utilities,powerpc-utils,v$(POWERPC_UTILS_VERSION))
-POWERPC_UTILS_DEPENDENCIES = zlib
+POWERPC_UTILS_DEPENDENCIES = zlib numactl
 POWERPC_UTILS_AUTORECONF = YES
 POWERPC_UTILS_LICENSE = GPL-2.0+
 POWERPC_UTILS_LICENSE_FILES = COPYING