diff mbox series

[2/2] package/rauc: add option to enable/disable streaming support

Message ID 20220604115458.7914-2-heiko.thiery@gmail.com
State Accepted
Headers show
Series [1/2] package/rauc: bump to version 1.7 | expand

Commit Message

Heiko Thiery June 4, 2022, 11:55 a.m. UTC
RAUC 1.7 introduces streaming update support. Make this configurable and add
required dependency to libnl.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 package/rauc/Config.in | 13 +++++++++++++
 package/rauc/rauc.mk   |  7 +++++++
 2 files changed, 20 insertions(+)

Comments

Thomas Petazzoni June 5, 2022, 8:26 p.m. UTC | #1
On Sat,  4 Jun 2022 13:55:00 +0200
Heiko Thiery <heiko.thiery@gmail.com> wrote:

> RAUC 1.7 introduces streaming update support. Make this configurable and add
> required dependency to libnl.
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
>  package/rauc/Config.in | 13 +++++++++++++
>  package/rauc/rauc.mk   |  7 +++++++
>  2 files changed, 20 insertions(+)
> 
> diff --git a/package/rauc/Config.in b/package/rauc/Config.in
> index 1170e50845..fe029c73ca 100644
> --- a/package/rauc/Config.in
> +++ b/package/rauc/Config.in
> @@ -40,6 +40,19 @@ config BR2_PACKAGE_RAUC_NETWORK
>  	  This option enables support for updating firmware over
>  	  the network using libcurl.
>  
> +comment "rauc streaming support needs network support"
> +	depends on !BR2_PACKAGE_RAUC_NETWORK

I found this comment to not be very useful, it's pretty obvious that
streaming will only be available with network support enabled IMO, so I
dropped this comment and applied to next. Of course, I can always be
convinced differently by you or my fellow co-maintainers :-)

Thomas
diff mbox series

Patch

diff --git a/package/rauc/Config.in b/package/rauc/Config.in
index 1170e50845..fe029c73ca 100644
--- a/package/rauc/Config.in
+++ b/package/rauc/Config.in
@@ -40,6 +40,19 @@  config BR2_PACKAGE_RAUC_NETWORK
 	  This option enables support for updating firmware over
 	  the network using libcurl.
 
+comment "rauc streaming support needs network support"
+	depends on !BR2_PACKAGE_RAUC_NETWORK
+
+if BR2_PACKAGE_RAUC_NETWORK
+
+config BR2_PACKAGE_RAUC_STREAMING
+	bool "streaming update support"
+	select BR2_PACKAGE_LIBNL
+	help
+	  This option enables support for streaming update mode.
+
+endif
+
 config BR2_PACKAGE_RAUC_JSON
 	bool "JSON output support"
 	select BR2_PACKAGE_JSON_GLIB
diff --git a/package/rauc/rauc.mk b/package/rauc/rauc.mk
index 90b2317d4b..8bfb0b79ba 100644
--- a/package/rauc/rauc.mk
+++ b/package/rauc/rauc.mk
@@ -52,6 +52,13 @@  else
 RAUC_CONF_OPTS += --disable-json
 endif
 
+ifeq ($(BR2_PACKAGE_RAUC_STREAMING),y)
+RAUC_CONF_OPTS += --enable-streaming
+RAUC_DEPENDENCIES += libnl
+else
+RAUC_CONF_OPTS += --disable-streaming
+endif
+
 HOST_RAUC_DEPENDENCIES = \
 	host-pkgconf \
 	host-openssl \