diff mbox series

[1/1] package/libwebsockets: disable -Werror

Message ID 20220528204423.2214898-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libwebsockets: disable -Werror | expand

Commit Message

Fabrice Fontaine May 28, 2022, 8:44 p.m. UTC
Disable -Werror (enabled by default) through DISABLE_WERROR which is
available since version 4.1.0 and
https://github.com/warmcat/libwebsockets/commit/c9c152baba1fbd6e2b061b16a5c987a80309caee
to avoid the following build failure with gcc 4.8 and libev:

/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-1/output-1/build/libwebsockets-4.3.1/lib/event-libs/libev/libev.c: In function 'lws_ev_hrtimer_cb':
/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-1/output-1/build/libwebsockets-4.3.1/lib/event-libs/libev/libev.c:44:3: error: dereferencing type-punned pointer will break strict-aliasing rules [-Werror=strict-aliasing]
   ev_timer_set(&ptpr->hrtimer, ((float)us) / 1000000.0, 0);
   ^

Fixes:
 - http://autobuild.buildroot.org/results/75ddbd2e0b058b69a99a2a2f01c62dedad1199c0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libwebsockets/libwebsockets.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN May 28, 2022, 10:09 p.m. UTC | #1
Fabrice, All,

On 2022-05-28 22:44 +0200, Fabrice Fontaine spake thusly:
> Disable -Werror (enabled by default) through DISABLE_WERROR which is
> available since version 4.1.0 and
> https://github.com/warmcat/libwebsockets/commit/c9c152baba1fbd6e2b061b16a5c987a80309caee
> to avoid the following build failure with gcc 4.8 and libev:
> 
> /usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-1/output-1/build/libwebsockets-4.3.1/lib/event-libs/libev/libev.c: In function 'lws_ev_hrtimer_cb':
> /usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-1/output-1/build/libwebsockets-4.3.1/lib/event-libs/libev/libev.c:44:3: error: dereferencing type-punned pointer will break strict-aliasing rules [-Werror=strict-aliasing]
>    ev_timer_set(&ptpr->hrtimer, ((float)us) / 1000000.0, 0);
>    ^
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/75ddbd2e0b058b69a99a2a2f01c62dedad1199c0
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libwebsockets/libwebsockets.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/libwebsockets/libwebsockets.mk b/package/libwebsockets/libwebsockets.mk
> index 63d50999a5..3a9b9ea88f 100644
> --- a/package/libwebsockets/libwebsockets.mk
> +++ b/package/libwebsockets/libwebsockets.mk
> @@ -11,6 +11,7 @@ LIBWEBSOCKETS_LICENSE_FILES = LICENSE
>  LIBWEBSOCKETS_DEPENDENCIES = zlib
>  LIBWEBSOCKETS_INSTALL_STAGING = YES
>  LIBWEBSOCKETS_CONF_OPTS = \
> +	-DDISABLE_WERROR=ON \
>  	-DLWS_WITHOUT_TESTAPPS=ON \
>  	-DLWS_IPV6=ON \
>  	-DLWS_UNIX_SOCK=ON \
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libwebsockets/libwebsockets.mk b/package/libwebsockets/libwebsockets.mk
index 63d50999a5..3a9b9ea88f 100644
--- a/package/libwebsockets/libwebsockets.mk
+++ b/package/libwebsockets/libwebsockets.mk
@@ -11,6 +11,7 @@  LIBWEBSOCKETS_LICENSE_FILES = LICENSE
 LIBWEBSOCKETS_DEPENDENCIES = zlib
 LIBWEBSOCKETS_INSTALL_STAGING = YES
 LIBWEBSOCKETS_CONF_OPTS = \
+	-DDISABLE_WERROR=ON \
 	-DLWS_WITHOUT_TESTAPPS=ON \
 	-DLWS_IPV6=ON \
 	-DLWS_UNIX_SOCK=ON \