diff mbox series

package/strace: download from Github

Message ID 20220527184501.1992852-1-mmayer@broadcom.com
State Accepted
Headers show
Series package/strace: download from Github | expand

Commit Message

Markus Mayer May 27, 2022, 6:45 p.m. UTC
Some corporate networks may be blocking access to Russian servers.
The server "strace.io" is in Russia, which will make it inaccessible
from some networks.

Use Github instead to download the sources.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
---

Not sure if there is a precedence for such a change or if it'll be deemed
acceptable. I am putting this out there in case it is considered helpful.

Thanks,
-Markus

 package/strace/strace.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN May 28, 2022, 10 a.m. UTC | #1
Mrkus, All,

On 2022-05-27 11:45 -0700, Markus Mayer via buildroot spake thusly:
> Some corporate networks may be blocking access to Russian servers.
> The server "strace.io" is in Russia, which will make it inaccessible
> from some networks.
> 
> Use Github instead to download the sources.
> 
> Signed-off-by: Markus Mayer <mmayer@broadcom.com>

Applied to master, thanks.

> ---
> 
> Not sure if there is a precedence for such a change or if it'll be deemed
> acceptable. I am putting this out there in case it is considered helpful.

Yes, there's already been such switch in the past. We jsut have to
ensure one of the folowing:

  - if the archive filename did not change, it must be the exact same
    content as what we already use (i.e. the same hash), or it would
    conflict eith the cached archive we have on s.b.o.

  - if the archive content changed, we must ensure its filename changed,
    like we bump the version or something, to avoid aforementioned hash
    mismatch.

In this case, the hash did match, so it's (very probably!) the same file,
so that's OK.

Regards,
Yann E. MORIN.

> Thanks,
> -Markus
> 
>  package/strace/strace.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/strace/strace.mk b/package/strace/strace.mk
> index c35e0c84da22..67924d4b660a 100644
> --- a/package/strace/strace.mk
> +++ b/package/strace/strace.mk
> @@ -6,7 +6,7 @@
>  
>  STRACE_VERSION = 5.17
>  STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
> -STRACE_SITE = https://strace.io/files/$(STRACE_VERSION)
> +STRACE_SITE = https://github.com/strace/strace/releases/download/v$(STRACE_VERSION)
>  STRACE_LICENSE = LGPL-2.1+
>  STRACE_LICENSE_FILES = COPYING LGPL-2.1-or-later
>  STRACE_CPE_ID_VENDOR = strace_project
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard June 1, 2022, 9:22 p.m. UTC | #2
>>>>> "Markus" == Markus Mayer via buildroot <buildroot@buildroot.org> writes:

 > Some corporate networks may be blocking access to Russian servers.
 > The server "strace.io" is in Russia, which will make it inaccessible
 > from some networks.

 > Use Github instead to download the sources.

 > Signed-off-by: Markus Mayer <mmayer@broadcom.com>
 > ---

 > Not sure if there is a precedence for such a change or if it'll be deemed
 > acceptable. I am putting this out there in case it is considered helpful.

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/strace/strace.mk b/package/strace/strace.mk
index c35e0c84da22..67924d4b660a 100644
--- a/package/strace/strace.mk
+++ b/package/strace/strace.mk
@@ -6,7 +6,7 @@ 
 
 STRACE_VERSION = 5.17
 STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
-STRACE_SITE = https://strace.io/files/$(STRACE_VERSION)
+STRACE_SITE = https://github.com/strace/strace/releases/download/v$(STRACE_VERSION)
 STRACE_LICENSE = LGPL-2.1+
 STRACE_LICENSE_FILES = COPYING LGPL-2.1-or-later
 STRACE_CPE_ID_VENDOR = strace_project