diff mbox series

[2/4] package/sysrepo: bump version to 2.1.42

Message ID 20220513071046.18618-3-heiko.thiery@gmail.com
State Accepted
Headers show
Series Bump netopeer2 and dependencies to actual upstream version | expand

Commit Message

Heiko Thiery May 13, 2022, 7:10 a.m. UTC
Drop patch that is now fixed upstream. Add a dependency to sytemd if
enabled so cmake can find libsystemd and install the systemd service file.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 ...uild-with-musl-libc-fails-due-to-unk.patch | 42 -------------------
 package/sysrepo/sysrepo.hash                  |  2 +-
 package/sysrepo/sysrepo.mk                    |  6 ++-
 3 files changed, 6 insertions(+), 44 deletions(-)
 delete mode 100644 package/sysrepo/0001-sysrepo-BUGFIX-build-with-musl-libc-fails-due-to-unk.patch
diff mbox series

Patch

diff --git a/package/sysrepo/0001-sysrepo-BUGFIX-build-with-musl-libc-fails-due-to-unk.patch b/package/sysrepo/0001-sysrepo-BUGFIX-build-with-musl-libc-fails-due-to-unk.patch
deleted file mode 100644
index 784cfb1445..0000000000
--- a/package/sysrepo/0001-sysrepo-BUGFIX-build-with-musl-libc-fails-due-to-unk.patch
+++ /dev/null
@@ -1,42 +0,0 @@ 
-From 896dc6aee38898fe1c6822ee6a4a4989d21c650b Mon Sep 17 00:00:00 2001
-From: Heiko Thiery <heiko.thiery@gmail.com>
-Date: Thu, 25 Nov 2021 12:18:06 +0100
-Subject: [PATCH] sysrepo BUGFIX build with musl libc fails due to unknown type
- name 'mode_t'
-
-When building against the musl libc the build will fail due to the
-missing sys/type.h include.
-
-Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
----
- src/plugins_datastore.h    | 1 +
- src/plugins_notification.h | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/src/plugins_datastore.h b/src/plugins_datastore.h
-index a64e4131..d577e929 100644
---- a/src/plugins_datastore.h
-+++ b/src/plugins_datastore.h
-@@ -18,6 +18,7 @@
- #define _SYSREPO_PLUGINS_DATASTORE_H
- 
- #include <stdint.h>
-+#include <sys/types.h>
- 
- #include <libyang/libyang.h>
- 
-diff --git a/src/plugins_notification.h b/src/plugins_notification.h
-index 2099db62..f410e8d9 100644
---- a/src/plugins_notification.h
-+++ b/src/plugins_notification.h
-@@ -18,6 +18,7 @@
- #define _SYSREPO_PLUGINS_NOTIFICATION_H
- 
- #include <stdint.h>
-+#include <sys/types.h>
- 
- #include <libyang/libyang.h>
- 
--- 
-2.30.2
-
diff --git a/package/sysrepo/sysrepo.hash b/package/sysrepo/sysrepo.hash
index b382c16036..7232711b46 100644
--- a/package/sysrepo/sysrepo.hash
+++ b/package/sysrepo/sysrepo.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  fe09da5f40fb53e3fb97268a134cc0ed3003f0018d0d117c73e81e1553a11f30  sysrepo-2.0.53.tar.gz
+sha256  1182b9d5e1178ad74b3bde6d282b86d17b60e206cd8a014895f74252492d96ab  sysrepo-2.1.42.tar.gz
 sha256  88f1b7e5c64d2c113e07105aa9c0fb80639b40287565be1c2afd0949df83d826  LICENSE
diff --git a/package/sysrepo/sysrepo.mk b/package/sysrepo/sysrepo.mk
index acb3052023..c999bd0ea7 100644
--- a/package/sysrepo/sysrepo.mk
+++ b/package/sysrepo/sysrepo.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-SYSREPO_VERSION = 2.0.53
+SYSREPO_VERSION = 2.1.42
 SYSREPO_SITE = $(call github,sysrepo,sysrepo,v$(SYSREPO_VERSION))
 SYSREPO_INSTALL_STAGING = YES
 SYSREPO_LICENSE = BSD-3-Clause
@@ -12,6 +12,10 @@  SYSREPO_LICENSE_FILES = LICENSE
 SYSREPO_DEPENDENCIES = libyang pcre2 host-sysrepo
 HOST_SYSREPO_DEPENDENCIES = host-libyang host-pcre2
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+SYSREPO_DEPENDENCIES += systemd
+endif
+
 SYSREPO_CONF_OPTS = \
 	-DBUILD_EXAMPLES=$(if $(BR2_PACKAGE_SYSREPO_EXAMPLES),ON,OFF) \
 	-DENABLE_TESTS=OFF \