diff mbox series

[2/5] package/gnutls: remove unused libregex dependency

Message ID 20220512160116.2011627-2-arnout@mind.be
State Accepted
Headers show
Series [1/5] package/gnutls: disable library search in /usr/lib | expand

Commit Message

Arnout Vandecappelle May 12, 2022, 4:01 p.m. UTC
The pcre/libregex dependency was removed in version 3.7.3 with upstream
commit 26578b7d02c269ff1d34ff782d84c7667734d03d, which removed the
bundled libopts. Remove the pcre dependency and the relevant CONF_OPTS
handling.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
This is for stable since it's already the case for 3.7.3, the version in
2022.02.x
---
 package/gnutls/Config.in |  1 -
 package/gnutls/gnutls.mk | 11 +----------
 2 files changed, 1 insertion(+), 11 deletions(-)

Comments

Yann E. MORIN May 12, 2022, 8:52 p.m. UTC | #1
Arnout, All,

On 2022-05-12 18:01 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
> The pcre/libregex dependency was removed in version 3.7.3 with upstream
> commit 26578b7d02c269ff1d34ff782d84c7667734d03d, which removed the
> bundled libopts. Remove the pcre dependency and the relevant CONF_OPTS
> handling.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> This is for stable since it's already the case for 3.7.3, the version in
> 2022.02.x
> ---
>  package/gnutls/Config.in |  1 -
>  package/gnutls/gnutls.mk | 11 +----------
>  2 files changed, 1 insertion(+), 11 deletions(-)
> 
> diff --git a/package/gnutls/Config.in b/package/gnutls/Config.in
> index d57bb8d135..28982b15a1 100644
> --- a/package/gnutls/Config.in
> +++ b/package/gnutls/Config.in
> @@ -7,7 +7,6 @@ config BR2_PACKAGE_GNUTLS
>  	depends on BR2_USE_WCHAR
>  	select BR2_PACKAGE_LIBTASN1
>  	select BR2_PACKAGE_NETTLE
> -	select BR2_PACKAGE_PCRE
>  	help
>  	  GnuTLS is a secure communications library implementing the SSL
>  	  and TLS protocols and technologies around them.
> diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
> index b5503b1fc9..79e7d529b1 100644
> --- a/package/gnutls/gnutls.mk
> +++ b/package/gnutls/gnutls.mk
> @@ -17,7 +17,7 @@ GNUTLS_LICENSE += , GPL-3.0+ (gnutls-openssl library)
>  GNUTLS_LICENSE_FILES += doc/COPYING
>  endif
>  
> -GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle pcre
> +GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle
>  GNUTLS_CPE_ID_VENDOR = gnu
>  GNUTLS_CONF_OPTS = \
>  	--disable-doc \
> @@ -25,7 +25,6 @@ GNUTLS_CONF_OPTS = \
>  	--disable-libdane \
>  	--disable-rpath \
>  	--disable-tests \
> -	--enable-local-libopts \
>  	--enable-openssl-compatibility \
>  	--without-libcrypto-prefix \
>  	--without-libdl-prefix \
> @@ -48,14 +47,6 @@ GNUTLS_CONF_ENV = gl_cv_socket_ipv6=yes \
>  	gl_cv_func_gettimeofday_clobber=no
>  GNUTLS_INSTALL_STAGING = YES
>  
> -# gnutls needs libregex, but pcre can be used too
> -# The check isn't cross-compile friendly
> -GNUTLS_CONF_ENV += libopts_cv_with_libregex=yes
> -GNUTLS_CONF_OPTS += \
> -	--with-regex-header=pcreposix.h \
> -	--with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
> -	--with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
> -
>  ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
>  GNUTLS_CONF_OPTS += --enable-cryptodev
>  GNUTLS_DEPENDENCIES += cryptodev-linux
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/gnutls/Config.in b/package/gnutls/Config.in
index d57bb8d135..28982b15a1 100644
--- a/package/gnutls/Config.in
+++ b/package/gnutls/Config.in
@@ -7,7 +7,6 @@  config BR2_PACKAGE_GNUTLS
 	depends on BR2_USE_WCHAR
 	select BR2_PACKAGE_LIBTASN1
 	select BR2_PACKAGE_NETTLE
-	select BR2_PACKAGE_PCRE
 	help
 	  GnuTLS is a secure communications library implementing the SSL
 	  and TLS protocols and technologies around them.
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index b5503b1fc9..79e7d529b1 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -17,7 +17,7 @@  GNUTLS_LICENSE += , GPL-3.0+ (gnutls-openssl library)
 GNUTLS_LICENSE_FILES += doc/COPYING
 endif
 
-GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle pcre
+GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle
 GNUTLS_CPE_ID_VENDOR = gnu
 GNUTLS_CONF_OPTS = \
 	--disable-doc \
@@ -25,7 +25,6 @@  GNUTLS_CONF_OPTS = \
 	--disable-libdane \
 	--disable-rpath \
 	--disable-tests \
-	--enable-local-libopts \
 	--enable-openssl-compatibility \
 	--without-libcrypto-prefix \
 	--without-libdl-prefix \
@@ -48,14 +47,6 @@  GNUTLS_CONF_ENV = gl_cv_socket_ipv6=yes \
 	gl_cv_func_gettimeofday_clobber=no
 GNUTLS_INSTALL_STAGING = YES
 
-# gnutls needs libregex, but pcre can be used too
-# The check isn't cross-compile friendly
-GNUTLS_CONF_ENV += libopts_cv_with_libregex=yes
-GNUTLS_CONF_OPTS += \
-	--with-regex-header=pcreposix.h \
-	--with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
-	--with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
-
 ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
 GNUTLS_CONF_OPTS += --enable-cryptodev
 GNUTLS_DEPENDENCIES += cryptodev-linux