diff mbox series

[v1,1/1] package/rsyslog: update to fix service permissions

Message ID 20220511143316.58942-1-jared.bents@rockwellcollins.com
State Handled Elsewhere
Headers show
Series [v1,1/1] package/rsyslog: update to fix service permissions | expand

Commit Message

Jared Bents May 11, 2022, 2:33 p.m. UTC
Update to fix the permissions being set when installing the
rsyslog service. The service should be installed with 644
permissions and not 755 permissions.

Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
---
 package/rsyslog/rsyslog.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 26, 2022, 9:33 p.m. UTC | #1
On Wed, 11 May 2022 09:33:16 -0500
Jared Bents <jared.bents@rockwellcollins.com> wrote:

> Update to fix the permissions being set when installing the
> rsyslog service. The service should be installed with 644
> permissions and not 755 permissions.
> 
> Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
> ---
>  package/rsyslog/rsyslog.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 29, 2022, 6:56 a.m. UTC | #2
>>>>> "Jared" == Jared Bents <jared.bents@rockwellcollins.com> writes:

 > Update to fix the permissions being set when installing the
 > rsyslog service. The service should be installed with 644
 > permissions and not 755 permissions.

 > Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/rsyslog/rsyslog.mk b/package/rsyslog/rsyslog.mk
index afd1a5557e..7cd75b19b6 100644
--- a/package/rsyslog/rsyslog.mk
+++ b/package/rsyslog/rsyslog.mk
@@ -121,7 +121,7 @@  RSYSLOG_CONF_OPTS += \
 endif
 
 define RSYSLOG_INSTALL_INIT_SYSTEMD
-	$(INSTALL) -m 0755 -D package/rsyslog/rsyslog.service \
+	$(INSTALL) -m 0644 -D package/rsyslog/rsyslog.service \
 		$(TARGET_DIR)/usr/lib/systemd/system/rsyslog.service
 endef