diff mbox series

[1/1] package/pkg-meson: do not pass -j$(PARALLEL_JOBS) to ninja

Message ID 20220509062100.3969630-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/pkg-meson: do not pass -j$(PARALLEL_JOBS) to ninja | expand

Commit Message

James Hilliard May 9, 2022, 6:21 a.m. UTC
Now that we are using ninja with jobserver support we should not pass
-j$(PARALLEL_JOBS) to ninja.

Fixes:
ninja: warning: -jN forced on command line; ignoring GNU make jobserver.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/pkg-meson.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle May 13, 2022, 9:57 p.m. UTC | #1
On 09/05/2022 08:21, James Hilliard wrote:
> Now that we are using ninja with jobserver support we should not pass
> -j$(PARALLEL_JOBS) to ninja.
> 
> Fixes:
> ninja: warning: -jN forced on command line; ignoring GNU make jobserver.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/pkg-meson.mk | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/pkg-meson.mk b/package/pkg-meson.mk
> index 9987fb73bb..0835e08e3a 100644
> --- a/package/pkg-meson.mk
> +++ b/package/pkg-meson.mk
> @@ -27,7 +27,7 @@
>   #
>   MESON		= PYTHONNOUSERSITE=y $(HOST_DIR)/bin/meson
>   NINJA		= PYTHONNOUSERSITE=y $(HOST_DIR)/bin/ninja
> -NINJA_OPTS	= $(if $(VERBOSE),-v) -j$(PARALLEL_JOBS)
> +NINJA_OPTS	= $(if $(VERBOSE),-v)
>   
>   # https://mesonbuild.com/Reference-tables.html#cpu-families
>   ifeq ($(BR2_arcle)$(BR2_arceb),y)
diff mbox series

Patch

diff --git a/package/pkg-meson.mk b/package/pkg-meson.mk
index 9987fb73bb..0835e08e3a 100644
--- a/package/pkg-meson.mk
+++ b/package/pkg-meson.mk
@@ -27,7 +27,7 @@ 
 #
 MESON		= PYTHONNOUSERSITE=y $(HOST_DIR)/bin/meson
 NINJA		= PYTHONNOUSERSITE=y $(HOST_DIR)/bin/ninja
-NINJA_OPTS	= $(if $(VERBOSE),-v) -j$(PARALLEL_JOBS)
+NINJA_OPTS	= $(if $(VERBOSE),-v)
 
 # https://mesonbuild.com/Reference-tables.html#cpu-families
 ifeq ($(BR2_arcle)$(BR2_arceb),y)