diff mbox series

[1/1] package/bcusdk: fix build with argp-standalone and NLS

Message ID 20220508182727.888244-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/bcusdk: fix build with argp-standalone and NLS | expand

Commit Message

Fabrice Fontaine May 8, 2022, 6:27 p.m. UTC
Fix the following build failure with argp-standalone and NLS raised
since commit 5430c8fedd0392e79e0c011825b056fea129980a:

configure:16428: /home/buildroot/autobuild/instance-3/output-1/host/bin/sh4-linux-gcc -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os -g0  -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  conftest.c -largp   >&5
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sh4-buildroot-linux-uclibc/10.3.0/../../../../sh4-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/sh4-buildroot-linux-uclibc/sysroot/usr/lib/libargp.a(argp-parse.o): in function `argp_version_parser':
/home/buildroot/autobuild/instance-3/output-1/build/argp-standalone-1.4.1/argp-parse.c:190: undefined reference to `libintl_dgettext'

[...]

checking for library containing argp_parse... no
configure: error: argp_parse not found

Fixes:
 - http://autobuild.buildroot.org/results/9277a064b61f24ad35334b318fe4d899a4c39aa1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/bcusdk/bcusdk.mk | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard May 10, 2022, 7:23 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with argp-standalone and NLS raised
 > since commit 5430c8fedd0392e79e0c011825b056fea129980a:

 > configure:16428:
 > /home/buildroot/autobuild/instance-3/output-1/host/bin/sh4-linux-gcc
 > -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
 > -D_FILE_OFFSET_BITS=64 -Os -g0 -D_LARGEFILE_SOURCE
 > -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 conftest.c -largp >&5
 > /home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sh4-buildroot-linux-uclibc/10.3.0/../../../../sh4-buildroot-linux-uclibc/bin/ld:
 > /home/buildroot/autobuild/instance-3/output-1/host/sh4-buildroot-linux-uclibc/sysroot/usr/lib/libargp.a(argp-parse.o):
 > in function `argp_version_parser':
 > /home/buildroot/autobuild/instance-3/output-1/build/argp-standalone-1.4.1/argp-parse.c:190:
 > undefined reference to `libintl_dgettext'

 > [...]

 > checking for library containing argp_parse... no
 > configure: error: argp_parse not found

 > Fixes:
 >  - http://autobuild.buildroot.org/results/9277a064b61f24ad35334b318fe4d899a4c39aa1

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 >  package/bcusdk/bcusdk.mk | 9 ++++++---
 >  1 file changed, 6 insertions(+), 3 deletions(-)

 > diff --git a/package/bcusdk/bcusdk.mk b/package/bcusdk/bcusdk.mk
 > index ff5becd84b..8006b265b9 100644
 > --- a/package/bcusdk/bcusdk.mk
 > +++ b/package/bcusdk/bcusdk.mk
 > @@ -21,9 +21,12 @@ BCUSDK_CONF_OPTS = \
 >  	--without-pth-test \
 >  	--with-pth=$(STAGING_DIR)/usr
 
 > -BCUSDK_DEPENDENCIES = \
 > -	libpthsem \
 > -	$(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
 > +BCUSDK_DEPENDENCIES = libpthsem \

Dropped the backslash and committed, thanks.
diff mbox series

Patch

diff --git a/package/bcusdk/bcusdk.mk b/package/bcusdk/bcusdk.mk
index ff5becd84b..8006b265b9 100644
--- a/package/bcusdk/bcusdk.mk
+++ b/package/bcusdk/bcusdk.mk
@@ -21,9 +21,12 @@  BCUSDK_CONF_OPTS = \
 	--without-pth-test \
 	--with-pth=$(STAGING_DIR)/usr
 
-BCUSDK_DEPENDENCIES = \
-	libpthsem \
-	$(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
+BCUSDK_DEPENDENCIES = libpthsem \
+
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+BCUSDK_DEPENDENCIES += argp-standalone $(TARGET_NLS_DEPENDENCIES)
+BCUSDK_CONF_ENV += LIBS=$(TARGET_NLS_LIBS)
+endif
 
 define BCUSDK_REMOVE_EXAMPLES
 	$(RM) -rf $(TARGET_DIR)/usr/share/bcusdk