diff mbox series

[2/3] package/xr819-xradio: enable required kernel options

Message ID 20220507202905.397732-3-geomatsi@gmail.com
State Accepted
Headers show
Series xr819-xradio: fixes for autobuild failures | expand

Commit Message

Sergey Matyukevich May 7, 2022, 8:29 p.m. UTC
Enable Linux kernel configuration options required by xradio driver.
Those are wireless networking support, sdio support, and power
management core functions.

Fixes:
- http://autobuild.buildroot.net/results/7ad4a4b6b1612460427e667d98efc6df7b4a2153/

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
---
 package/xr819-xradio/xr819-xradio.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Arnout Vandecappelle May 13, 2022, 8:52 p.m. UTC | #1
On 07/05/2022 22:29, Sergey Matyukevich wrote:
> Enable Linux kernel configuration options required by xradio driver.
> Those are wireless networking support, sdio support, and power
> management core functions.
> 
> Fixes:
> - http://autobuild.buildroot.net/results/7ad4a4b6b1612460427e667d98efc6df7b4a2153/
> 
> Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
> ---
>   package/xr819-xradio/xr819-xradio.mk | 8 ++++++++
>   1 file changed, 8 insertions(+)
> 
> diff --git a/package/xr819-xradio/xr819-xradio.mk b/package/xr819-xradio/xr819-xradio.mk
> index d4b9826f64..835e229347 100644
> --- a/package/xr819-xradio/xr819-xradio.mk
> +++ b/package/xr819-xradio/xr819-xradio.mk
> @@ -9,5 +9,13 @@ XR819_XRADIO_SITE = $(call github,fifteenhex,xradio,$(XR819_XRADIO_VERSION))
>   XR819_XRADIO_LICENSE = GPL-2.0
>   XR819_XRADIO_LICENSE_FILES = LICENSE
>   
> +define XR819_XRADIO_LINUX_CONFIG_FIXUPS
> +	$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
> +	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
> +	$(call KCONFIG_ENABLE_OPT,CONFIG_MAC80211)
> +	$(call KCONFIG_ENABLE_OPT,CONFIG_MMC)
> +	$(call KCONFIG_ENABLE_OPT,CONFIG_PM)

  I've applied to master. However, these options have dependencies that need to 
be checked as well. E.g. WIRELESS depends on NET (which is usually enabled, but 
you can't count on it). But it also depends on !S390 - in other words, you 
simply can't build this package for s390x, so that dependency has to be added to 
Config.in.

  Could you check this stuff and update the options?

  Regards,
  Arnout

> +endef
> +
>   $(eval $(kernel-module))
>   $(eval $(generic-package))
diff mbox series

Patch

diff --git a/package/xr819-xradio/xr819-xradio.mk b/package/xr819-xradio/xr819-xradio.mk
index d4b9826f64..835e229347 100644
--- a/package/xr819-xradio/xr819-xradio.mk
+++ b/package/xr819-xradio/xr819-xradio.mk
@@ -9,5 +9,13 @@  XR819_XRADIO_SITE = $(call github,fifteenhex,xradio,$(XR819_XRADIO_VERSION))
 XR819_XRADIO_LICENSE = GPL-2.0
 XR819_XRADIO_LICENSE_FILES = LICENSE
 
+define XR819_XRADIO_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_MAC80211)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_MMC)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_PM)
+endef
+
 $(eval $(kernel-module))
 $(eval $(generic-package))