diff mbox series

package/tbb: always build Release

Message ID 20220430185701.606071-1-arnout@mind.be
State Accepted
Headers show
Series package/tbb: always build Release | expand

Commit Message

Arnout Vandecappelle April 30, 2022, 6:57 p.m. UTC
When tbb is built in Debug mode, it installs libtbb_debug.so instead of
libtbb.so. This confuses downstream packages that want to link with it
(e.g. sysdig).

Always build in Release mode. This means that BR2_ENABLE_RUNTIME_DEBUG
has no effect for this package, but that shouldn't be a bi issue.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/tbb/tbb.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN May 1, 2022, 7:43 p.m. UTC | #1
Arnout, All,

On 2022-04-30 20:57 +0200, Arnout Vandecappelle (Essensium/Mind) spake thusly:
> When tbb is built in Debug mode, it installs libtbb_debug.so instead of
> libtbb.so. This confuses downstream packages that want to link with it
> (e.g. sysdig).
> 
> Always build in Release mode. This means that BR2_ENABLE_RUNTIME_DEBUG
> has no effect for this package, but that shouldn't be a bi issue.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/tbb/tbb.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/tbb/tbb.mk b/package/tbb/tbb.mk
> index afe756a85a..fc720fd2f5 100644
> --- a/package/tbb/tbb.mk
> +++ b/package/tbb/tbb.mk
> @@ -13,6 +13,7 @@ TBB_CPE_ID_VENDOR = intel
>  TBB_CPE_ID_PRODUCT = threading_building_blocks
>  
>  TBB_CONF_OPTS = \
> +	-DCMAKE_BUILD_TYPE=Release \
>  	-DTBB_STRICT=OFF \
>  	-DTBB_TEST=OFF
>  
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/tbb/tbb.mk b/package/tbb/tbb.mk
index afe756a85a..fc720fd2f5 100644
--- a/package/tbb/tbb.mk
+++ b/package/tbb/tbb.mk
@@ -13,6 +13,7 @@  TBB_CPE_ID_VENDOR = intel
 TBB_CPE_ID_PRODUCT = threading_building_blocks
 
 TBB_CONF_OPTS = \
+	-DCMAKE_BUILD_TYPE=Release \
 	-DTBB_STRICT=OFF \
 	-DTBB_TEST=OFF