diff mbox series

package/systemd: add the missing sgx group

Message ID 20220420135549.3536397-1-tianyuanhao3@163.com
State Accepted
Headers show
Series package/systemd: add the missing sgx group | expand

Commit Message

TIAN Yuanhao April 20, 2022, 1:55 p.m. UTC
systemd-udevd needs this group:
  /usr/lib/udev/rules.d/50-udev-default.rules:43 Unknown group 'sgx', ignoring

Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
---
 package/systemd/systemd.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN April 21, 2022, 7:16 p.m. UTC | #1
Yuanhao, All,

On 2022-04-20 06:55 -0700, TIAN Yuanhao spake thusly:
> systemd-udevd needs this group:
>   /usr/lib/udev/rules.d/50-udev-default.rules:43 Unknown group 'sgx', ignoring
> 
> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
> ---
>  package/systemd/systemd.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index b07fac27d4..44185a35a0 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -603,6 +603,7 @@ endef
>  
>  define SYSTEMD_USERS
>  	# udev user groups
> +	- - sgx -1 * - - - SGX device nodes

This should have been in the udev virtual package, as all the
udev-related users and groups have been moved there to be common between
systemd-udevd and the stand-alone eudev, in commit d648d81dd581
(packages/{eudev, systemd}: move common users to package/udev).

Applied to master with this fixed, thanks.

Would you be kind enough to send a follow-up patch that removes the now
misleading "# udev user groups" comment, and adds a comment, in systemd
and eudev, that directs changes to the udev virtual package instead,
please?

Regards,
Yann E. MORIN.

>  	# systemd user groups
>  	- - systemd-journal -1 * - - - Journal
>  	$(SYSTEMD_REMOTE_USER)
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
TIAN Yuanhao April 21, 2022, 11:55 p.m. UTC | #2
Hi Yann,

On 4/21/22 12:16, Yann E. MORIN wrote:
> Yuanhao, All,
>
> On 2022-04-20 06:55 -0700, TIAN Yuanhao spake thusly:
>> systemd-udevd needs this group:
>>    /usr/lib/udev/rules.d/50-udev-default.rules:43 Unknown group 'sgx', ignoring
>>
>> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
>> ---
>>   package/systemd/systemd.mk | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
>> index b07fac27d4..44185a35a0 100644
>> --- a/package/systemd/systemd.mk
>> +++ b/package/systemd/systemd.mk
>> @@ -603,6 +603,7 @@ endef
>>   
>>   define SYSTEMD_USERS
>>   	# udev user groups
>> +	- - sgx -1 * - - - SGX device nodes
> This should have been in the udev virtual package, as all the
> udev-related users and groups have been moved there to be common between
> systemd-udevd and the stand-alone eudev, in commit d648d81dd581
> (packages/{eudev, systemd}: move common users to package/udev).
>
> Applied to master with this fixed, thanks.
>
> Would you be kind enough to send a follow-up patch that removes the now
> misleading "# udev user groups" comment, and adds a comment, in systemd
> and eudev, that directs changes to the udev virtual package instead,
> please?
I did notice the common rules in the udev virtual package. However "sgx" 
only appears in systemd but not eudev. Besides, I found that the 
"render" group in systemd should be "video" in eudev.

Regards,
TIAN Yuanhao
>
> Regards,
> Yann E. MORIN.
>
>>   	# systemd user groups
>>   	- - systemd-journal -1 * - - - Journal
>>   	$(SYSTEMD_REMOTE_USER)
>> -- 
>> 2.25.1
>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@buildroot.org
>> https://lists.buildroot.org/mailman/listinfo/buildroot
Yann E. MORIN April 24, 2022, 2:50 p.m. UTC | #3
Yuanhao, All,

On 2022-04-21 16:55 -0700, TIAN Yuanhao spake thusly:
> On 4/21/22 12:16, Yann E. MORIN wrote:
> >On 2022-04-20 06:55 -0700, TIAN Yuanhao spake thusly:
> >>systemd-udevd needs this group:
> >>   /usr/lib/udev/rules.d/50-udev-default.rules:43 Unknown group 'sgx', ignoring
[--SNIP--]
> >>diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> >>index b07fac27d4..44185a35a0 100644
> >>--- a/package/systemd/systemd.mk
> >>+++ b/package/systemd/systemd.mk
> >>@@ -603,6 +603,7 @@ endef
> >>  define SYSTEMD_USERS
> >>  	# udev user groups
> >>+	- - sgx -1 * - - - SGX device nodes
> >This should have been in the udev virtual package, as all the
> >udev-related users and groups have been moved there to be common between
> >systemd-udevd and the stand-alone eudev, in commit d648d81dd581
> >(packages/{eudev, systemd}: move common users to package/udev).
> I did notice the common rules in the udev virtual package. However "sgx"
> only appears in systemd but not eudev.

OK, my bad. Can you send a patch that moves it back to systemd, please?

> Besides, I found that the "render"
> group in systemd should be "video" in eudev.

This is going to be concerning if the same device nodes have different
groups assigned to them by the two different udev implementations...

In systemd, the renderD* nodes have always been assigned to group
'render', since commit 4e15a7343cb3 (udev-rules: Permission changes for
/dev/dri/renderD*), committed 2017-11-08.

In eudev, renderD* nodes were also assigned to the 'render' group in
commit bb070c154e70 (rules: update), committed 2018-02-20.

But then, in eudev, that was changed with commit a8ffcd1b985f
(rules/50-udev-default.rules: fix issue 160), where they were then
assigned to the 'video' group.

There is not much that is interesting in issue 160, except for some
people reporting issues on distros where the 'render' group does not
exist (along with a bit of the usual whining about systemd).

So, I'm not sure how we should go in that case... Indeed, if we have
packages which want to declare users that belong to the appropriate
group to be able to use the render nodes, then they'd have to know
whether running with systemd or eudev, which was initially the reason to
have a virtual package to abstract that, and have the groups defined in
that virtual package...

Sigh...

But in the end, then yes, 'render' and 'video' should be moved out of
the virtual package and into systemd and eudev, respectively. Can you do
that, please?

Regards,
Yann E. MORIN.

> Regards,
> TIAN Yuanhao
> >
> >Regards,
> >Yann E. MORIN.
> >
> >>  	# systemd user groups
> >>  	- - systemd-journal -1 * - - - Journal
> >>  	$(SYSTEMD_REMOTE_USER)
> >>-- 
> >>2.25.1
> >>
> >>_______________________________________________
> >>buildroot mailing list
> >>buildroot@buildroot.org
> >>https://lists.buildroot.org/mailman/listinfo/buildroot
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard May 24, 2022, 8:19 a.m. UTC | #4
>>>>> "TIAN" == TIAN Yuanhao <tianyuanhao3@163.com> writes:

 > systemd-udevd needs this group:
 >   /usr/lib/udev/rules.d/50-udev-default.rules:43 Unknown group 'sgx', ignoring

 > Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index b07fac27d4..44185a35a0 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -603,6 +603,7 @@  endef
 
 define SYSTEMD_USERS
 	# udev user groups
+	- - sgx -1 * - - - SGX device nodes
 	# systemd user groups
 	- - systemd-journal -1 * - - - Journal
 	$(SYSTEMD_REMOTE_USER)