diff mbox series

[v2,3/3] package/flac: Configure powerpc vector extensions

Message ID 20220407005608.203359-4-joel@jms.id.au
State Accepted
Headers show
Series powerpc: Add flag to control VSX | expand

Commit Message

Joel Stanley April 7, 2022, 12:56 a.m. UTC
Remove the hard coded disabling of altivec and vsx, and instead use the
BR2_POWERPC_CPU_HAS_VSX and BR2_POWERPC_CPU_HAS_ALTIVEC variables to
control the flags.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
 package/flac/flac.mk | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle April 14, 2022, 7:45 p.m. UTC | #1
On 07/04/2022 02:56, Joel Stanley wrote:
> Remove the hard coded disabling of altivec and vsx, and instead use the
> BR2_POWERPC_CPU_HAS_VSX and BR2_POWERPC_CPU_HAS_ALTIVEC variables to
> control the flags.
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>
> ---
>   package/flac/flac.mk | 12 +++++++++---
>   1 file changed, 9 insertions(+), 3 deletions(-)
> 
> diff --git a/package/flac/flac.mk b/package/flac/flac.mk
> index 3a18d81591e6..d1cc42f352f2 100644
> --- a/package/flac/flac.mk
> +++ b/package/flac/flac.mk
> @@ -19,9 +19,15 @@ FLAC_AUTORECONF = YES
>   FLAC_CONF_OPTS = \
>   	$(if $(BR2_INSTALL_LIBSTDCPP),--enable-cpplibs,--disable-cpplibs) \

  I've rewritten this with --enable and --disable in the same style as this.

  Series applied to master, thanks.

  Regards,
  Arnout

>   	--disable-xmms-plugin \
> -	--disable-altivec \
> -	--disable-stack-smash-protection \
> -	--disable-vsx
> +	--disable-stack-smash-protection
> +
> +ifeq ($(BR2_POWERPC_CPU_HAS_VSX),)
> +FLAC_CONF_OPTS += --disable-vsx
> +endif
> +
> +ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),)
> +FLAC_CONF_OPTS += --disable-altivec
> +endif
>   
>   ifeq ($(BR2_PACKAGE_LIBOGG),y)
>   FLAC_CONF_OPTS += --with-ogg=$(STAGING_DIR)/usr
diff mbox series

Patch

diff --git a/package/flac/flac.mk b/package/flac/flac.mk
index 3a18d81591e6..d1cc42f352f2 100644
--- a/package/flac/flac.mk
+++ b/package/flac/flac.mk
@@ -19,9 +19,15 @@  FLAC_AUTORECONF = YES
 FLAC_CONF_OPTS = \
 	$(if $(BR2_INSTALL_LIBSTDCPP),--enable-cpplibs,--disable-cpplibs) \
 	--disable-xmms-plugin \
-	--disable-altivec \
-	--disable-stack-smash-protection \
-	--disable-vsx
+	--disable-stack-smash-protection
+
+ifeq ($(BR2_POWERPC_CPU_HAS_VSX),)
+FLAC_CONF_OPTS += --disable-vsx
+endif
+
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),)
+FLAC_CONF_OPTS += --disable-altivec
+endif
 
 ifeq ($(BR2_PACKAGE_LIBOGG),y)
 FLAC_CONF_OPTS += --with-ogg=$(STAGING_DIR)/usr