diff mbox series

[1/1] package/zlib-ng: fix build on powerpc

Message ID 20220403191103.1019544-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/zlib-ng: fix build on powerpc | expand

Commit Message

Fabrice Fontaine April 3, 2022, 7:11 p.m. UTC
Disable POWER8 optimisations to fix the following build failure with
powerpc and libglib2 raised since bump to version 1.9.9-b1 in commit
1f7b12a0b4572d7e763c431a63c22cfb912b8b14 and
https://github.com/zlib-ng/zlib-ng/commit/b81f4ee96dcbdf1db34b00727b6f1829a2ba1edb:

/home/autobuild/autobuild/instance-9/output-1/host/lib/gcc/powerpc-buildroot-linux-musl/11.2.0/../../../../powerpc-buildroot-linux-musl/bin/ld: /home/autobuild/autobuild/instance-9/output-1/host/powerpc-buildroot-linux-musl/sysroot/usr/lib/libz.a(adler32_power8.c.o): in function `adler32_power8':
/home/autobuild/autobuild/instance-9/output-1/build/zlib-ng-2.0.6/arch/power/adler32_power8.c:106: undefined reference to `vec_sumsu'

Fixes:
 - http://autobuild.buildroot.org/results/f864a0e2307e25342b45c90a5b4fb57a0f5c1c93

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/zlib-ng/zlib-ng.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN April 3, 2022, 7:59 p.m. UTC | #1
Fabrice, All,

On 2022-04-03 21:11 +0200, Fabrice Fontaine spake thusly:
> Disable POWER8 optimisations to fix the following build failure with
> powerpc and libglib2 raised since bump to version 1.9.9-b1 in commit
> 1f7b12a0b4572d7e763c431a63c22cfb912b8b14 and
> https://github.com/zlib-ng/zlib-ng/commit/b81f4ee96dcbdf1db34b00727b6f1829a2ba1edb:
> 
> /home/autobuild/autobuild/instance-9/output-1/host/lib/gcc/powerpc-buildroot-linux-musl/11.2.0/../../../../powerpc-buildroot-linux-musl/bin/ld: /home/autobuild/autobuild/instance-9/output-1/host/powerpc-buildroot-linux-musl/sysroot/usr/lib/libz.a(adler32_power8.c.o): in function `adler32_power8':
> /home/autobuild/autobuild/instance-9/output-1/build/zlib-ng-2.0.6/arch/power/adler32_power8.c:106: undefined reference to `vec_sumsu'
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/f864a0e2307e25342b45c90a5b4fb57a0f5c1c93
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/zlib-ng/zlib-ng.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
> index fb497b8c11..09edfe1faf 100644
> --- a/package/zlib-ng/zlib-ng.mk
> +++ b/package/zlib-ng/zlib-ng.mk
> @@ -15,6 +15,7 @@ ZLIB_NG_PROVIDES = zlib
>  ZLIB_NG_CONF_OPTS += \
>  	-DWITH_GZFILEOP=1 \
>  	-DWITH_OPTIM=1 \
> +	-DWITH_POWER8=OFF \

Why can't that be conditional on BR2_powerpc_power8 ?

Regards,
Yann E. MORIN.

>  	-DZLIB_COMPAT=1 \
>  	-DZLIB_ENABLE_TESTS=OFF
>  
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Fabrice Fontaine April 3, 2022, 8:13 p.m. UTC | #2
Le dim. 3 avr. 2022 à 21:59, Yann E. MORIN <yann.morin.1998@free.fr> a écrit :
>
> Fabrice, All,
>
> On 2022-04-03 21:11 +0200, Fabrice Fontaine spake thusly:
> > Disable POWER8 optimisations to fix the following build failure with
> > powerpc and libglib2 raised since bump to version 1.9.9-b1 in commit
> > 1f7b12a0b4572d7e763c431a63c22cfb912b8b14 and
> > https://github.com/zlib-ng/zlib-ng/commit/b81f4ee96dcbdf1db34b00727b6f1829a2ba1edb:
> >
> > /home/autobuild/autobuild/instance-9/output-1/host/lib/gcc/powerpc-buildroot-linux-musl/11.2.0/../../../../powerpc-buildroot-linux-musl/bin/ld: /home/autobuild/autobuild/instance-9/output-1/host/powerpc-buildroot-linux-musl/sysroot/usr/lib/libz.a(adler32_power8.c.o): in function `adler32_power8':
> > /home/autobuild/autobuild/instance-9/output-1/build/zlib-ng-2.0.6/arch/power/adler32_power8.c:106: undefined reference to `vec_sumsu'
> >
> > Fixes:
> >  - http://autobuild.buildroot.org/results/f864a0e2307e25342b45c90a5b4fb57a0f5c1c93
> >
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >  package/zlib-ng/zlib-ng.mk | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
> > index fb497b8c11..09edfe1faf 100644
> > --- a/package/zlib-ng/zlib-ng.mk
> > +++ b/package/zlib-ng/zlib-ng.mk
> > @@ -15,6 +15,7 @@ ZLIB_NG_PROVIDES = zlib
> >  ZLIB_NG_CONF_OPTS += \
> >       -DWITH_GZFILEOP=1 \
> >       -DWITH_OPTIM=1 \
> > +     -DWITH_POWER8=OFF \
>
> Why can't that be conditional on BR2_powerpc_power8 ?

It can, I'll send a v2.
However, it should be noted that power8 is unconditionally disabled on
mesa3d though.

>
> Regards,
> Yann E. MORIN.
>
> >       -DZLIB_COMPAT=1 \
> >       -DZLIB_ENABLE_TESTS=OFF
> >
> > --
> > 2.35.1
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
Best Regards,

Fabrice
diff mbox series

Patch

diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
index fb497b8c11..09edfe1faf 100644
--- a/package/zlib-ng/zlib-ng.mk
+++ b/package/zlib-ng/zlib-ng.mk
@@ -15,6 +15,7 @@  ZLIB_NG_PROVIDES = zlib
 ZLIB_NG_CONF_OPTS += \
 	-DWITH_GZFILEOP=1 \
 	-DWITH_OPTIM=1 \
+	-DWITH_POWER8=OFF \
 	-DZLIB_COMPAT=1 \
 	-DZLIB_ENABLE_TESTS=OFF