diff mbox series

package/python-{treq, twisted}: add a comment to use the same version

Message ID 20220331201718.728570-1-romain.naour@gmail.com
State Accepted
Headers show
Series package/python-{treq, twisted}: add a comment to use the same version | expand

Commit Message

Romain Naour March 31, 2022, 8:17 p.m. UTC
As reported by [1], python-twisted and python-treq must use the same
version because its the same project:

https://github.com/twisted/twisted
https://github.com/twisted/treq

We have to update python-treq to version 22.2.0 [2] otherwise we have
a runtime issue:

Traceback (most recent call last):
  File "/root/sample_python_treq.py", line 2, in <module>
    import treq
  File "/usr/lib/python3.10/site-packages/treq/__init__.py", line 5, in <module>
  File "/usr/lib/python3.10/site-packages/treq/api.py", line 5, in <module>
  File "/usr/lib/python3.10/site-packages/treq/client.py", line 11, in <module>
ImportError: cannot import name '_PY3' from 'twisted.python.compat' (unknown
location)

The comment should avoid forgeting one of them while upgrading or
backporting version bump.

[1] http://lists.busybox.net/pipermail/buildroot/2022-February/637505.html
[2] https://github.com/twisted/treq/releases/tag/release-22.2.0
[3] https://gitlab.com/buildroot.org/buildroot/-/jobs/2179206653

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/python-treq/python-treq.mk       | 3 +++
 package/python-twisted/python-twisted.mk | 3 +++
 2 files changed, 6 insertions(+)

Comments

Peter Korsgaard April 3, 2022, 9:44 a.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@gmail.com> writes:

 > As reported by [1], python-twisted and python-treq must use the same
 > version because its the same project:

 > https://github.com/twisted/twisted
 > https://github.com/twisted/treq

 > We have to update python-treq to version 22.2.0 [2] otherwise we have
 > a runtime issue:

 > Traceback (most recent call last):
 >   File "/root/sample_python_treq.py", line 2, in <module>
 >     import treq
 >   File "/usr/lib/python3.10/site-packages/treq/__init__.py", line 5, in <module>
 >   File "/usr/lib/python3.10/site-packages/treq/api.py", line 5, in <module>
 >   File "/usr/lib/python3.10/site-packages/treq/client.py", line 11, in <module>
 > ImportError: cannot import name '_PY3' from 'twisted.python.compat' (unknown
 > location)

 > The comment should avoid forgeting one of them while upgrading or
 > backporting version bump.

 > [1] http://lists.busybox.net/pipermail/buildroot/2022-February/637505.html
 > [2] https://github.com/twisted/treq/releases/tag/release-22.2.0
 > [3] https://gitlab.com/buildroot.org/buildroot/-/jobs/2179206653

 > Signed-off-by: Romain Naour <romain.naour@gmail.com>
 > Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard April 4, 2022, 12:48 p.m. UTC | #2
>>>>> "Romain" == Romain Naour <romain.naour@gmail.com> writes:

 > As reported by [1], python-twisted and python-treq must use the same
 > version because its the same project:

 > https://github.com/twisted/twisted
 > https://github.com/twisted/treq

 > We have to update python-treq to version 22.2.0 [2] otherwise we have
 > a runtime issue:

 > Traceback (most recent call last):
 >   File "/root/sample_python_treq.py", line 2, in <module>
 >     import treq
 >   File "/usr/lib/python3.10/site-packages/treq/__init__.py", line 5, in <module>
 >   File "/usr/lib/python3.10/site-packages/treq/api.py", line 5, in <module>
 >   File "/usr/lib/python3.10/site-packages/treq/client.py", line 11, in <module>
 > ImportError: cannot import name '_PY3' from 'twisted.python.compat' (unknown
 > location)

 > The comment should avoid forgeting one of them while upgrading or
 > backporting version bump.

 > [1] http://lists.busybox.net/pipermail/buildroot/2022-February/637505.html
 > [2] https://github.com/twisted/treq/releases/tag/release-22.2.0
 > [3] https://gitlab.com/buildroot.org/buildroot/-/jobs/2179206653

 > Signed-off-by: Romain Naour <romain.naour@gmail.com>
 > Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2021.02.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/python-treq/python-treq.mk b/package/python-treq/python-treq.mk
index 57dc50ee74..8995bf2cfe 100644
--- a/package/python-treq/python-treq.mk
+++ b/package/python-treq/python-treq.mk
@@ -4,6 +4,9 @@ 
 #
 ################################################################################
 
+# When bumping this package, make sure to also verify if the
+# python-twisted package still works and to update its hash,
+# as they share the same version/site variables.
 PYTHON_TREQ_VERSION = 22.2.0
 PYTHON_TREQ_SOURCE = treq-$(PYTHON_TREQ_VERSION).tar.gz
 PYTHON_TREQ_SITE = https://files.pythonhosted.org/packages/cd/c8/b68ab17d994133baf6edbcb5551ba81e1494bdc6d5e21a9d4f3bc4315140
diff --git a/package/python-twisted/python-twisted.mk b/package/python-twisted/python-twisted.mk
index e5d643ec05..8a89d3dc82 100644
--- a/package/python-twisted/python-twisted.mk
+++ b/package/python-twisted/python-twisted.mk
@@ -4,6 +4,9 @@ 
 #
 ################################################################################
 
+# When bumping this package, make sure to also verify if the
+# python-treq package still works and to update its hash,
+# as they share the same version/site variables.
 PYTHON_TWISTED_VERSION = 22.2.0
 PYTHON_TWISTED_SOURCE = Twisted-$(PYTHON_TWISTED_VERSION).tar.gz
 PYTHON_TWISTED_SITE = https://files.pythonhosted.org/packages/40/8b/56e8870d412c550b3ff2d6714ee212c7e80a6634f4e720c3a26a983e7b46