diff mbox series

[v1] package/wireshark: fix compile with ccache enabled

Message ID 20220325190934.24982-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1] package/wireshark: fix compile with ccache enabled | expand

Commit Message

Peter Seiderer March 25, 2022, 7:09 p.m. UTC
- use HOSTCC_NOCCACHE (instead of HOSTCC) for LEMON_C_COMPILER

Fixes:
  [...] /usr/bin/cmake [...] -DLEMON_C_COMPILER=.../host/bin/ccache /usr/bin/gcc [...]
  [...]
  [  0%] Building C object tools/lemon/CMakeFiles/lemon.dir/lemon.c.o
  .../host/bin/ccache: invalid option -- 'D'

Reported-by: Dan Ambrosio <dambrosio@outrider.ai>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/wireshark/wireshark.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 27, 2022, 4:28 p.m. UTC | #1
On 25/03/2022 20:09, Peter Seiderer wrote:
> - use HOSTCC_NOCCACHE (instead of HOSTCC) for LEMON_C_COMPILER
> 
> Fixes:
>    [...] /usr/bin/cmake [...] -DLEMON_C_COMPILER=.../host/bin/ccache /usr/bin/gcc [...]
>    [...]
>    [  0%] Building C object tools/lemon/CMakeFiles/lemon.dir/lemon.c.o
>    .../host/bin/ccache: invalid option -- 'D'
> 
> Reported-by: Dan Ambrosio <dambrosio@outrider.ai>
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/wireshark/wireshark.mk | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/wireshark/wireshark.mk b/package/wireshark/wireshark.mk
> index a5ca4b1f73..1a549f7037 100644
> --- a/package/wireshark/wireshark.mk
> +++ b/package/wireshark/wireshark.mk
> @@ -25,7 +25,7 @@ WIRESHARK_CONF_OPTS = \
>   	-DENABLE_ILBC=OFF \
>   	-DENABLE_PCAP=ON \
>   	-DENABLE_SMI=OFF \
> -	-DLEMON_C_COMPILER=$(HOSTCC)
> +	-DLEMON_C_COMPILER=$(HOSTCC_NOCCACHE)
>   
>   ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
>   WIRESHARK_CONF_OPTS += -DCMAKE_EXE_LINKER_FLAGS=-latomic
Peter Korsgaard March 31, 2022, 11:44 a.m. UTC | #2
>>>>> "Peter" == Peter Seiderer <ps.report@gmx.net> writes:

 > - use HOSTCC_NOCCACHE (instead of HOSTCC) for LEMON_C_COMPILER
 > Fixes:
 >   [...] /usr/bin/cmake [...] -DLEMON_C_COMPILER=.../host/bin/ccache /usr/bin/gcc [...]
 >   [...]
 >   [  0%] Building C object tools/lemon/CMakeFiles/lemon.dir/lemon.c.o
 >   .../host/bin/ccache: invalid option -- 'D'

 > Reported-by: Dan Ambrosio <dambrosio@outrider.ai>
 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Committed to 2021.02.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/wireshark/wireshark.mk b/package/wireshark/wireshark.mk
index a5ca4b1f73..1a549f7037 100644
--- a/package/wireshark/wireshark.mk
+++ b/package/wireshark/wireshark.mk
@@ -25,7 +25,7 @@  WIRESHARK_CONF_OPTS = \
 	-DENABLE_ILBC=OFF \
 	-DENABLE_PCAP=ON \
 	-DENABLE_SMI=OFF \
-	-DLEMON_C_COMPILER=$(HOSTCC)
+	-DLEMON_C_COMPILER=$(HOSTCC_NOCCACHE)
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 WIRESHARK_CONF_OPTS += -DCMAKE_EXE_LINKER_FLAGS=-latomic