diff mbox series

[1/1] package/gdk-pixbuf: fix target loaders.cache

Message ID 20220322190032.2566880-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gdk-pixbuf: fix target loaders.cache | expand

Commit Message

Fabrice Fontaine March 22, 2022, 7 p.m. UTC
As reported by Rutger Sassen in
https://lists.buildroot.org/pipermail/buildroot/2022-March/638895.html,
target loaders.cache is broken since commit
75361a9aba042799040591fb84192802b137fc3a so fix it by prepending /usr/
to relative host paths

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gdk-pixbuf/gdk-pixbuf.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle March 27, 2022, 4:09 p.m. UTC | #1
On 22/03/2022 20:00, Fabrice Fontaine wrote:
> As reported by Rutger Sassen in
> https://lists.buildroot.org/pipermail/buildroot/2022-March/638895.html,
> target loaders.cache is broken since commit
> 75361a9aba042799040591fb84192802b137fc3a so fix it by prepending /usr/
> to relative host paths
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/gdk-pixbuf/gdk-pixbuf.mk | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
> index 6eaf023789..69bb34b0cb 100644
> --- a/package/gdk-pixbuf/gdk-pixbuf.mk
> +++ b/package/gdk-pixbuf/gdk-pixbuf.mk
> @@ -70,14 +70,14 @@ endif
>   # gdk-pixbuf requires the loaders.cache file populated to work properly
>   # Rather than doing so at runtime, since the fs can be read-only, do so
>   # here after building and installing to target.
> -# And since the cache file will contain absolute host directory names we
> -# need to sanitize (strip) them.
> +# And since the cache file will contain relative host directory names we
> +# need to prepend them with /usr/.
>   ifeq ($(BR2_STATIC_LIBS),)
>   define GDK_PIXBUF_UPDATE_CACHE
>   	GDK_PIXBUF_MODULEDIR=$(HOST_DIR)/lib/gdk-pixbuf-2.0/2.10.0/loaders \
>   		$(HOST_DIR)/bin/gdk-pixbuf-query-loaders \
>   		> $(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
> -	$(SED) "s,$(HOST_DIR)/lib,/usr/lib,g" \
> +	$(SED) 's,^"lib,"/usr/lib,g' \
>   		$(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
>   endef
>   GDK_PIXBUF_POST_INSTALL_TARGET_HOOKS += GDK_PIXBUF_UPDATE_CACHE
Peter Korsgaard March 31, 2022, 11:21 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > As reported by Rutger Sassen in
 > https://lists.buildroot.org/pipermail/buildroot/2022-March/638895.html,
 > target loaders.cache is broken since commit
 > 75361a9aba042799040591fb84192802b137fc3a so fix it by prepending /usr/
 > to relative host paths

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2021.02.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
index 6eaf023789..69bb34b0cb 100644
--- a/package/gdk-pixbuf/gdk-pixbuf.mk
+++ b/package/gdk-pixbuf/gdk-pixbuf.mk
@@ -70,14 +70,14 @@  endif
 # gdk-pixbuf requires the loaders.cache file populated to work properly
 # Rather than doing so at runtime, since the fs can be read-only, do so
 # here after building and installing to target.
-# And since the cache file will contain absolute host directory names we
-# need to sanitize (strip) them.
+# And since the cache file will contain relative host directory names we
+# need to prepend them with /usr/.
 ifeq ($(BR2_STATIC_LIBS),)
 define GDK_PIXBUF_UPDATE_CACHE
 	GDK_PIXBUF_MODULEDIR=$(HOST_DIR)/lib/gdk-pixbuf-2.0/2.10.0/loaders \
 		$(HOST_DIR)/bin/gdk-pixbuf-query-loaders \
 		> $(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
-	$(SED) "s,$(HOST_DIR)/lib,/usr/lib,g" \
+	$(SED) 's,^"lib,"/usr/lib,g' \
 		$(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
 endef
 GDK_PIXBUF_POST_INSTALL_TARGET_HOOKS += GDK_PIXBUF_UPDATE_CACHE