diff mbox series

[v2,5/5] package/wget: bump version to 1.21.3

Message ID 20220318202044.10413-5-ps.report@gmx.net
State Changes Requested
Headers show
Series [v2,1/5] package/wget: explicit set some default options | expand

Commit Message

Peter Seiderer March 18, 2022, 8:20 p.m. UTC
- bump version to 1.21.3 (for details see [1])

- remove legacy --with-libidn option (see [2]), replace with
  --enable-iri option in case locale support and libidn2 are available

[1] https://lists.gnu.org/archive/html/info-gnu/2022-02/msg00017.html
[2] https://git.savannah.gnu.org/cgit/wget.git/commit/configure.ac?id=a24e67e239ef949cc77a4c4e5a0beb703026a296

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Changes v1 -> v2:
  - split out from original patch
  - fix iri option enable dependency
---
 package/wget/wget.hash |  4 ++--
 package/wget/wget.mk   | 14 ++++++--------
 2 files changed, 8 insertions(+), 10 deletions(-)

Comments

Peter Seiderer March 18, 2022, 8:50 p.m. UTC | #1
Hello *,

On Fri, 18 Mar 2022 21:20:44 +0100, Peter Seiderer <ps.report@gmx.net> wrote:

> - bump version to 1.21.3 (for details see [1])
>
> - remove legacy --with-libidn option (see [2]), replace with
>   --enable-iri option in case locale support and libidn2 are available
>
> [1] https://lists.gnu.org/archive/html/info-gnu/2022-02/msg00017.html
> [2] https://git.savannah.gnu.org/cgit/wget.git/commit/configure.ac?id=a24e67e239ef949cc77a4c4e5a0beb703026a296
>
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
> Changes v1 -> v2:
>   - split out from original patch
>   - fix iri option enable dependency
> ---
>  package/wget/wget.hash |  4 ++--
>  package/wget/wget.mk   | 14 ++++++--------
>  2 files changed, 8 insertions(+), 10 deletions(-)
>
> diff --git a/package/wget/wget.hash b/package/wget/wget.hash
> index 7f89bedb88..22674650a2 100644
> --- a/package/wget/wget.hash
> +++ b/package/wget/wget.hash
> @@ -1,6 +1,6 @@
>  # Locally calculated after checking pgp signature
> -# https://ftp.gnu.org/gnu/wget/wget-1.21.2.tar.lz.sig
> +# https://ftp.gnu.org/gnu/wget/wget-1.21.3.tar.lz.sig
>  # with key 6B98F637D879C5236E277C5C64FF90AAE8C70AF9
> -sha256  1727a330a86acacb3e57615ce268f5f29978bf7adec4abe6a30d370207bc91b3  wget-1.21.2.tar.lz
> +sha256  dbd2fb5e47149d4752d0eaa0dac68cc49cf20d46df4f8e326ffc8f18b2af4ea5  wget-1.21.3.tar.lz
>  # Locally calculated
>  sha256  e79e9c8a0c85d735ff98185918ec94ed7d175efc377012787aebcf3b80f0d90b  COPYING
> diff --git a/package/wget/wget.mk b/package/wget/wget.mk
> index 69ca8f261c..079afbee48 100644
> --- a/package/wget/wget.mk
> +++ b/package/wget/wget.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>
> -WGET_VERSION = 1.21.2
> +WGET_VERSION = 1.21.3
>  WGET_SOURCE = wget-$(WGET_VERSION).tar.lz
>  WGET_SITE = $(BR2_GNU_MIRROR)/wget
>  WGET_DEPENDENCIES = host-pkgconf
> @@ -38,15 +38,13 @@ else
>  WGET_CONF_OPTS += --without-ssl
>  endif
>
> -ifeq ($(BR2_PACKAGE_LIBICONV),y)
> -WGET_DEPENDENCIES += libiconv
> -endif

The above code one should be kept as there is at least one other
location in the source using iconv (protexted by '#ifdef HAVE_ICONV',
see src/url.c)...

> -
> -ifeq ($(BR2_PACKAGE_LIBIDN2),y)
> -WGET_CONF_OPTS += --with-libidn
> +# BR2_ENABLE_LOCALE and BR2_PACKAGE_LIBICONV are mutually exclusive
> +ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV)$(BR2_PACKAGE_LIBIDN2),yy)
> +WGET_CONF_OPTS += --enable-iri
>  WGET_DEPENDENCIES += libidn2
> +WGET_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)

And so the above line can be removed...

Will send an updated patch set...

Regards,
Peter

>  else
> -WGET_CONF_OPTS += --without-libidn
> +WGET_CONF_OPTS += --disable-iri
>  endif
>
>  ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
diff mbox series

Patch

diff --git a/package/wget/wget.hash b/package/wget/wget.hash
index 7f89bedb88..22674650a2 100644
--- a/package/wget/wget.hash
+++ b/package/wget/wget.hash
@@ -1,6 +1,6 @@ 
 # Locally calculated after checking pgp signature
-# https://ftp.gnu.org/gnu/wget/wget-1.21.2.tar.lz.sig
+# https://ftp.gnu.org/gnu/wget/wget-1.21.3.tar.lz.sig
 # with key 6B98F637D879C5236E277C5C64FF90AAE8C70AF9
-sha256  1727a330a86acacb3e57615ce268f5f29978bf7adec4abe6a30d370207bc91b3  wget-1.21.2.tar.lz
+sha256  dbd2fb5e47149d4752d0eaa0dac68cc49cf20d46df4f8e326ffc8f18b2af4ea5  wget-1.21.3.tar.lz
 # Locally calculated
 sha256  e79e9c8a0c85d735ff98185918ec94ed7d175efc377012787aebcf3b80f0d90b  COPYING
diff --git a/package/wget/wget.mk b/package/wget/wget.mk
index 69ca8f261c..079afbee48 100644
--- a/package/wget/wget.mk
+++ b/package/wget/wget.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-WGET_VERSION = 1.21.2
+WGET_VERSION = 1.21.3
 WGET_SOURCE = wget-$(WGET_VERSION).tar.lz
 WGET_SITE = $(BR2_GNU_MIRROR)/wget
 WGET_DEPENDENCIES = host-pkgconf
@@ -38,15 +38,13 @@  else
 WGET_CONF_OPTS += --without-ssl
 endif
 
-ifeq ($(BR2_PACKAGE_LIBICONV),y)
-WGET_DEPENDENCIES += libiconv
-endif
-
-ifeq ($(BR2_PACKAGE_LIBIDN2),y)
-WGET_CONF_OPTS += --with-libidn
+# BR2_ENABLE_LOCALE and BR2_PACKAGE_LIBICONV are mutually exclusive
+ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV)$(BR2_PACKAGE_LIBIDN2),yy)
+WGET_CONF_OPTS += --enable-iri
 WGET_DEPENDENCIES += libidn2
+WGET_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 else
-WGET_CONF_OPTS += --without-libidn
+WGET_CONF_OPTS += --disable-iri
 endif
 
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)