diff mbox series

[v5,2/8] package/python-cryptography: enable host package

Message ID 20220318132427.48737-3-clement.leger@bootlin.com
State Accepted
Headers show
Series boot/optee-os: support new optee-os 3.16.0 build dependencies | expand

Commit Message

Clément Léger March 18, 2022, 1:24 p.m. UTC
Enable host package and add needed variables. Host POST_PROCESS and
DOWNLOAD_DEPENDENCIES variables are inherited from target ones.

Acked-by: Etienne Carriere <etienne.carriere@linaro.org>
Signed-off-by: Clément Léger <clement.leger@bootlin.com>
---
 package/python-cryptography/python-cryptography.mk | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Yann E. MORIN March 18, 2022, 10:32 p.m. UTC | #1
Clément, All,

On 2022-03-18 14:24 +0100, Clément Léger spake thusly:
> Enable host package and add needed variables. Host POST_PROCESS and
> DOWNLOAD_DEPENDENCIES variables are inherited from target ones.
> 
> Acked-by: Etienne Carriere <etienne.carriere@linaro.org>
> Signed-off-by: Clément Léger <clement.leger@bootlin.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/python-cryptography/python-cryptography.mk | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> diff --git a/package/python-cryptography/python-cryptography.mk b/package/python-cryptography/python-cryptography.mk
> index a524f729c8..872ede9b89 100644
> --- a/package/python-cryptography/python-cryptography.mk
> +++ b/package/python-cryptography/python-cryptography.mk
> @@ -17,14 +17,26 @@ PYTHON_CRYPTOGRAPHY_DEPENDENCIES = \
>  	host-python-cffi \
>  	host-rustc \
>  	openssl
> +HOST_PYTHON_CRYPTOGRAPHY_DEPENDENCIES = \
> +	host-python-setuptools-rust \
> +	host-python-cffi \
> +	host-rustc \
> +	host-openssl
>  PYTHON_CRYPTOGRAPHY_ENV = \
>  	$(PKG_CARGO_ENV) \
>  	PYO3_CROSS_LIB_DIR="$(STAGING_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)"
> +HOST_PYTHON_CRYPTOGRAPHY_ENV = \
> +	$(HOST_PKG_CARGO_ENV) \
> +	PYO3_CROSS_LIB_DIR="$(HOST_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)"
>  # We need to vendor the Cargo crates at download time
>  PYTHON_CRYPTOGRAPHY_DOWNLOAD_POST_PROCESS = cargo
>  PYTHON_CRYPTOGRAPHY_DOWNLOAD_DEPENDENCIES = host-rustc
>  PYTHON_CRYPTOGRAPHY_DL_ENV = \
>  	$(PKG_CARGO_ENV) \
>  	BR_CARGO_MANIFEST_PATH=src/rust/Cargo.toml
> +HOST_PYTHON_CRYPTOGRAPHY_DL_ENV = \
> +	$(HOST_PKG_CARGO_ENV) \
> +	BR_CARGO_MANIFEST_PATH=src/rust/Cargo.toml
>  
>  $(eval $(python-package))
> +$(eval $(host-python-package))
> -- 
> 2.34.1
>
diff mbox series

Patch

diff --git a/package/python-cryptography/python-cryptography.mk b/package/python-cryptography/python-cryptography.mk
index a524f729c8..872ede9b89 100644
--- a/package/python-cryptography/python-cryptography.mk
+++ b/package/python-cryptography/python-cryptography.mk
@@ -17,14 +17,26 @@  PYTHON_CRYPTOGRAPHY_DEPENDENCIES = \
 	host-python-cffi \
 	host-rustc \
 	openssl
+HOST_PYTHON_CRYPTOGRAPHY_DEPENDENCIES = \
+	host-python-setuptools-rust \
+	host-python-cffi \
+	host-rustc \
+	host-openssl
 PYTHON_CRYPTOGRAPHY_ENV = \
 	$(PKG_CARGO_ENV) \
 	PYO3_CROSS_LIB_DIR="$(STAGING_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)"
+HOST_PYTHON_CRYPTOGRAPHY_ENV = \
+	$(HOST_PKG_CARGO_ENV) \
+	PYO3_CROSS_LIB_DIR="$(HOST_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)"
 # We need to vendor the Cargo crates at download time
 PYTHON_CRYPTOGRAPHY_DOWNLOAD_POST_PROCESS = cargo
 PYTHON_CRYPTOGRAPHY_DOWNLOAD_DEPENDENCIES = host-rustc
 PYTHON_CRYPTOGRAPHY_DL_ENV = \
 	$(PKG_CARGO_ENV) \
 	BR_CARGO_MANIFEST_PATH=src/rust/Cargo.toml
+HOST_PYTHON_CRYPTOGRAPHY_DL_ENV = \
+	$(HOST_PKG_CARGO_ENV) \
+	BR_CARGO_MANIFEST_PATH=src/rust/Cargo.toml
 
 $(eval $(python-package))
+$(eval $(host-python-package))