diff mbox series

[2/2] package/bind: fix libxml2 build

Message ID 20220313092148.353432-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/bind: reorder openssl variables | expand

Commit Message

Fabrice Fontaine March 13, 2022, 9:21 a.m. UTC
Fix the following build failure with libxml2 raised since bump to
version 9.16.26 in commit 8adeaec8afacbc680edebae91524f6144926ac92:

configure: error: Specifying libxml2 installation path is not supported, adjust PKG_CONFIG_PATH instead

Fixes:
 - http://autobuild.buildroot.org/results/648d29e4cfa6a40bb6e54793c044e9c834f03a1b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/bind/bind.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

James Hilliard March 14, 2022, 6:15 p.m. UTC | #1
On Sun, Mar 13, 2022 at 3:23 AM Fabrice Fontaine
<fontaine.fabrice@gmail.com> wrote:
>
> Fix the following build failure with libxml2 raised since bump to
> version 9.16.26 in commit 8adeaec8afacbc680edebae91524f6144926ac92:
>
> configure: error: Specifying libxml2 installation path is not supported, adjust PKG_CONFIG_PATH instead
>
> Fixes:
>  - http://autobuild.buildroot.org/results/648d29e4cfa6a40bb6e54793c044e9c834f03a1b
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/bind/bind.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/bind/bind.mk b/package/bind/bind.mk
> index e0c81152e1..63cc948c73 100644
> --- a/package/bind/bind.mk
> +++ b/package/bind/bind.mk
> @@ -74,7 +74,7 @@ BIND_CONF_OPTS += --with-gssapi=no
>  endif
>
>  ifeq ($(BR2_PACKAGE_LIBXML2),y)
> -BIND_CONF_OPTS += --with-libxml2=$(STAGING_DIR)/usr
> +BIND_CONF_OPTS += --with-libxml2
>  BIND_DEPENDENCIES += libxml2
>  else
>  BIND_CONF_OPTS += --with-libxml2=no
> --
> 2.34.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard March 23, 2022, 9:11 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with libxml2 raised since bump to
 > version 9.16.26 in commit 8adeaec8afacbc680edebae91524f6144926ac92:

 > configure: error: Specifying libxml2 installation path is not
 > supported, adjust PKG_CONFIG_PATH instead

 > Fixes:
 >  - http://autobuild.buildroot.org/results/648d29e4cfa6a40bb6e54793c044e9c834f03a1b

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index e0c81152e1..63cc948c73 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -74,7 +74,7 @@  BIND_CONF_OPTS += --with-gssapi=no
 endif
 
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
-BIND_CONF_OPTS += --with-libxml2=$(STAGING_DIR)/usr
+BIND_CONF_OPTS += --with-libxml2
 BIND_DEPENDENCIES += libxml2
 else
 BIND_CONF_OPTS += --with-libxml2=no