diff mbox series

[1/1] package/pkg-python: apply host platform and project base to pep517 env

Message ID 20220311192726.3879992-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/pkg-python: apply host platform and project base to pep517 env | expand

Commit Message

James Hilliard March 11, 2022, 7:27 p.m. UTC
The _PYTHON_HOST_PLATFORM and _PYTHON_PROJECT_BASE variables should
also be set for pep517 builds as they are not setuptools/distutils
specific.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/pkg-python.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yann E. MORIN March 12, 2022, 5:03 p.m. UTC | #1
Kames, All,

On 2022-03-11 12:27 -0700, James Hilliard spake thusly:
> The _PYTHON_HOST_PLATFORM and _PYTHON_PROJECT_BASE variables should
> also be set for pep517 builds as they are not setuptools/distutils
> specific.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/pkg-python.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/pkg-python.mk b/package/pkg-python.mk
> index f031bc8fae..52ce402281 100644
> --- a/package/pkg-python.mk
> +++ b/package/pkg-python.mk
> @@ -113,6 +113,8 @@ HOST_PKG_PYTHON_SETUPTOOLS_INSTALL_OPTS = \
>  
>  # Target pep517-based packages
>  PKG_PYTHON_PEP517_ENV = \
> +	_PYTHON_HOST_PLATFORM="$(PKG_PYTHON_HOST_PLATFORM)" \
> +	_PYTHON_PROJECT_BASE="$(PYTHON3_DIR)" \
>  	_PYTHON_SYSCONFIGDATA_NAME="$(PKG_PYTHON_SYSCONFIGDATA_NAME)" \
>  	PATH=$(BR_PATH) \
>  	$(TARGET_CONFIGURE_OPTS) \
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/pkg-python.mk b/package/pkg-python.mk
index f031bc8fae..52ce402281 100644
--- a/package/pkg-python.mk
+++ b/package/pkg-python.mk
@@ -113,6 +113,8 @@  HOST_PKG_PYTHON_SETUPTOOLS_INSTALL_OPTS = \
 
 # Target pep517-based packages
 PKG_PYTHON_PEP517_ENV = \
+	_PYTHON_HOST_PLATFORM="$(PKG_PYTHON_HOST_PLATFORM)" \
+	_PYTHON_PROJECT_BASE="$(PYTHON3_DIR)" \
 	_PYTHON_SYSCONFIGDATA_NAME="$(PKG_PYTHON_SYSCONFIGDATA_NAME)" \
 	PATH=$(BR_PATH) \
 	$(TARGET_CONFIGURE_OPTS) \