diff mbox series

[v2] package/qt5/qt5webkit: needs OpenSSL

Message ID 20220222210024.6013-1-abrodkin@synopsys.com
State Accepted
Headers show
Series [v2] package/qt5/qt5webkit: needs OpenSSL | expand

Commit Message

Alexey Brodkin Feb. 22, 2022, 9 p.m. UTC
W/o OpenSSL QT5Webkit fails to build that way:
-------------------------------->8-----------------------------
.../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp: In static member function ‘static bool WebCore::ResourceRequest::alpnIsSupported()’:
.../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp:68:12: error: ‘QSslSocket’ has not been declared
   68 |     return QSslSocket::sslLibraryVersionNumber() > 0x10002000L &&
      |            ^~~~~~~~~~
.../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp:69:9: error: ‘QSslSocket’ has not been declared
   69 |         QSslSocket::sslLibraryVersionString().startsWith(QLatin1String("OpenSSL"));
      |         ^~~~~~~~~~
-------------------------------->8-----------------------------

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Cc: James Hilliard <james.hilliard1@gmail.com>
Cc: Peter Seiderer <ps.report@gmx.net>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
---

Changes v1 -> v2:

 * Added "openssl" to QT5WEBKIT_DEPENDENCIES, thanks Yann for
   spotting this one.

Note that I interntionally added "openssl" not following
alphabetic order because:

 1. Existing dependencies are already a bit shufffled
 2. I wanted to keep this diff as small as possible, w/o
    re-shuffling multiple lines. If really needed we may do
    reordering in a separate patch.

---
 package/qt5/qt5webkit/Config.in    | 1 +
 package/qt5/qt5webkit/qt5webkit.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 7, 2022, 10:09 p.m. UTC | #1
On 22/02/2022 22:00, Alexey Brodkin via buildroot wrote:
> W/o OpenSSL QT5Webkit fails to build that way:
> -------------------------------->8-----------------------------
> .../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp: In static member function ‘static bool WebCore::ResourceRequest::alpnIsSupported()’:
> .../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp:68:12: error: ‘QSslSocket’ has not been declared
>     68 |     return QSslSocket::sslLibraryVersionNumber() > 0x10002000L &&
>        |            ^~~~~~~~~~
> .../build/qt5webkit-5.212.0-alpha4/Source/WebCore/platform/network/qt/ResourceRequestQt.cpp:69:9: error: ‘QSslSocket’ has not been declared
>     69 |         QSslSocket::sslLibraryVersionString().startsWith(QLatin1String("OpenSSL"));
>        |         ^~~~~~~~~~
> -------------------------------->8-----------------------------
> 
> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> Cc: James Hilliard <james.hilliard1@gmail.com>
> Cc: Peter Seiderer <ps.report@gmx.net>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
> 
> Changes v1 -> v2:
> 
>   * Added "openssl" to QT5WEBKIT_DEPENDENCIES, thanks Yann for
>     spotting this one.
> 
> Note that I interntionally added "openssl" not following
> alphabetic order because:
> 
>   1. Existing dependencies are already a bit shufffled
>   2. I wanted to keep this diff as small as possible, w/o
>      re-shuffling multiple lines. If really needed we may do
>      reordering in a separate patch.
> 
> ---
>   package/qt5/qt5webkit/Config.in    | 1 +
>   package/qt5/qt5webkit/qt5webkit.mk | 2 +-
>   2 files changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/qt5/qt5webkit/Config.in b/package/qt5/qt5webkit/Config.in
> index ed87efca95..26c3897d1d 100644
> --- a/package/qt5/qt5webkit/Config.in
> +++ b/package/qt5/qt5webkit/Config.in
> @@ -15,6 +15,7 @@ config BR2_PACKAGE_QT5WEBKIT
>   	select BR2_PACKAGE_JPEG
>   	select BR2_PACKAGE_LEVELDB
>   	select BR2_PACKAGE_LIBPNG
> +	select BR2_PACKAGE_OPENSSL
>   	select BR2_PACKAGE_QT5BASE_ICU
>   	select BR2_PACKAGE_QT5BASE_GUI
>   	select BR2_PACKAGE_QT5BASE_WIDGETS
> diff --git a/package/qt5/qt5webkit/qt5webkit.mk b/package/qt5/qt5webkit/qt5webkit.mk
> index 2e96acc00f..c9b354e725 100644
> --- a/package/qt5/qt5webkit/qt5webkit.mk
> +++ b/package/qt5/qt5webkit/qt5webkit.mk
> @@ -10,7 +10,7 @@ QT5WEBKIT_SOURCE = qtwebkit-$(QT5WEBKIT_VERSION).tar.xz
>   QT5WEBKIT_DEPENDENCIES = \
>   	host-bison host-flex host-gperf host-python3 host-ruby gstreamer1 \
>   	gst1-plugins-base icu leveldb jpeg libpng libxml2 libxslt qt5location \
> -	qt5sensors qt5webchannel sqlite webp woff2
> +	openssl qt5sensors qt5webchannel sqlite webp woff2
>   QT5WEBKIT_INSTALL_STAGING = YES
>   
>   QT5WEBKIT_LICENSE_FILES = Source/WebCore/LICENSE-LGPL-2 Source/WebCore/LICENSE-LGPL-2.1
diff mbox series

Patch

diff --git a/package/qt5/qt5webkit/Config.in b/package/qt5/qt5webkit/Config.in
index ed87efca95..26c3897d1d 100644
--- a/package/qt5/qt5webkit/Config.in
+++ b/package/qt5/qt5webkit/Config.in
@@ -15,6 +15,7 @@  config BR2_PACKAGE_QT5WEBKIT
 	select BR2_PACKAGE_JPEG
 	select BR2_PACKAGE_LEVELDB
 	select BR2_PACKAGE_LIBPNG
+	select BR2_PACKAGE_OPENSSL
 	select BR2_PACKAGE_QT5BASE_ICU
 	select BR2_PACKAGE_QT5BASE_GUI
 	select BR2_PACKAGE_QT5BASE_WIDGETS
diff --git a/package/qt5/qt5webkit/qt5webkit.mk b/package/qt5/qt5webkit/qt5webkit.mk
index 2e96acc00f..c9b354e725 100644
--- a/package/qt5/qt5webkit/qt5webkit.mk
+++ b/package/qt5/qt5webkit/qt5webkit.mk
@@ -10,7 +10,7 @@  QT5WEBKIT_SOURCE = qtwebkit-$(QT5WEBKIT_VERSION).tar.xz
 QT5WEBKIT_DEPENDENCIES = \
 	host-bison host-flex host-gperf host-python3 host-ruby gstreamer1 \
 	gst1-plugins-base icu leveldb jpeg libpng libxml2 libxslt qt5location \
-	qt5sensors qt5webchannel sqlite webp woff2
+	openssl qt5sensors qt5webchannel sqlite webp woff2
 QT5WEBKIT_INSTALL_STAGING = YES
 
 QT5WEBKIT_LICENSE_FILES = Source/WebCore/LICENSE-LGPL-2 Source/WebCore/LICENSE-LGPL-2.1